pull in upstream rev.475 to fix format string problem in the "proxy"

debug tool, bump PKGREV
This commit is contained in:
drochner 2012-11-27 11:26:23 +00:00
parent 48aa14a093
commit 5222a04e6a
3 changed files with 23 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.14 2012/11/23 16:40:41 drochner Exp $
# $NetBSD: Makefile,v 1.15 2012/11/27 11:26:23 drochner Exp $
#
DISTNAME= libproxy-0.3.1
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= www gnome
MASTER_SITES= http://libproxy.googlecode.com/files/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2012/11/23 16:40:41 drochner Exp $
$NetBSD: distinfo,v 1.9 2012/11/27 11:26:23 drochner Exp $
SHA1 (libproxy-0.3.1.tar.bz2) = 71338ede69b4ed2b32541f7cf5285c8828ad3a8d
RMD160 (libproxy-0.3.1.tar.bz2) = 565deed81f13752f61bbff531085ef1b2c5e13d0
@ -6,3 +6,4 @@ Size (libproxy-0.3.1.tar.bz2) = 315526 bytes
SHA1 (patch-CVE-2012-4505) = ad59e5196a334d909073170bf2e56f1feca3dccf
SHA1 (patch-aa) = 08baf8aeab5a1060cc5a6fa0435199892c7a0ab6
SHA1 (patch-ab) = b2bd350d3af3274fa028612dbe6e2cb8ddd3e8bd
SHA1 (patch-ac) = 6de9bf20c6a684e0ddc300bb94944c85f057aa55

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ac,v 1.3 2012/11/27 11:26:23 drochner Exp $
see https://bugzilla.novell.com/show_bug.cgi?id=791086
--- src/bin/proxy.c.orig 2009-09-29 19:52:50.000000000 +0000
+++ src/bin/proxy.c
@@ -89,11 +89,7 @@ print_proxies(char **proxies)
{
for (int j = 0; proxies[j] ; j++)
{
- printf(proxies[j]);
- if (proxies[j+1])
- printf(" ");
- else
- printf("\n");
+ printf("%s%s", proxies[j], proxies[j+1] ? " " : "\n");
free(proxies[j]);
}
free(proxies);