Update to 0.18.4
Add LICENSE Update HOMEPAGE Upstream changes: v0.18.4 (12th April, 2018) * fix for clang6 * add better build instructions to INSTALL * add option (-v) to show version * fix minor mem leak (8 bytes per apachetop invocation) v0.17.4 (25th April, 2017) * create config.nice when running ./configure * fix error: extra qualification on member (when using adns) * fix compiler warnings * fix a potential buffer overflow v0.15.6 (10th June, 2015) * allow other time/date formats in Apache log * use sys/param.h for MAXPATHLEN * fix deprecated auto tools macros * fix compiler warnings * use silent compile rules * updated man page * change version to 0.YY.M of new release v0.12.6 (27th October, 2005) * fixed security issue which described at CVE-2005-2660
This commit is contained in:
parent
5b7fd6b928
commit
524d242749
3 changed files with 15 additions and 33 deletions
|
@ -1,18 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.20 2017/08/01 16:47:45 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.21 2018/05/08 08:17:36 wen Exp $
|
||||
#
|
||||
|
||||
DISTNAME= apachetop-0.12.5
|
||||
PKGREVISION= 4
|
||||
DISTNAME= apachetop-0.18.4
|
||||
CATEGORIES= sysutils www
|
||||
MASTER_SITES= ${MASTER_SITE_FREEBSD}
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=tessus/apachetop/archive/}
|
||||
DISTFILES= 0.18.4.zip
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
#HOMEPAGE= http://spork.qfe3.net/apachetop/
|
||||
HOMEPAGE= https://github.com/tessus/apachetop
|
||||
COMMENT= Real time apache log display
|
||||
LICENSE= modified-bsd
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS+= --with-logfile=${VARBASE}/log/httpd/access_log
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= autoconf automake
|
||||
|
||||
pre-configure:
|
||||
(cd ${WRKSRC}; ./autogen.sh)
|
||||
|
||||
.include "../../mk/curses.buildlink3.mk"
|
||||
.include "../../mk/readline.buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.5 2015/11/04 02:46:50 agc Exp $
|
||||
$NetBSD: distinfo,v 1.6 2018/05/08 08:17:36 wen Exp $
|
||||
|
||||
SHA1 (apachetop-0.12.5.tar.gz) = b41d3c68478e3cd378988834f32ce9a33975c67e
|
||||
RMD160 (apachetop-0.12.5.tar.gz) = a46fb8e850d6d98ce38aaa97fb2ea62553091ded
|
||||
SHA512 (apachetop-0.12.5.tar.gz) = 9a81aed697b81e619d68b940f1c6718fce8d5c5dd8eb401eb93aaf1846f9a12c9660cdc50a2dd7b3c7ae79494b8d70c8e79262383a5abd19a66870515ec6dbf0
|
||||
Size (apachetop-0.12.5.tar.gz) = 126967 bytes
|
||||
SHA1 (patch-aa) = eae05f08dc87ba367256d632e8b95d186955e4dc
|
||||
SHA1 (0.18.4.zip) = 911b6a9bac7d320ee1f2dc3e4a8f8afd34a97fd4
|
||||
RMD160 (0.18.4.zip) = 09f5ed68c0584d5e20deae4bf1b1831e965cb671
|
||||
SHA512 (0.18.4.zip) = 91d5cadbe5a7ffc1bdd4999e5986ab55ad770caf6f2d19811b322d9e5af42b7f40a16d4b05c05c9d1d59ac80392ca90ba03dddb2a69e08d2d8243f9ef58158b7
|
||||
Size (0.18.4.zip) = 55053 bytes
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2005/10/06 11:26:18 sketch Exp $
|
||||
|
||||
--- src/apachetop.cc.orig 2005-10-06 12:07:41.000000000 +0100
|
||||
+++ src/apachetop.cc 2005-10-06 12:10:07.000000000 +0100
|
||||
@@ -1104,8 +1104,16 @@
|
||||
{
|
||||
FILE *d;
|
||||
va_list args;
|
||||
+ static char tmpfile[1024] = {'\0'};
|
||||
|
||||
- if (cf.debug && (d = fopen(DEBUG_OUTPUT, "a")))
|
||||
+ if (!strlen(tmpfile))
|
||||
+ {
|
||||
+ strcpy(tmpfile, "/tmp/atop.XXXXXX");
|
||||
+ mkdtemp(tmpfile);
|
||||
+ strncat(tmpfile, "/debug", sizeof(tmpfile));
|
||||
+ }
|
||||
+
|
||||
+ if (cf.debug && (d = fopen(tmpfile, "a")))
|
||||
{
|
||||
va_start(args, fmt);
|
||||
vfprintf(d, fmt, args);
|
Loading…
Reference in a new issue