Inline definitions inside functions are invalid. Remove constructor that
calls non-existing parent constructor.
This commit is contained in:
parent
681628e72a
commit
5254c03e33
4 changed files with 71 additions and 1 deletions
|
@ -1,6 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.3 2011/11/24 14:18:30 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.4 2013/02/26 10:23:50 joerg Exp $
|
||||
|
||||
SHA1 (freehdl-0.0.7.tar.gz) = eca7ad3ac58e56b72842e83a0a702c05b8f86aa4
|
||||
RMD160 (freehdl-0.0.7.tar.gz) = d00e14d6b1cd97154b221717124c6e20b0d4f776
|
||||
Size (freehdl-0.0.7.tar.gz) = 1394351 bytes
|
||||
SHA1 (patch-aa) = 4c7b147c47079931506366ce50fc0eeac187fd65
|
||||
SHA1 (patch-freehdl_kernel-sig-info.hh) = 86279768c0501434951e4d9cd6b2870c09278e9b
|
||||
SHA1 (patch-freehdl_std-vhdl-types.hh) = eb5d237c9df90adf057ab9d5c650e76fe0ae5b28
|
||||
SHA1 (patch-kernel_driver__info.cc) = 7db334da74f9e5856e1dd8b3c7b627d2f3d27646
|
||||
|
|
15
cad/freehdl/patches/patch-freehdl_kernel-sig-info.hh
Normal file
15
cad/freehdl/patches/patch-freehdl_kernel-sig-info.hh
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-freehdl_kernel-sig-info.hh,v 1.1 2013/02/26 10:23:51 joerg Exp $
|
||||
|
||||
--- freehdl/kernel-sig-info.hh.orig 2013-02-25 17:49:33.000000000 +0000
|
||||
+++ freehdl/kernel-sig-info.hh
|
||||
@@ -164,10 +164,6 @@ template<class T>class sig_info : public
|
||||
type_info_interface *type, char attr, sig_info_base *base_sig,
|
||||
acl *aclp, vtime delay, void *sr) :
|
||||
sig_info_base(iname, n, sln, type, attr, base_sig, aclp, delay, sr) {};
|
||||
- /* Constructor to instantiate a guard signal */
|
||||
- sig_info(name_stack &iname, const char *n, const char *sln,
|
||||
- void *reader, void *sr) :
|
||||
- sig_info_base(iname, n, sln, reader, sr) {};
|
||||
/* Constructor to instantiate an alias signal */
|
||||
sig_info(name_stack &iname, const char *n, const char *sln,
|
||||
type_info_interface *ty, sig_info_base *aliased_sig,
|
13
cad/freehdl/patches/patch-freehdl_std-vhdl-types.hh
Normal file
13
cad/freehdl/patches/patch-freehdl_std-vhdl-types.hh
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-freehdl_std-vhdl-types.hh,v 1.1 2013/02/26 10:23:51 joerg Exp $
|
||||
|
||||
--- freehdl/std-vhdl-types.hh.orig 2013-02-25 17:33:20.000000000 +0000
|
||||
+++ freehdl/std-vhdl-types.hh
|
||||
@@ -1483,7 +1483,7 @@ A concat(array_info *ainfo, const A &a1,
|
||||
new_array.info->add_ref();
|
||||
|
||||
/* Allocate memory for the data */
|
||||
- const int mem_size = length * ainfo->element_type->size();
|
||||
+ const int mem_size = length * ainfo->element_type->size;
|
||||
new_array.data = (char*)internal_dynamic_alloc(mem_size);
|
||||
|
||||
/* Note, scalar(...) can be evaluated at compile time. */
|
39
cad/freehdl/patches/patch-kernel_driver__info.cc
Normal file
39
cad/freehdl/patches/patch-kernel_driver__info.cc
Normal file
|
@ -0,0 +1,39 @@
|
|||
$NetBSD: patch-kernel_driver__info.cc,v 1.1 2013/02/26 10:23:51 joerg Exp $
|
||||
|
||||
--- kernel/driver_info.cc.orig 2013-02-25 17:38:05.000000000 +0000
|
||||
+++ kernel/driver_info.cc
|
||||
@@ -268,6 +268,7 @@ do_scalar_inertial_assignment(driver_inf
|
||||
*************************************************************************
|
||||
*************************************************************************/
|
||||
|
||||
+inline int do_record_transport_assignment(driver_info &, const record_base &, int, const vtime &);
|
||||
|
||||
// Creates transaction composite signals. Returns number of assigned scalars.
|
||||
inline int
|
||||
@@ -311,7 +312,6 @@ do_array_transport_assignment(driver_inf
|
||||
assigned_scalars += do_array_transport_assignment(driver, (array_base&)value.data[j], i, tr_time);
|
||||
break;
|
||||
case RECORD:
|
||||
- inline int do_record_transport_assignment(driver_info &, const record_base &, int, const vtime &);
|
||||
assigned_scalars += do_record_transport_assignment(driver, (record_base&)value.data[j], i, tr_time);
|
||||
break;
|
||||
}
|
||||
@@ -338,6 +338,9 @@ driver_info::transport_assign(const arra
|
||||
}
|
||||
|
||||
|
||||
+inline int do_record_inertial_assignment(driver_info &, const record_base &, int,
|
||||
+ const vtime &, const vtime &);
|
||||
+
|
||||
// Creates transaction for composite signals. Returns number of assigned scalars.
|
||||
inline int
|
||||
do_array_inertial_assignment(driver_info &driver,
|
||||
@@ -381,8 +384,6 @@ do_array_inertial_assignment(driver_info
|
||||
assigned_scalars += do_array_inertial_assignment(driver, (array_base&)value.data[j], i, tr_time, rm_time);
|
||||
break;
|
||||
case RECORD:
|
||||
- inline int do_record_inertial_assignment(driver_info &, const record_base &, int,
|
||||
- const vtime &, const vtime &);
|
||||
assigned_scalars += do_record_inertial_assignment(driver, (record_base&)value.data[j], i, tr_time, rm_time);
|
||||
break;
|
||||
}
|
Loading…
Reference in a new issue