Don't use ((command)), use ( (command)) instead. Fixes some build breakage.
This commit is contained in:
parent
b310e96b20
commit
5256eea097
5 changed files with 149 additions and 1 deletions
|
@ -1,5 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.37 2008/08/27 12:23:15 markd Exp $
|
||||
$NetBSD: distinfo,v 1.38 2011/11/29 15:30:27 hans Exp $
|
||||
|
||||
SHA1 (kdegames-3.5.10.tar.bz2) = 287aa0d1ae19b8f04d64c4449fed6a7cec58844d
|
||||
RMD160 (kdegames-3.5.10.tar.bz2) = a185104b0048b0554f4638b482e69455eb10daa5
|
||||
Size (kdegames-3.5.10.tar.bz2) = 10783059 bytes
|
||||
SHA1 (patch-kfouleggs_Makefile.in) = 53fc5088a5f6221f17f766fd37095950643da7e3
|
||||
SHA1 (patch-klickety_Makefile.in) = eac00e6ac57e5e6c0a5fadb5cb2d03e72f263a4d
|
||||
SHA1 (patch-kmines_Makefile.in) = 279c24b558b48323a25ff1e4e50d2b942b96b1b2
|
||||
SHA1 (patch-ksirtet_ksirtet_Makefile.in) = cc9b7c9bba6039d5d5291e6e53c7afdf289b36b9
|
||||
|
|
36
games/kdegames3/patches/patch-kfouleggs_Makefile.in
Normal file
36
games/kdegames3/patches/patch-kfouleggs_Makefile.in
Normal file
|
@ -0,0 +1,36 @@
|
|||
--- kfouleggs/Makefile.in.orig 2008-08-20 17:43:05.000000000 +0200
|
||||
+++ kfouleggs/Makefile.in 2011-11-02 12:57:01.562496478 +0100
|
||||
@@ -905,28 +905,28 @@ install-data-local:
|
||||
|
||||
install-exec-hook:
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
+ && ( (chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
|
||||
+ && ( (mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
|
||||
&& chmod 750 $(DESTHIGHSCORES)) \
|
||||
|| echo "Error: Could not create the highscore directory with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
+ && ( (chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test ${setgid} = true \
|
||||
- && ((chmod 2755 $(DESTBIN)) \
|
||||
+ && ( (chmod 2755 $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
|
||||
+ && ( (touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
|
||||
&& chmod 0660 $(DESTSCORES)) \
|
||||
|| echo "Error: Could not create system-wide highscore file with correct permissions !!" \
|
||||
)) || true
|
36
games/kdegames3/patches/patch-klickety_Makefile.in
Normal file
36
games/kdegames3/patches/patch-klickety_Makefile.in
Normal file
|
@ -0,0 +1,36 @@
|
|||
--- klickety/Makefile.in.orig 2008-08-20 17:43:06.000000000 +0200
|
||||
+++ klickety/Makefile.in 2011-11-02 12:57:45.964380911 +0100
|
||||
@@ -881,28 +881,28 @@ install-data-local:
|
||||
|
||||
install-exec-hook:
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
+ && ( (chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
|
||||
+ && ( (mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
|
||||
&& chmod 750 $(DESTHIGHSCORES)) \
|
||||
|| echo "Error: Could not create the highscore directory with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
+ && ( (chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test ${setgid} = true \
|
||||
- && ((chmod 2755 $(DESTBIN)) \
|
||||
+ && ( (chmod 2755 $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
|
||||
+ && ( (touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
|
||||
&& chmod 0660 $(DESTSCORES)) \
|
||||
|| echo "Error: Could not create system-wide highscore file with correct permissions !!" \
|
||||
)) || true
|
36
games/kdegames3/patches/patch-kmines_Makefile.in
Normal file
36
games/kdegames3/patches/patch-kmines_Makefile.in
Normal file
|
@ -0,0 +1,36 @@
|
|||
--- kmines/Makefile.in.orig 2008-08-20 17:43:06.000000000 +0200
|
||||
+++ kmines/Makefile.in 2011-11-02 12:54:17.713830056 +0100
|
||||
@@ -849,28 +849,28 @@ install-data-local:
|
||||
|
||||
install-exec-hook:
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
+ && ( (chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
|
||||
+ && ( (mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
|
||||
&& chmod 750 $(DESTHIGHSCORES)) \
|
||||
|| echo "Error: Could not create the highscore directory with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
+ && ( (chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test ${setgid} = true \
|
||||
- && ((chmod 2755 $(DESTBIN)) \
|
||||
+ && ( (chmod 2755 $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
|
||||
+ && ( (touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
|
||||
&& chmod 0660 $(DESTSCORES)) \
|
||||
|| echo "Error: Could not create system-wide highscore file with correct permissions !!" \
|
||||
)) || true
|
36
games/kdegames3/patches/patch-ksirtet_ksirtet_Makefile.in
Normal file
36
games/kdegames3/patches/patch-ksirtet_ksirtet_Makefile.in
Normal file
|
@ -0,0 +1,36 @@
|
|||
--- ksirtet/ksirtet/Makefile.in.orig 2008-08-20 17:43:06.000000000 +0200
|
||||
+++ ksirtet/ksirtet/Makefile.in 2011-11-02 12:56:14.974702886 +0100
|
||||
@@ -820,28 +820,28 @@ install-data-local:
|
||||
|
||||
install-exec-hook:
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
+ && ( (chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
|
||||
+ && ( (mkdir -p $(DESTHIGHSCORES) && chown $(highscore_user):$(highscore_group) $(DESTHIGHSCORES) \
|
||||
&& chmod 750 $(DESTHIGHSCORES)) \
|
||||
|| echo "Error: Could not create the highscore directory with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
+ && ( (chown $(highscore_user):$(highscore_group) $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test ${setgid} = true \
|
||||
- && ((chmod 2755 $(DESTBIN)) \
|
||||
+ && ( (chmod 2755 $(DESTBIN)) \
|
||||
|| echo "Error: Could not install the game with correct permissions !!" \
|
||||
)) || true
|
||||
|
||||
@(test x$(HIGHSCORE_DIRECTORY) != x \
|
||||
- && ((touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
|
||||
+ && ( (touch $(DESTSCORES) && chown $(highscore_user):$(highscore_group) $(DESTSCORES) \
|
||||
&& chmod 0660 $(DESTSCORES)) \
|
||||
|| echo "Error: Could not create system-wide highscore file with correct permissions !!" \
|
||||
)) || true
|
Loading…
Reference in a new issue