Update to 2.11.9.2:

Fixed calc man page examples to move -f to the end of the line.
    Thanks goes to Michael Somos <somos at grail dot cba dot csuohio
    dot edu> for pointing this out.

    Linux and gcc now compiled with -Wall -W -Wno-comment.

    Fixed a post increment that was reported by R. Trinler <trinler at
    web dot de> and fixed by Ernest Bowen <ernie at turing dot une dot
    edu dot au>.

    Fixed pi.cal to not depend on the buggy pre-2.11.9 post increment
    behavior.

    Added config("cygwin") to determine if calc was compiled under Cygwin.
    The config("cygwin") is a read-only configuration value that is 1
    when calc was compiled under Cygwin and 0 otherwise.  Regression
    tests 949 and 950 are skipped when config("cygwin") is true.

    The Makefile variable HAVE_NO_IMPLICIT is empty by default so that
    the Makefile will test if the compiler has a -Wno-implicit flag.

    Added HAVE_UNUSED Makefile variable.  If HAVE_UNUSED is empty,
    then the Makefile will run the have_unused program to determine
    if the unused attribute is supported.  If HAVE_UNUSED is set to
    -DHAVE_NO_UNUSED, then the unused attribute will not be used.

    The Makefile builds have_unused.h which defines, if the unused
    attribute is supported:

	#define HAVE_UNUSED /* yes */
	#define UNUSED __attribute__((unused)) /* yes */

    or defines, if the unused is not supported (or if the Makefile
    variable is HAVE_UNUSED= -DHAVE_NO_UNUSED):

	#undef HAVE_UNUSED /* no */
	#define UNUSED /* no */

    Fixed numerous warnings about comparison between signed and unsigned
    value warnings and unused parameter warnings in version.c, zrand.c,
    string.c, shs1.c, shs.c, qtrans.c, qmath.c, qfunc.c, md5.c, matfunc.c,
    hist.c, file.c, const.c, blkcpy.c, seed.c, opcodes.c, func.c, qio.c,
    zrandom.c, custom/c_argv.c, custom/c_devnull.c, custom/c_help.c,
    custom/c_sysinfo.c, addop.c and calc.c.

    Fixed some typos in this file.

    By default, compile with -O3 -g3.  The Makefile comments on how some
    distributions might need to use -O2 -g or -O -g.
This commit is contained in:
wiz 2004-03-10 18:17:11 +00:00
parent 84ca498c40
commit 526430a3ad
4 changed files with 30 additions and 29 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.19 2003/09/28 09:13:58 jlam Exp $
# $NetBSD: Makefile,v 1.20 2004/03/10 18:17:11 wiz Exp $
#
DISTNAME= calc-2.11.8
DISTNAME= calc-2.11.9.2
PKGNAME= capc-${DISTNAME:S/t/./}
CATEGORIES= math
MASTER_SITES= http://www.isthe.com/chongo/src/calc/ \
@ -11,8 +11,8 @@ MAINTAINER= wiz@NetBSD.org
HOMEPAGE= http://www.isthe.com/chongo/tech/comp/calc/
COMMENT= C arbitrary precision calculator
USE_BUILDLINK2= # defined
USE_BUILDLINK3= # defined
.include "../../devel/ncurses/buildlink2.mk"
.include "../../devel/readline/buildlink2.mk"
.include "../../devel/ncurses/buildlink3.mk"
.include "../../devel/readline/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2003/01/16 15:40:12 wiz Exp $
@comment $NetBSD: PLIST,v 1.4 2004/03/10 18:17:11 wiz Exp $
bin/calc
bin/cscript/4dsphere
bin/cscript/fproduct
@ -44,6 +44,7 @@ include/calc/have_string.h
include/calc/have_times.h
include/calc/have_uid_t.h
include/calc/have_unistd.h
include/calc/have_unused.h
include/calc/have_urandom.h
include/calc/have_ustat.h
include/calc/hist.h

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.8 2003/08/30 23:27:30 wiz Exp $
$NetBSD: distinfo,v 1.9 2004/03/10 18:17:11 wiz Exp $
SHA1 (calc-2.11.8.tar.gz) = d90a9de8346346a5dd25ed19c3cc7e86c6b6a645
Size (calc-2.11.8.tar.gz) = 956819 bytes
SHA1 (patch-aa) = 7ca5ffdb73cf05ec5ceb76c7d529c8f2112ea923
SHA1 (calc-2.11.9.2.tar.gz) = b7fc42c53e140159b753688373ed17c18d49cd59
Size (calc-2.11.9.2.tar.gz) = 959025 bytes
SHA1 (patch-aa) = 55ac789f43cb8616a0b8917de707c6ff8f3520ea

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
$NetBSD: patch-aa,v 1.4 2004/03/10 18:17:11 wiz Exp $
--- Makefile.orig Sun Dec 29 08:14:00 2002
--- Makefile.orig 2004-02-23 11:57:13.000000000 +0100
+++ Makefile
@@ -556,7 +556,7 @@ HAVE_UNISTD_H=
@@ -594,7 +594,7 @@ HAVE_UNUSED=
#INCDIR= /usr/local/include
#INCDIR= /dev/env/DJDIR/include
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
# Where to install calc realted things
#
@@ -583,15 +583,15 @@ INCDIR= /usr/include
@@ -621,15 +621,15 @@ INCDIR= /usr/include
#
#BINDIR= /usr/local/bin
#BINDIR= /dev/env/DJDIR/bin
@ -30,7 +30,7 @@ $NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
#CALC_INCDIR= /usr/local/include/calc
#CALC_INCDIR= /dev/env/DJDIR/include/calc
@@ -665,7 +665,7 @@ T=
@@ -703,7 +703,7 @@ T=
#MANDIR=
#MANDIR= /usr/local/man/man1
#MANDIR= /usr/man/man1
@ -39,7 +39,7 @@ $NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
#MANDIR= /dev/env/DJDIR/man/man1
#MANDIR= /usr/man/u_man/man1
#MANDIR= /usr/contrib/man/man1
@@ -676,7 +676,7 @@ MANDIR= /usr/share/man/man1
@@ -714,7 +714,7 @@ MANDIR= /usr/share/man/man1
#
# Use CATDIR= to disable installation of the calc cat (formatted) page.
#
@ -48,7 +48,7 @@ $NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
#CATDIR= /usr/local/man/cat1
#CATDIR= /usr/local/catman/cat1
#CATDIR= /usr/man/cat1
@@ -697,9 +697,9 @@ MANEXT= 1
@@ -735,9 +735,9 @@ MANEXT= 1
#
# This is ignored if CATDIR is empty.
#
@ -60,7 +60,7 @@ $NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
#CATEXT= l
# how to format a man page
@@ -725,8 +725,8 @@ CATEXT= 1
@@ -763,8 +763,8 @@ CATEXT= 1
# and CATDIR to empty and ignore the NROFF, NROFF_ARG and MANMAKE
# lines below.
#
@ -71,7 +71,7 @@ $NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
#NROFF= groff
NROFF_ARG= -man
#NROFF_ARG= -mandoc
@@ -770,10 +770,10 @@ CALCRC= ${CALC_SHAREDIR}/startup:~/.calc
@@ -808,10 +808,10 @@ CALCRC= ${CALC_SHAREDIR}/startup:~/.calc
#
# If in doubt, set USE_READLINE, READLINE_LIB and READLINE_INCLUDE to nothing.
#
@ -85,7 +85,7 @@ $NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
#READLINE_LIB= -lreadline -lhistory -lncurses
#READLINE_LIB= -L/usr/gnu/lib -lreadline -lhistory -lncurses
#READLINE_LIB= -L/usr/local/lib -lreadline -lhistory -lncurses
@@ -786,10 +786,10 @@ READLINE_INCLUDE=
@@ -824,10 +824,10 @@ READLINE_INCLUDE=
#
# Select CALCPAGER= less.exe -ci for DJGPP.
#
@ -98,16 +98,16 @@ $NetBSD: patch-aa,v 1.3 2003/01/03 20:35:29 wiz Exp $
#CALCPAGER= less.exe -ci
# Debug/Optimize options for ${CC} and ${LCC}
@@ -807,7 +807,7 @@ CALCPAGER= more
#DEBUG= -O1 -g3
@@ -852,7 +852,7 @@ CALCPAGER= more
#
#DEBUG= -O2
-DEBUG= -O2 -g
+#DEBUG= -O2 -g
#DEBUG= -O2 -g3
#DEBUG= -O2 -ipa
#DEBUG= -O2 -g3 -ipa
@@ -959,10 +959,10 @@ CCWARN= -Wall -Wno-implicit -Wno-comment
#DEBUG= -O3
#DEBUG= -O3 -g
-DEBUG= -O3 -g3
+#DEBUG= -O3 -g3
#DEBUG= -O3 -ipa
#DEBUG= -O3 -g3 -ipa
#
@@ -1008,10 +1008,10 @@ CCWARN= -Wall -W -Wno-comment
CCOPT= ${DEBUG} ${NO_SHARED}
CCMISC=
#