Import scim-python-0.1.13rc1nb1 as inputmethod/scim-python.
Python wrapper for Smart Common Input Method platform.
This commit is contained in:
parent
43be323160
commit
526c704d4f
8 changed files with 305 additions and 0 deletions
1
inputmethod/scim-python/DESCR
Normal file
1
inputmethod/scim-python/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
Python wrapper for Smart Common Input Method platform.
|
42
inputmethod/scim-python/Makefile
Normal file
42
inputmethod/scim-python/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/08/08 01:05:04 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= scim-python-0.1.13rc1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= inputmethod python
|
||||
MASTER_SITES= http://scim-python.googlecode.com/files/
|
||||
DISTFILES= ${DEFAULT_DISTFILES} ${DBTAR}
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://code.google.com/p/scim-python/
|
||||
COMMENT= Python wrapper for Smart Common Input Method platform
|
||||
LICENSE= gnu-lgpl-v2 AND gnu-gpl-v2
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-sqlite3-[0-9]*:../../databases/py-sqlite3
|
||||
DEPENDS+= ${PYPKGPREFIX}-enchant-[0-9]*:../../textproc/py-enchant
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_PKGLOCALEDIR= yes
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= pkg-config msgfmt
|
||||
|
||||
# taken from ${WRKSRC}/python/engine/PinYin/Makefile.in
|
||||
DBVER= 0.1.10.5
|
||||
DBTAR= pinyin-database-${DBVER}.tar.bz2
|
||||
|
||||
post-extract:
|
||||
${TOUCH} ${WRKSRC}/python/engine/PinYin/${DBTAR}
|
||||
${CP} ${WRKDIR}/py.db ${WRKSRC}/python/engine/PinYin/py.db
|
||||
|
||||
PY_PATCHPLIST= yes
|
||||
|
||||
REPLACE_PYTHON+= python/engine/XingMa/XMCreateDB.py
|
||||
|
||||
.include "../../inputmethod/scim/buildlink3.mk"
|
||||
.include "../../x11/py-gtk2/buildlink3.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
128
inputmethod/scim-python/PLIST
Normal file
128
inputmethod/scim-python/PLIST
Normal file
|
@ -0,0 +1,128 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/08/08 01:05:04 obache Exp $
|
||||
bin/XMCreateDB
|
||||
${PYSITELIB}/scim-0.1/scim/KeyCode.py
|
||||
${PYSITELIB}/scim-0.1/scim/KeyCode.pyc
|
||||
${PYSITELIB}/scim-0.1/scim/KeyCode.pyo
|
||||
${PYSITELIB}/scim-0.1/scim/KeyMask.py
|
||||
${PYSITELIB}/scim-0.1/scim/KeyMask.pyc
|
||||
${PYSITELIB}/scim-0.1/scim/KeyMask.pyo
|
||||
${PYSITELIB}/scim-0.1/scim/Log.py
|
||||
${PYSITELIB}/scim-0.1/scim/Log.pyc
|
||||
${PYSITELIB}/scim-0.1/scim/Log.pyo
|
||||
${PYSITELIB}/scim-0.1/scim/SCTC.py
|
||||
${PYSITELIB}/scim-0.1/scim/SCTC.pyc
|
||||
${PYSITELIB}/scim-0.1/scim/SCTC.pyo
|
||||
${PYSITELIB}/scim-0.1/scim/Utility.py
|
||||
${PYSITELIB}/scim-0.1/scim/Utility.pyc
|
||||
${PYSITELIB}/scim-0.1/scim/Utility.pyo
|
||||
${PYSITELIB}/scim-0.1/scim/__init__.py
|
||||
${PYSITELIB}/scim-0.1/scim/__init__.pyc
|
||||
${PYSITELIB}/scim-0.1/scim/__init__.pyo
|
||||
${PYSITELIB}/scim-0.1/scim/_scim.la
|
||||
${PYSITELIB}/scim-0.1/scim/ascii.py
|
||||
${PYSITELIB}/scim-0.1/scim/ascii.pyc
|
||||
${PYSITELIB}/scim-0.1/scim/ascii.pyo
|
||||
${PYSITELIB}/scim.pth
|
||||
lib/scim-1.0/1.4.0/Helper/python.so
|
||||
lib/scim-1.0/1.4.0/IMEngine/python.so
|
||||
lib/scim-1.0/1.4.0/SetupUI/python.so
|
||||
share/locale/nl/LC_MESSAGES/scim-python.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/scim-python.mo
|
||||
share/scim-python/data/pinyin_table.txt
|
||||
share/scim-python/engine/EnglishWriter/English.py
|
||||
share/scim-python/engine/EnglishWriter/English.pyc
|
||||
share/scim-python/engine/EnglishWriter/English.pyo
|
||||
share/scim-python/engine/EnglishWriter/__init__.py
|
||||
share/scim-python/engine/EnglishWriter/__init__.pyc
|
||||
share/scim-python/engine/EnglishWriter/__init__.pyo
|
||||
share/scim-python/engine/PinYin/JianPin.py
|
||||
share/scim-python/engine/PinYin/JianPin.pyc
|
||||
share/scim-python/engine/PinYin/JianPin.pyo
|
||||
share/scim-python/engine/PinYin/PYCreatePinYinDB.py
|
||||
share/scim-python/engine/PinYin/PYCreatePinYinDB.pyc
|
||||
share/scim-python/engine/PinYin/PYCreatePinYinDB.pyo
|
||||
share/scim-python/engine/PinYin/PYDict.py
|
||||
share/scim-python/engine/PinYin/PYDict.pyc
|
||||
share/scim-python/engine/PinYin/PYDict.pyo
|
||||
share/scim-python/engine/PinYin/PYParser.py
|
||||
share/scim-python/engine/PinYin/PYParser.pyc
|
||||
share/scim-python/engine/PinYin/PYParser.pyo
|
||||
share/scim-python/engine/PinYin/PYSQLiteDB.py
|
||||
share/scim-python/engine/PinYin/PYSQLiteDB.pyc
|
||||
share/scim-python/engine/PinYin/PYSQLiteDB.pyo
|
||||
share/scim-python/engine/PinYin/PYUtil.py
|
||||
share/scim-python/engine/PinYin/PYUtil.pyc
|
||||
share/scim-python/engine/PinYin/PYUtil.pyo
|
||||
share/scim-python/engine/PinYin/PinYin.py
|
||||
share/scim-python/engine/PinYin/PinYin.pyc
|
||||
share/scim-python/engine/PinYin/PinYin.pyo
|
||||
share/scim-python/engine/PinYin/QuanPin.py
|
||||
share/scim-python/engine/PinYin/QuanPin.pyc
|
||||
share/scim-python/engine/PinYin/QuanPin.pyo
|
||||
share/scim-python/engine/PinYin/ShuangPin.py
|
||||
share/scim-python/engine/PinYin/ShuangPin.pyc
|
||||
share/scim-python/engine/PinYin/ShuangPin.pyo
|
||||
share/scim-python/engine/PinYin/SpecialPhrase.py
|
||||
share/scim-python/engine/PinYin/SpecialPhrase.pyc
|
||||
share/scim-python/engine/PinYin/SpecialPhrase.pyo
|
||||
share/scim-python/engine/PinYin/SpecialTable.py
|
||||
share/scim-python/engine/PinYin/SpecialTable.pyc
|
||||
share/scim-python/engine/PinYin/SpecialTable.pyo
|
||||
share/scim-python/engine/PinYin/ZhengJu.py
|
||||
share/scim-python/engine/PinYin/ZhengJu.pyc
|
||||
share/scim-python/engine/PinYin/ZhengJu.pyo
|
||||
share/scim-python/engine/PinYin/ZhengJuDB.py
|
||||
share/scim-python/engine/PinYin/ZhengJuDB.pyc
|
||||
share/scim-python/engine/PinYin/ZhengJuDB.pyo
|
||||
share/scim-python/engine/PinYin/__init__.py
|
||||
share/scim-python/engine/PinYin/__init__.pyc
|
||||
share/scim-python/engine/PinYin/__init__.pyo
|
||||
share/scim-python/engine/PinYin/py.db
|
||||
share/scim-python/engine/PinYin/special_phrase
|
||||
share/scim-python/engine/PinYin/special_table
|
||||
share/scim-python/engine/XingMa/XMCreateDB.py
|
||||
share/scim-python/engine/XingMa/XMDict.py
|
||||
share/scim-python/engine/XingMa/XMDict.pyc
|
||||
share/scim-python/engine/XingMa/XMDict.pyo
|
||||
share/scim-python/engine/XingMa/XMSQLiteDB.py
|
||||
share/scim-python/engine/XingMa/XMSQLiteDB.pyc
|
||||
share/scim-python/engine/XingMa/XMSQLiteDB.pyo
|
||||
share/scim-python/engine/XingMa/XingMa.py
|
||||
share/scim-python/engine/XingMa/XingMa.pyc
|
||||
share/scim-python/engine/XingMa/XingMa.pyo
|
||||
share/scim-python/engine/XingMa/__init__.py
|
||||
share/scim-python/engine/XingMa/__init__.pyc
|
||||
share/scim-python/engine/XingMa/__init__.pyo
|
||||
share/scim-python/engine/XingMa/tables/.keep
|
||||
share/scim-python/engine/__init__.py
|
||||
share/scim-python/engine/__init__.pyc
|
||||
share/scim-python/engine/__init__.pyo
|
||||
share/scim-python/helper/PinYinSetup/SetupUI.glade
|
||||
share/scim-python/helper/PinYinSetup/SetupUI.py
|
||||
share/scim-python/helper/PinYinSetup/SetupUI.pyc
|
||||
share/scim-python/helper/PinYinSetup/SetupUI.pyo
|
||||
share/scim-python/helper/PinYinSetup/__init__.py
|
||||
share/scim-python/helper/PinYinSetup/__init__.pyc
|
||||
share/scim-python/helper/PinYinSetup/__init__.pyo
|
||||
share/scim-python/helper/ZhengJuSetup/ZhengJuUI.glade
|
||||
share/scim-python/helper/ZhengJuSetup/ZhengJuUI.py
|
||||
share/scim-python/helper/ZhengJuSetup/ZhengJuUI.pyc
|
||||
share/scim-python/helper/ZhengJuSetup/ZhengJuUI.pyo
|
||||
share/scim-python/helper/ZhengJuSetup/__init__.py
|
||||
share/scim-python/helper/ZhengJuSetup/__init__.pyc
|
||||
share/scim-python/helper/ZhengJuSetup/__init__.pyo
|
||||
share/scim-python/helper/__init__.py
|
||||
share/scim-python/helper/__init__.pyc
|
||||
share/scim-python/helper/__init__.pyo
|
||||
share/scim-python/setupui/EnglishWriter/English.py
|
||||
share/scim-python/setupui/EnglishWriter/English.pyc
|
||||
share/scim-python/setupui/EnglishWriter/English.pyo
|
||||
share/scim-python/setupui/EnglishWriter/__init__.py
|
||||
share/scim-python/setupui/EnglishWriter/__init__.pyc
|
||||
share/scim-python/setupui/EnglishWriter/__init__.pyo
|
||||
share/scim-python/setupui/__init__.py
|
||||
share/scim-python/setupui/__init__.pyc
|
||||
share/scim-python/setupui/__init__.pyo
|
||||
share/scim/icons/py-mode.png
|
||||
share/scim/icons/scim-python.png
|
||||
share/scim/icons/xm-mode.png
|
12
inputmethod/scim-python/distinfo
Normal file
12
inputmethod/scim-python/distinfo
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/08/08 01:05:04 obache Exp $
|
||||
|
||||
SHA1 (pinyin-database-0.1.10.5.tar.bz2) = d0bb78416431a59cbcaf62809e56fab284f6d588
|
||||
RMD160 (pinyin-database-0.1.10.5.tar.bz2) = 3acfa16d11b2099d7719f3b7b5a77c523b982d2d
|
||||
Size (pinyin-database-0.1.10.5.tar.bz2) = 12044655 bytes
|
||||
SHA1 (scim-python-0.1.13rc1.tar.gz) = 93343522a5f50fc1f68fd29e76e276036a77e965
|
||||
RMD160 (scim-python-0.1.13rc1.tar.gz) = 1a47d4f7d2be5d171d23f040748299b6e0c1dce4
|
||||
Size (scim-python-0.1.13rc1.tar.gz) = 715364 bytes
|
||||
SHA1 (patch-aa) = b576047a60704b19db91792fcdbe4e1e8515be26
|
||||
SHA1 (patch-ab) = 4505e5d93f2b44d46560f9d04fa769038bea8956
|
||||
SHA1 (patch-ac) = e3b795ee4b218d8c1bb0e57cfbc2ec879f9bc840
|
||||
SHA1 (patch-ad) = 9fbfb2bb233a0779d0b4cef7dff476956757a5f2
|
42
inputmethod/scim-python/patches/patch-aa
Normal file
42
inputmethod/scim-python/patches/patch-aa
Normal file
|
@ -0,0 +1,42 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/08/08 01:05:04 obache Exp $
|
||||
|
||||
portability fix.
|
||||
|
||||
--- configure.orig 2008-07-11 04:17:12.000000000 +0000
|
||||
+++ configure
|
||||
@@ -20602,7 +20602,7 @@ fi
|
||||
|
||||
|
||||
# define PYTHOPN_CFLAGS & PYTHON_LIBS
|
||||
-PYTHON_CONFIG=`type -p python$PYTHON_VERSION-config`
|
||||
+PYTHON_CONFIG="python$PYTHON_VERSION-config"
|
||||
if test "$PYTHON_CONFIG" != ""; then
|
||||
PYTHON_CFLAGS=`$PYTHON_CONFIG --includes`
|
||||
PYTHON_LIBS=`$PYTHON_CONFIG --libs`
|
||||
@@ -20660,7 +20660,7 @@ if test "${enable_english_writer+set}" =
|
||||
fi
|
||||
|
||||
|
||||
-if test "$enable_english_writer" == "force"; then
|
||||
+if test "$enable_english_writer" = "force"; then
|
||||
if true; then
|
||||
ENABLE_ENGLISH_WRITER_TRUE=
|
||||
ENABLE_ENGLISH_WRITER_FALSE='#'
|
||||
@@ -20669,7 +20669,7 @@ else
|
||||
ENABLE_ENGLISH_WRITER_FALSE=
|
||||
fi
|
||||
|
||||
-elif test "$enable_english_writer" == "no"; then
|
||||
+elif test "$enable_english_writer" = "no"; then
|
||||
if false; then
|
||||
ENABLE_ENGLISH_WRITER_TRUE=
|
||||
ENABLE_ENGLISH_WRITER_FALSE='#'
|
||||
@@ -20679,7 +20679,7 @@ else
|
||||
fi
|
||||
|
||||
else
|
||||
- if test "$have_python_enchant" == "no"; then
|
||||
+ if test "$have_python_enchant" = "no"; then
|
||||
{ { echo "$as_me:$LINENO: error:
|
||||
Your system does not have python-enchant, please install it or run \"./configure --disable-english-writer\".
|
||||
You may also use \"./configure --enable-english-writer=force\" to foce build this english engine." >&5
|
33
inputmethod/scim-python/patches/patch-ab
Normal file
33
inputmethod/scim-python/patches/patch-ab
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2010/08/08 01:05:04 obache Exp $
|
||||
|
||||
remove unwanted cast.
|
||||
|
||||
--- src/scim-python-engine.cpp.orig 2008-07-11 04:16:15.000000000 +0000
|
||||
+++ src/scim-python-engine.cpp
|
||||
@@ -621,7 +621,7 @@ PyIMEngine::py_update_preedit_string (Py
|
||||
|
||||
unistr = g_utf16_to_ucs4 (str, size, NULL, NULL, NULL);
|
||||
|
||||
- self->engine.update_preedit_string (WideString ((wchar_t *)unistr),
|
||||
+ self->engine.update_preedit_string (WideString (unistr),
|
||||
Attributes_FromTupleOrList (pAttrs));
|
||||
g_free (unistr);
|
||||
|
||||
@@ -659,7 +659,7 @@ PyIMEngine::py_update_aux_string (PyIMEn
|
||||
return NULL;
|
||||
|
||||
unistr = g_utf16_to_ucs4 (str, size, NULL, NULL, NULL);
|
||||
- self->engine.update_aux_string (WideString ((wchar_t *)unistr),
|
||||
+ self->engine.update_aux_string (WideString (unistr),
|
||||
Attributes_FromTupleOrList (pAttrs));
|
||||
g_free (unistr);
|
||||
#endif
|
||||
@@ -713,7 +713,7 @@ PyIMEngine::py_commit_string (PyIMEngine
|
||||
return NULL;
|
||||
|
||||
unistr = g_utf16_to_ucs4 (str, size, NULL, NULL, NULL);
|
||||
- self->engine.commit_string (WideString ((wchar_t *)unistr));
|
||||
+ self->engine.commit_string (WideString (unistr));
|
||||
g_free (unistr);
|
||||
#endif
|
||||
|
23
inputmethod/scim-python/patches/patch-ac
Normal file
23
inputmethod/scim-python/patches/patch-ac
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2010/08/08 01:05:04 obache Exp $
|
||||
|
||||
add wanted convert.
|
||||
|
||||
--- src/scim-python-factory.cpp.orig 2008-07-11 04:16:15.000000000 +0000
|
||||
+++ src/scim-python-factory.cpp
|
||||
@@ -134,14 +134,14 @@ PyIMEngineFactory::get_attr_unicode (cha
|
||||
#else
|
||||
gunichar *unistr = g_utf16_to_ucs4 (PyUnicode_AS_UNICODE (pValue),
|
||||
PyUnicode_GET_SIZE (pValue), NULL, NULL, NULL);
|
||||
- result = (wchar_t *) unistr;
|
||||
+ result = WideString(unistr);
|
||||
g_free (unistr);
|
||||
#endif
|
||||
}
|
||||
else if (PyString_Check (pValue)) {
|
||||
gunichar *unistr = g_utf8_to_ucs4 (PyString_AsString (pValue),
|
||||
PyString_GET_SIZE (pValue), NULL, NULL, NULL);
|
||||
- result = (wchar_t *)unistr;
|
||||
+ result = WideString(unistr);
|
||||
g_free (unistr);
|
||||
}
|
||||
Py_DECREF (pValue);
|
24
inputmethod/scim-python/patches/patch-ad
Normal file
24
inputmethod/scim-python/patches/patch-ad
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2010/08/08 01:05:04 obache Exp $
|
||||
|
||||
remove unwanted cast.
|
||||
|
||||
--- src/scim-python-lookup-table.cpp.orig 2008-07-11 04:16:15.000000000 +0000
|
||||
+++ src/scim-python-lookup-table.cpp
|
||||
@@ -86,7 +86,7 @@ PyLookupTable::py_set_candidate_labels (
|
||||
#else
|
||||
int usize = PyUnicode_GET_SIZE (items[i]);
|
||||
gunichar *unistr = g_utf16_to_ucs4 (PyUnicode_AS_UNICODE (items[i]), usize, NULL, NULL, NULL);
|
||||
- _labels.push_back (WideString ((wchar_t *)unistr));
|
||||
+ _labels.push_back (WideString (unistr));
|
||||
g_free (unistr);
|
||||
#endif
|
||||
}
|
||||
@@ -518,7 +518,7 @@ PyLookupTable::py_append_candidate (PyLo
|
||||
return NULL;
|
||||
unistr = g_utf16_to_ucs4 (candidate, size, NULL, NULL, NULL);
|
||||
|
||||
- if (self->lookup_table.append_candidate (WideString ((wchar_t *)unistr),
|
||||
+ if (self->lookup_table.append_candidate (WideString (unistr),
|
||||
Attributes_FromTupleOrList (pAttrs)))
|
||||
{
|
||||
result = Py_True;
|
Loading…
Reference in a new issue