Fix DragonFly support.
This commit is contained in:
parent
05ae4d41ee
commit
5347a4c764
3 changed files with 40 additions and 1 deletions
|
@ -1,8 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.8 2007/07/12 19:48:41 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.9 2007/09/16 09:25:03 joerg Exp $
|
||||
|
||||
SHA1 (plib-1.8.4.tar.gz) = 16d3faab36fdde85c5bf620046b56c65dfad6769
|
||||
RMD160 (plib-1.8.4.tar.gz) = a0b6f2fdd4035cb2a6b83616726563d779efb87f
|
||||
Size (plib-1.8.4.tar.gz) = 793758 bytes
|
||||
SHA1 (patch-aa) = 87f53811b33d3dbf7ea4cd12fcc0dd594847eeb2
|
||||
SHA1 (patch-ab) = 3976dcf78e8ba44d55d08e67ddf3fa7f23def91e
|
||||
SHA1 (patch-ad) = 1ec59b079a662bfc9b5ea5fa03686292ac05659f
|
||||
SHA1 (patch-ae) = ae69e86642c53ef32619d6411809f80ab973b208
|
||||
SHA1 (patch-af) = 2eac06fa7462711c018c2b5876b218ef56b46dbb
|
||||
|
|
24
games/plib/patches/patch-aa
Normal file
24
games/plib/patches/patch-aa
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-aa,v 1.6 2007/09/16 09:25:03 joerg Exp $
|
||||
|
||||
--- src/sl/slPortability.h.orig 2007-09-16 08:50:46.000000000 +0000
|
||||
+++ src/sl/slPortability.h
|
||||
@@ -59,8 +59,8 @@
|
||||
# if defined(UL_LINUX)
|
||||
# include <linux/soundcard.h>
|
||||
# include <sys/ioctl.h>
|
||||
-# elif defined(__FreeBSD__)
|
||||
-# include <machine/soundcard.h>
|
||||
+# elif defined(__FreeBSD__) || defined(__DragonFly__)
|
||||
+# include <sys/soundcard.h>
|
||||
# else
|
||||
/*
|
||||
Tom thinks this file may be <sys/soundcard.h> under some
|
||||
@@ -75,7 +75,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef UL_BSD
|
||||
-#ifndef __FreeBSD__
|
||||
+#if !defined(__FreeBSD__) && !defined(__DragonFly__)
|
||||
# include <sys/audioio.h>
|
||||
#endif
|
||||
#endif
|
13
games/plib/patches/patch-ab
Normal file
13
games/plib/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.7 2007/09/16 09:25:03 joerg Exp $
|
||||
|
||||
--- src/sl/slDSP.cxx.orig 2007-09-16 08:55:07.000000000 +0000
|
||||
+++ src/sl/slDSP.cxx
|
||||
@@ -413,7 +413,7 @@ void slDSP::stop ()
|
||||
/* NetBSD/OpenBSD 2.3 this should be very close to SUN Audio */
|
||||
/* ------------------------------------------------------------ */
|
||||
|
||||
-#elif (defined(UL_BSD) && !defined(__FreeBSD__)) || defined(UL_SOLARIS)
|
||||
+#elif (defined(UL_BSD) && !defined(__FreeBSD__) &&!defined(__DragonFly__)) || defined(UL_SOLARIS)
|
||||
void slDSP::open ( const char *device, int _rate, int _stereo, int _bps )
|
||||
{
|
||||
|
Loading…
Reference in a new issue