Fix inline use.

This commit is contained in:
joerg 2013-10-10 00:09:07 +00:00
parent ad44a6e12a
commit 535b1324d3
3 changed files with 164 additions and 1 deletions

View file

@ -1,8 +1,10 @@
$NetBSD: distinfo,v 1.3 2013/10/08 12:31:22 obache Exp $
$NetBSD: distinfo,v 1.4 2013/10/10 00:09:07 joerg Exp $
SHA1 (freerdp-1.0.2.tar.gz) = 6c21e7f1505c64eeff056497bdd7b64551d34f5b
RMD160 (freerdp-1.0.2.tar.gz) = cf2a584c3a3628ca068913d7e5bcd2e305211045
Size (freerdp-1.0.2.tar.gz) = 3506620 bytes
SHA1 (patch-client_X11_CMakeLists.txt) = cef86f1b64a562b5d7c2fa9d2f934a5167276b14
SHA1 (patch-libfreerdp-codec_color.c) = 63bb566d4b37a8a04cbb3e1ce1071ba0d3efffad
SHA1 (patch-libfreerdp-core_listener.c) = 6023aa6714cf26cb3d0193978531b49bf7b06c78
SHA1 (patch-libfreerdp-core_orders.c) = 7534fab21949795b15525a9496c129d7fd4f1956
SHA1 (patch-libfreerdp-core_tcp.c) = 0a4cfac09484fd1f9ba3efb18e35540b9684e23c

View file

@ -0,0 +1,40 @@
$NetBSD: patch-libfreerdp-codec_color.c,v 1.1 2013/10/10 00:09:07 joerg Exp $
--- libfreerdp-codec/color.c.orig 2013-10-09 23:34:52.000000000 +0000
+++ libfreerdp-codec/color.c
@@ -86,7 +86,7 @@ void freerdp_set_pixel(uint8* data, int
}
}
-INLINE void freerdp_color_split_rgb(uint32* color, int bpp, uint8* red, uint8* green, uint8* blue, uint8* alpha, HCLRCONV clrconv)
+static INLINE void freerdp_color_split_rgb(uint32* color, int bpp, uint8* red, uint8* green, uint8* blue, uint8* alpha, HCLRCONV clrconv)
{
*red = *green = *blue = 0;
*alpha = (clrconv->alpha) ? 0xFF : 0x00;
@@ -137,7 +137,7 @@ INLINE void freerdp_color_split_rgb(uint
}
}
-INLINE void freerdp_color_split_bgr(uint32* color, int bpp, uint8* red, uint8* green, uint8* blue, uint8* alpha, HCLRCONV clrconv)
+static INLINE void freerdp_color_split_bgr(uint32* color, int bpp, uint8* red, uint8* green, uint8* blue, uint8* alpha, HCLRCONV clrconv)
{
*red = *green = *blue = 0;
*alpha = (clrconv->alpha) ? 0xFF : 0x00;
@@ -188,7 +188,7 @@ INLINE void freerdp_color_split_bgr(uint
}
}
-INLINE void freerdp_color_make_rgb(uint32* color, int bpp, uint8* red, uint8* green, uint8* blue, uint8* alpha, HCLRCONV clrconv)
+static INLINE void freerdp_color_make_rgb(uint32* color, int bpp, uint8* red, uint8* green, uint8* blue, uint8* alpha, HCLRCONV clrconv)
{
switch (bpp)
{
@@ -229,7 +229,7 @@ INLINE void freerdp_color_make_rgb(uint3
}
}
-INLINE void freerdp_color_make_bgr(uint32* color, int bpp, uint8* red, uint8* green, uint8* blue, uint8* alpha, HCLRCONV clrconv)
+static INLINE void freerdp_color_make_bgr(uint32* color, int bpp, uint8* red, uint8* green, uint8* blue, uint8* alpha, HCLRCONV clrconv)
{
switch (bpp)
{

View file

@ -0,0 +1,121 @@
$NetBSD: patch-libfreerdp-core_orders.c,v 1.1 2013/10/10 00:09:07 joerg Exp $
--- libfreerdp-core/orders.c.orig 2013-10-09 23:33:10.000000000 +0000
+++ libfreerdp-core/orders.c
@@ -138,7 +138,7 @@ static const uint8 BMF_BPP[] =
0, 1, 0, 8, 16, 24, 32
};
-INLINE void update_read_coord(STREAM* s, sint32* coord, boolean delta)
+static INLINE void update_read_coord(STREAM* s, sint32* coord, boolean delta)
{
sint8 lsi8;
sint16 lsi16;
@@ -155,7 +155,7 @@ INLINE void update_read_coord(STREAM* s,
}
}
-INLINE void update_read_color(STREAM* s, uint32* color)
+static INLINE void update_read_color(STREAM* s, uint32* color)
{
uint8 byte;
@@ -167,7 +167,7 @@ INLINE void update_read_color(STREAM* s,
*color |= (byte << 16);
}
-INLINE void update_read_colorref(STREAM* s, uint32* color)
+static INLINE void update_read_colorref(STREAM* s, uint32* color)
{
uint8 byte;
@@ -180,7 +180,7 @@ INLINE void update_read_colorref(STREAM*
stream_seek_uint8(s);
}
-INLINE void update_read_color_quad(STREAM* s, uint32* color)
+static INLINE void update_read_color_quad(STREAM* s, uint32* color)
{
uint8 byte;
@@ -193,7 +193,7 @@ INLINE void update_read_color_quad(STREA
stream_seek_uint8(s);
}
-INLINE void update_read_2byte_unsigned(STREAM* s, uint32* value)
+static INLINE void update_read_2byte_unsigned(STREAM* s, uint32* value)
{
uint8 byte;
@@ -211,7 +211,7 @@ INLINE void update_read_2byte_unsigned(S
}
}
-INLINE void update_read_2byte_signed(STREAM* s, sint32* value)
+static INLINE void update_read_2byte_signed(STREAM* s, sint32* value)
{
uint8 byte;
boolean negative;
@@ -232,7 +232,7 @@ INLINE void update_read_2byte_signed(STR
*value *= -1;
}
-INLINE void update_read_4byte_unsigned(STREAM* s, uint32* value)
+static INLINE void update_read_4byte_unsigned(STREAM* s, uint32* value)
{
uint8 byte;
uint8 count;
@@ -276,7 +276,7 @@ INLINE void update_read_4byte_unsigned(S
}
}
-INLINE void update_read_delta(STREAM* s, sint32* value)
+static INLINE void update_read_delta(STREAM* s, sint32* value)
{
uint8 byte;
@@ -294,7 +294,7 @@ INLINE void update_read_delta(STREAM* s,
}
}
-INLINE void update_read_glyph_delta(STREAM* s, uint16* value)
+static INLINE void update_read_glyph_delta(STREAM* s, uint16* value)
{
uint8 byte;
@@ -306,7 +306,7 @@ INLINE void update_read_glyph_delta(STRE
*value = (byte & 0x3F);
}
-INLINE void update_seek_glyph_delta(STREAM* s)
+static INLINE void update_seek_glyph_delta(STREAM* s)
{
uint8 byte;
@@ -316,7 +316,7 @@ INLINE void update_seek_glyph_delta(STRE
stream_seek_uint8(s);
}
-INLINE void update_read_brush(STREAM* s, rdpBrush* brush, uint8 fieldFlags)
+static INLINE void update_read_brush(STREAM* s, rdpBrush* brush, uint8 fieldFlags)
{
if (fieldFlags & ORDER_FIELD_01)
stream_read_uint8(s, brush->x);
@@ -354,7 +354,7 @@ INLINE void update_read_brush(STREAM* s,
}
}
-INLINE void update_read_delta_rects(STREAM* s, DELTA_RECT* rectangles, int number)
+static INLINE void update_read_delta_rects(STREAM* s, DELTA_RECT* rectangles, int number)
{
int i;
uint8 flags = 0;
@@ -399,7 +399,7 @@ INLINE void update_read_delta_rects(STRE
}
}
-INLINE void update_read_delta_points(STREAM* s, DELTA_POINT* points, int number, sint16 x, sint16 y)
+static INLINE void update_read_delta_points(STREAM* s, DELTA_POINT* points, int number, sint16 x, sint16 y)
{
int i;
uint8 flags = 0;