xenConsole (aka xcon) is a curses-based tty/console monitor for Xen 2.0,

basically presenting the output from 'xm list' in a full-screen interface
with additional domain information from SNMP, colours and somewhat realtime
updates.
This commit is contained in:
martti 2005-11-13 18:36:00 +00:00
parent d369d05ff9
commit 53649cf3d6
8 changed files with 143 additions and 0 deletions

View file

@ -0,0 +1,4 @@
xenConsole (aka xcon) is a curses-based tty/console monitor for Xen 2.0,
basically presenting the output from 'xm list' in a full-screen interface
with additional domain information from SNMP, colours and somewhat realtime
updates.

View file

@ -0,0 +1,58 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/11/13 18:36:00 martti Exp $
DISTNAME= xenConsole-r0.15b1-1
PKGNAME= xenconsole-0.15b1.1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ucck/}
MAINTAINER= martti@NetBSD.org
HOMEPAGE= http://ucck.sourceforge.net/xenConsole/
COMMENT= Console monitor for Xen
WRKSRC= ${WRKDIR}/xenConsole
DEPENDS+= p5-Config-IniFiles>=2.38:../../devel/p5-Config-IniFiles
DEPENDS+= p5-Curses-UI>=0.95:../../devel/p5-Curses-UI
DEPENDS+= p5-Curses-UI-POE>=0.02801:../../devel/p5-Curses-UI-POE
DEPENDS+= p5-Data-Table>=1.43:../../databases/p5-Data-Table
DEPENDS+= p5-Net-SNMP>=5.0.1:../../net/p5-Net-SNMP
DEPENDS+= p5-POE>=0.3101:../../devel/p5-POE
DEPENDS+= p5-POE-Component-SNMP>=0.93:../../net/p5-POE-Component-SNMP
DEPENDS+= p5-Sys-CpuLoad>=0.03:../../sysutils/p5-Sys-CpuLoad
DEPENDS+= p5-Term-Size>=0.2:../../devel/p5-Term-Size
DEPENDS+= p5-Time-HiRes>=0:../../time/p5-Time-HiRes
SUBST_CLASSES+= xenconsole
SUBST_STAGE.xenconsole= pre-configure
SUBST_MESSAGE.xenconsole= "Fixing paths."
SUBST_FILES.xenconsole= xcon.pl xen_list.pm
SUBST_SED.xenconsole= -e "s,@PREFIX@,${PREFIX},g"
SUBST_SED.xenconsole+= -e "s,@LOCALBASE@,${LOCALBASE},g"
REPLACE_PERL= xcon.pl xsnmp.pm
USE_PKGINSTALL= yes
EGDIR= ${PREFIX}/share/examples/xenconsole
CONF_FILES= ${EGDIR}/xcon.ini ${PKG_SYSCONFDIR}/xcon.ini
do-build:
${SED} -e "s,@PREFIX@,${PREFIX},g" \
< ${FILESDIR}/xcon.sh > ${WRKDIR}/xcon
do-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/xenconsole
(cd ${WRKSRC} && ${PAX} -rw *.pm */*.pm ${PREFIX}/share/xenconsole)
${INSTALL_SCRIPT} ${WRKSRC}/xcon.pl ${PREFIX}/share/xenconsole/xcon
# Configuration file
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/sample-inifile ${EGDIR}/xcon.ini
# Documentation
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/xenconsole
(cd ${WRKSRC} && ${PAX} -rw *.txt ${PREFIX}/share/doc/xenconsole)
# Launcher script
${INSTALL_SCRIPT} ${WRKDIR}/xcon ${PREFIX}/bin/xcon
.include "../../mk/bsd.pkg.mk"

25
sysutils/xenconsole/PLIST Normal file
View file

@ -0,0 +1,25 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/11/13 18:36:00 martti Exp $
bin/xcon
share/examples/xenconsole/xcon.ini
share/doc/xenconsole/CHANGES.txt
share/doc/xenconsole/README.txt
share/doc/xenconsole/TODO.txt
share/xenconsole/colours.pm
share/xenconsole/gothix/capstderr.pm
share/xenconsole/gothix/cpusage.pm
share/xenconsole/gothix/misc.pm
share/xenconsole/gothix/oobase.pm
share/xenconsole/gothix/subversion.pm
share/xenconsole/gothix/themes.pm
share/xenconsole/gothix/timers.pm
share/xenconsole/gothix/xtable.pm
share/xenconsole/snmp_poll.pm
share/xenconsole/tui.pm
share/xenconsole/xcon
share/xenconsole/xen_list.pm
share/xenconsole/xglobal.pm
share/xenconsole/xsnmp.pm
@dirrm share/examples/xenconsole
@dirrm share/doc/xenconsole
@dirrm share/xenconsole/gothix
@dirrm share/xenconsole

View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2005/11/13 18:36:00 martti Exp $
SHA1 (xenConsole-r0.15b1-1.tar.gz) = 7f8cbd97d24fdb7e7c9bb9a0e8af69c01bb69f3a
RMD160 (xenConsole-r0.15b1-1.tar.gz) = 88959d0a564f1355d09d49e76000ea6aad27f34f
Size (xenConsole-r0.15b1-1.tar.gz) = 36083 bytes
SHA1 (patch-aa) = 05a4187cf375e036eceb60a6cb6f0594ac09ce26
SHA1 (patch-ab) = c1961487949acbacfb0595604d4371d39b438799
SHA1 (patch-ac) = 28950a3114e505a4b562a54e28a957b1f13f4e01

View file

@ -0,0 +1,6 @@
#!/bin/sh
#
# $NetBSD: xcon.sh,v 1.1.1.1 2005/11/13 18:36:00 martti Exp $
#
(cd "@PREFIX@/share/xenconsole" && ./xcon)

View file

@ -0,0 +1,19 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/11/13 18:36:00 martti Exp $
--- xcon.pl.orig 2005-11-05 05:23:18.000000000 +0900
+++ xcon.pl
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
# vim:aw:
#
# xcon.pl - xenConsole main executable
@@ -561,7 +561,7 @@ sub read_config {
foreach my $cfn (
'./inifile.xcon',
$ENV{HOME} . '/.xcon.ini',
- '/etc/xcon.ini',
+ '@PREFIX@/etc/xcon.ini',
) {
if (-r $cfn) {
conmsg('sys', "Use configuration from $cfn");

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2005/11/13 18:36:00 martti Exp $
--- xen_list.pm.orig 2005-11-05 05:23:18.000000000 +0900
+++ xen_list.pm
@@ -59,7 +59,7 @@ our @ISA = qw( gothix::oobase );
# --- Globals -------------------------------------------------------------
-our $pn_xen_xm = '/usr/sbin/xm';
+our $pn_xen_xm = '@LOCALBASE@/sbin/xm';
my $pn_xm_list = $pn_xen_xm . ' list|';
my $pn_xm_info = $pn_xen_xm . ' info|';

View file

@ -0,0 +1,10 @@
$NetBSD: patch-ac,v 1.1.1.1 2005/11/13 18:36:00 martti Exp $
--- xsnmp.pm.orig 2005-11-05 05:23:18.000000000 +0900
+++ xsnmp.pm
@@ -1,4 +1,4 @@
-#!/usr/bin/env perl
+#!/usr/bin/perl
# vim:aw:
#
# xcon.pl - xenConsole main executable