Remove newscache -- very outdated version that does not build with gcc3,
and no taker for updating the package. Code has diverged a lot, so making a new package for the program is probably the same (or less) work as starting from this version.
This commit is contained in:
parent
93c9637a53
commit
539b3e12f0
11 changed files with 1 additions and 196 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.31 2004/12/24 00:43:14 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.32 2005/04/22 19:33:49 wiz Exp $
|
||||
#
|
||||
|
||||
COMMENT= Network news
|
||||
|
@ -7,7 +7,6 @@ SUBDIR+= cg
|
|||
SUBDIR+= inn
|
||||
SUBDIR+= knews
|
||||
SUBDIR+= leafnode
|
||||
SUBDIR+= newscache
|
||||
SUBDIR+= newsfetch
|
||||
SUBDIR+= newsx
|
||||
SUBDIR+= nget
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
NewsCache is a free cache server for USENET News available under the GNU
|
||||
General Public License. NewsCache can be plugged in between your news
|
||||
reader(s) and your news server. NewsCache acts to news readers like a news
|
||||
server and retrieves news articles from the news server like a news reader.
|
||||
Whenever, a client requests an article from NewsCache, NewsCache checks
|
||||
whether the article has already been stored in the cache area. If this is
|
||||
the case, the article is sent directly to its client. Otherwise, the article
|
||||
is requested from the upstream news server, stored in the cache area and sent
|
||||
back to the client.
|
||||
|
||||
NewsCache provides the following functionality:
|
||||
|
||||
* Offline news reading.
|
||||
* Small articles are stored within a single database. This improves
|
||||
performance and reduces the number of inodes used of your system.
|
||||
* The overview-database is generated on the fly for articles already
|
||||
cached by the cache server.
|
||||
* This reduces the amount of disk space used, but decreases performance
|
||||
slightly.
|
||||
* The newsgroup-database is now managed as an array instead of a list to
|
||||
allow direct access to articles.
|
||||
* Merging different news servers to a virtual feed (on a per newsgroup
|
||||
basis).
|
|
@ -1,27 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.14 2005/04/11 21:47:03 tv Exp $
|
||||
#
|
||||
|
||||
DISTNAME= NewsCache-0.99.22p1
|
||||
PKGNAME= ${DISTNAME:S/p/.0./}
|
||||
CATEGORIES= news
|
||||
MASTER_SITES= http://www.hstraub.at/linux/downloads/src/
|
||||
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
HOMEPAGE= http://www.linuxhacker.at/newscache/
|
||||
COMMENT= Free cache server for USENET News
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_GNU_TOOLS+= make
|
||||
USE_LANGUAGES= c c++
|
||||
USE_PKGINSTALL= YES
|
||||
INFO_FILES= NewsCache.info
|
||||
|
||||
CONFIGURE_ARGS+= --sysconfdir="${PKG_SYSCONFDIR}"
|
||||
|
||||
CONF_FILES= ${PREFIX}/share/examples/NewsCache/newscache.conf \
|
||||
${PKG_SYSCONFDIR}/newscache.conf
|
||||
|
||||
post-extract:
|
||||
${MV} ${WRKSRC}/etc/newscache.conf-dist ${WRKSRC}/etc/newscache.conf
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,14 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2004/03/09 16:42:24 seb Exp $
|
||||
bin/updatenews
|
||||
man/man5/newscache.conf.5
|
||||
man/man8/NewsCache.8
|
||||
man/man8/NewsCacheClean.8
|
||||
man/man8/updatenews.8
|
||||
sbin/NewsCache
|
||||
sbin/NewsCacheClean
|
||||
sbin/accesslog
|
||||
sbin/cachestat
|
||||
sbin/hostlog
|
||||
sbin/hoststat
|
||||
share/examples/NewsCache/newscache.conf
|
||||
@dirrm share/examples/NewsCache
|
|
@ -1,11 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.6 2005/02/24 12:19:55 agc Exp $
|
||||
|
||||
SHA1 (NewsCache-0.99.22p1.tar.gz) = 4b11d255dff22341040ead41d0d3f33ba8a84d8a
|
||||
RMD160 (NewsCache-0.99.22p1.tar.gz) = b81bf9829b2a9d5769080754af7a94eea98f86b9
|
||||
Size (NewsCache-0.99.22p1.tar.gz) = 321605 bytes
|
||||
SHA1 (patch-aa) = 0964e234041c6ad76c215cbb2d381d8e9feeea85
|
||||
SHA1 (patch-ab) = 30da9db48ce320a5e21bb74a38cdbff05b3db28c
|
||||
SHA1 (patch-ac) = 48a21e95d80569784f91c3fc288d711d9e4f77d3
|
||||
SHA1 (patch-ad) = 93ca8786fea2c745587e6acdc9ec8f422cdbe8ee
|
||||
SHA1 (patch-ae) = 94bf16d68d09f86bbd30d34b8932e400b39af462
|
||||
SHA1 (patch-af) = b8302a9ec182fffdf2fc67eccdb9c742750b0f94
|
|
@ -1,29 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2001/08/28 03:30:43 mjl Exp $
|
||||
|
||||
--- configure.orig Tue Aug 28 05:11:12 2001
|
||||
+++ configure Tue Aug 28 05:13:05 2001
|
||||
@@ -1421,6 +1421,8 @@
|
||||
EOF
|
||||
|
||||
ac_cv_lib_wrap_hosts_ctl=yes
|
||||
+ LIBS="$ac_save_LIBS"
|
||||
+ LIBWRAP="-lwrap"
|
||||
else
|
||||
echo "configure: failed program was:" >&5
|
||||
cat conftest.$ac_ext >&5
|
||||
@@ -1428,6 +1430,7 @@
|
||||
LIBS="$ac_save_LIBS"
|
||||
echo "$ac_t""no" 1>&6
|
||||
ac_cv_lib_wrap_hosts_ctl=no
|
||||
+ LIBWRAP=""
|
||||
fi
|
||||
rm -f conftest*
|
||||
|
||||
@@ -2435,6 +2438,7 @@
|
||||
s%@DEFS@%$DEFS%g
|
||||
s%@LDFLAGS@%$LDFLAGS%g
|
||||
s%@LIBS@%$LIBS%g
|
||||
+s%@LIBWRAP@%$LIBWRAP%g
|
||||
s%@exec_prefix@%$exec_prefix%g
|
||||
s%@prefix@%$prefix%g
|
||||
s%@program_transform_name@%$program_transform_name%g
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 1999/08/22 13:44:20 rh Exp $
|
||||
|
||||
--- src/NewsCache.cc.orig Mon Jul 5 15:47:32 1999
|
||||
+++ src/NewsCache.cc Sun Aug 22 13:41:40 1999
|
||||
@@ -18,9 +18,12 @@
|
||||
*/
|
||||
#include "config.h"
|
||||
|
||||
+#ifdef HAVE_CRYPT_H
|
||||
#include <crypt.h>
|
||||
+#endif
|
||||
#include <ctype.h>
|
||||
#include <unistd.h>
|
||||
+#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
#include <netinet/in.h>
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.2 2001/08/28 03:30:43 mjl Exp $
|
||||
|
||||
--- src/Makefile.in.orig Tue Aug 28 05:14:04 2001
|
||||
+++ src/Makefile.in Tue Aug 28 05:14:52 2001
|
||||
@@ -103,6 +103,8 @@
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
||||
+LIBWRAP = @LIBWRAP@
|
||||
+
|
||||
cConfig_OBJECTS = AccessList.o cConfig.o Config.o
|
||||
cConfig_LDADD = $(LDADD)
|
||||
cConfig_DEPENDENCIES = ../NServer-0.9.1/libnserver.a \
|
||||
@@ -251,7 +253,7 @@
|
||||
|
||||
NewsCache: $(NewsCache_OBJECTS) $(NewsCache_DEPENDENCIES)
|
||||
@rm -f NewsCache
|
||||
- $(CXXLINK) $(NewsCache_LDFLAGS) $(NewsCache_OBJECTS) $(NewsCache_LDADD) $(LIBS)
|
||||
+ $(CXXLINK) $(NewsCache_LDFLAGS) $(NewsCache_OBJECTS) $(NewsCache_LDADD) $(LIBS) $(LIBWRAP)
|
||||
|
||||
NewsCacheClean: $(NewsCacheClean_OBJECTS) $(NewsCacheClean_DEPENDENCIES)
|
||||
@rm -f NewsCacheClean
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 1999/08/22 13:44:20 rh Exp $
|
||||
|
||||
--- doc/NewsCache.info.orig Thu Jan 14 20:24:53 1999
|
||||
+++ doc/NewsCache.info Sun Aug 22 14:03:42 1999
|
||||
@@ -1,6 +1,11 @@
|
||||
This is Info file NewsCache.info, produced by Makeinfo version 1.68
|
||||
from the input file NewsCache.texinfo.
|
||||
|
||||
+INFO-DIR-SECTION Net Utilities
|
||||
+START-INFO-DIR-ENTRY
|
||||
+* NewsCache: (NewsCache). NewsCache Reference Manual.
|
||||
+END-INFO-DIR-ENTRY
|
||||
+
|
||||
This is the NewsCache Reference Manual.
|
||||
|
||||
Copyright (C) 1998 Thomas Gschwind <tom@infosys.tuwien.ac.at>
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.2 2001/08/28 03:30:43 mjl Exp $
|
||||
|
||||
--- NServer-0.9.1/Article.h.orig Sun Jul 9 22:12:20 2000
|
||||
+++ NServer-0.9.1/Article.h Tue Aug 28 05:01:51 2001
|
||||
@@ -4,7 +4,7 @@
|
||||
#include <ctype.h>
|
||||
#include <stdio.h>
|
||||
|
||||
-#include <string>
|
||||
+#include <string.h>
|
||||
|
||||
#include "NSError.h"
|
||||
#include "Debug.h"
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1 2003/05/02 07:36:44 jmmv Exp $
|
||||
|
||||
--- etc/Makefile.in.orig 2000-07-09 23:10:15.000000000 +0200
|
||||
+++ etc/Makefile.in
|
||||
@@ -23,7 +23,7 @@ bindir = @bindir@
|
||||
sbindir = @sbindir@
|
||||
libexecdir = @libexecdir@
|
||||
datadir = @datadir@
|
||||
-sysconfdir = @sysconfdir@
|
||||
+sysconfdir = @datadir@/examples/@PACKAGE@
|
||||
sharedstatedir = @sharedstatedir@
|
||||
localstatedir = @localstatedir@
|
||||
libdir = @libdir@
|
||||
@@ -67,7 +67,7 @@ RANLIB = @RANLIB@
|
||||
VERSION = @VERSION@
|
||||
ac_cv_prog_find_printf = @ac_cv_prog_find_printf@
|
||||
|
||||
-sysconf_DATA = newscache.conf-dist
|
||||
+sysconf_DATA = newscache.conf
|
||||
|
||||
EXTRA_DIST = newscache.conf-dist NewsCache.init.in
|
||||
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
Loading…
Reference in a new issue