Remove conflicting declaration of malloc(). Include stdlib.h instead.
This commit is contained in:
parent
d77d9cb3e4
commit
539e7c596c
4 changed files with 44 additions and 2 deletions
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.3 2005/02/23 17:36:25 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.4 2006/07/29 04:42:08 minskim Exp $
|
||||
|
||||
SHA1 (xpostit3.3.1.tar.Z) = 8ba13bb544d9c99308e36fff2590623ad9a16fef
|
||||
RMD160 (xpostit3.3.1.tar.Z) = 913ed61908541c65b8f2930c0f066ad2704b7856
|
||||
Size (xpostit3.3.1.tar.Z) = 53910 bytes
|
||||
SHA1 (patch-aa) = f958b6cfdf3d6ac269d0a73efb4c483fcba1a273
|
||||
SHA1 (patch-ab) = 6a61ec1ed69e0311a98bea7bca30f09a74e386a3
|
||||
SHA1 (patch-ac) = ba9db152d764e0ab02aca8e0c2f8bf67ce4d4dc4
|
||||
|
|
20
x11/xpostit/patches/patch-ac
Normal file
20
x11/xpostit/patches/patch-ac
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-ac,v 1.1 2006/07/29 04:42:08 minskim Exp $
|
||||
|
||||
--- util.c.orig 1992-12-11 13:04:17.000000000 +0000
|
||||
+++ util.c
|
||||
@@ -45,6 +45,7 @@ static char *RCSid = "$Header: /home/har
|
||||
#include <X11/Intrinsic.h>
|
||||
#include <sys/param.h>
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <pwd.h>
|
||||
|
||||
#include "xpostit.h"
|
||||
@@ -129,7 +130,6 @@ char *
|
||||
SafeAlloc(nbytes)
|
||||
register int nbytes;
|
||||
{
|
||||
- char *malloc();
|
||||
register char *s;
|
||||
|
||||
if ((s = malloc(nbytes)) == NULL) {
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.5 2005/02/23 17:36:25 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.6 2006/07/29 04:39:31 minskim Exp $
|
||||
|
||||
SHA1 (xscribble.tgz) = 9983577533c6b6f482e2bfe863f54604337562c7
|
||||
RMD160 (xscribble.tgz) = 49f5a5339819a76e303a135d54fb8ffd4f88febb
|
||||
|
@ -7,3 +7,4 @@ SHA1 (patch-aa) = eaab5d05c9ced68dda8848df5360afc990e58b6d
|
|||
SHA1 (patch-ab) = 6da2e1ba900c05d428de74b44e369c0e0c242190
|
||||
SHA1 (patch-ac) = 0a6352bf35e79db51b25e195a5bed88661672987
|
||||
SHA1 (patch-ad) = 9fe0ce4f137975cd380280e13ccfa1543016b5b7
|
||||
SHA1 (patch-ae) = 383631838e7467196ed5fa579084d4637cf82d7b
|
||||
|
|
20
x11/xscribble/patches/patch-ae
Normal file
20
x11/xscribble/patches/patch-ae
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-ae,v 1.1 2006/07/29 04:39:31 minskim Exp $
|
||||
|
||||
--- lirec/util.c.orig 2000-06-12 22:20:14.000000000 +0000
|
||||
+++ lirec/util.c
|
||||
@@ -22,6 +22,7 @@ the full agreement.
|
||||
#include <setjmp.h>
|
||||
/* ari -- for strlen */
|
||||
#include <string.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
extern char* li_err_msg;
|
||||
static char err_msg[BUFSIZ];
|
||||
@@ -34,7 +35,6 @@ char *
|
||||
myalloc(nitems, itemsize, typename)
|
||||
char *typename;
|
||||
{
|
||||
- char *malloc();
|
||||
register unsigned int bytes = nitems * itemsize;
|
||||
register char *p = malloc(bytes);
|
||||
if(p == NULL)
|
Loading…
Reference in a new issue