Initial import of fcgiwrap, version 1.1.0,

into the NetBSD Packages Collection.
This commit is contained in:
nils 2016-08-07 18:01:29 +00:00
parent 3438da85c9
commit 53b2a993dc
5 changed files with 66 additions and 0 deletions

1
www/fcgiwrap/DESCR Normal file
View file

@ -0,0 +1 @@
A simple wrapper for using CGI scripts through FastCGI.

25
www/fcgiwrap/Makefile Normal file
View file

@ -0,0 +1,25 @@
# $NetBSD: Makefile,v 1.1 2016/08/07 18:01:29 nils Exp $
DISTNAME= fcgiwrap-1.1.0
CATEGORIES= www
COMMENT= FastCGI wrapper for plain CGI scripts
LICENSE= mit
GITHUB_TAG= ${PKGVERSION_NOREV}
MASTER_SITES= ${MASTER_SITE_GITHUB:=gnosek/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://nginx.localdomain.pl/wiki/FcgiWrap
GNU_CONFIGURE= yes
USE_TOOLS+= automake autoreconf pkg-config
LDFLAGS.SunOS+= -lsocket -lnsl
pre-configure:
cd ${WRKSRC} && autoreconf -i
.include "../../www/fcgi/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

3
www/fcgiwrap/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2016/08/07 18:01:29 nils Exp $
man/man8/fcgiwrap.8
sbin/fcgiwrap

6
www/fcgiwrap/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2016/08/07 18:01:29 nils Exp $
SHA1 (fcgiwrap-1.1.0.tar.gz) = 8e7b9140b3d96f4635352bb967715477b35caf84
RMD160 (fcgiwrap-1.1.0.tar.gz) = 7969f77430d1c51e58aa90619803caf723a50168
Size (fcgiwrap-1.1.0.tar.gz) = 9924 bytes
SHA1 (patch-Makefile.in) = 30615f4beb33f9ac47fdcd7cebb93bd42fa55e94

View file

@ -0,0 +1,31 @@
$NetBSD: patch-Makefile.in,v 1.1 2016/08/07 18:01:29 nils Exp $
Fix double-prefixing as @mandir@ already contains @prefix@
Comment out systemd stuff (not used with pkgsrc, and would just require gmake).
--- Makefile.in.orig 2013-05-07 07:57:54.000000000 -0400
+++ Makefile.in 2013-09-07 13:17:06.000000000 -0400
@@ -1,5 +1,5 @@
targetdir = $(DESTDIR)@prefix@@sbindir@
-man8dir = $(DESTDIR)@prefix@@mandir@/man8
+man8dir = $(DESTDIR)@mandir@/man8
datarootdir =
.PHONY: clean distclean
@@ -10,11 +10,11 @@
install -m 755 fcgiwrap $(targetdir)
install -d -m 755 $(man8dir)
install -m 644 fcgiwrap.8 $(man8dir)
-ifneq ("@systemdsystemunitdir@", "")
- install -d -m 755 $(DESTDIR)@systemdsystemunitdir@
- install -m 644 systemd/fcgiwrap.socket $(DESTDIR)@systemdsystemunitdir@
- install -m 644 systemd/fcgiwrap.service $(DESTDIR)@systemdsystemunitdir@
-endif
+#ifneq ("@systemdsystemunitdir@", "")
+# install -d -m 755 $(DESTDIR)@systemdsystemunitdir@
+# install -m 644 systemd/fcgiwrap.socket $(DESTDIR)@systemdsystemunitdir@
+# install -m 644 systemd/fcgiwrap.service $(DESTDIR)@systemdsystemunitdir@
+#endif
LDLIBS = -lfcgi @systemd_LIBS@
CFLAGS = @AM_CFLAGS@