Sunpro needs some more patches.

This commit is contained in:
rillig 2007-11-15 06:36:45 +00:00
parent 1d3ee5267c
commit 53bc38d7c1
5 changed files with 77 additions and 12 deletions

View file

@ -1,12 +1,13 @@
$NetBSD: distinfo,v 1.8 2007/05/24 02:06:14 dmcmahill Exp $
$NetBSD: distinfo,v 1.9 2007/11/15 06:36:45 rillig Exp $
SHA1 (ttmkfdir2.20021109.tar.bz2) = bee1944ce3e5b6c4503a14e6429737cc558a24c0
RMD160 (ttmkfdir2.20021109.tar.bz2) = 878fb57f80e7223ebb3f4214ed58621a9087e404
Size (ttmkfdir2.20021109.tar.bz2) = 701900 bytes
SHA1 (patch-aa) = ae2cb207635678d68d010e54de6ad6905fc3e38b
SHA1 (patch-ab) = 5c7e936fead9551b2b206abb512a9bbdcaadd101
SHA1 (patch-ab) = 82363c15471b835082c50488c167d11e68262944
SHA1 (patch-ac) = c29cd845647d67102a89476d931e5ee6bae63078
SHA1 (patch-ad) = 0c328908ffae3397293ff6b00094444e23164788
SHA1 (patch-ae) = 8544a176af1c079405371789955391b400f0154e
SHA1 (patch-af) = 9153a8c65960ce70a176418da2c507370a06d98b
SHA1 (patch-ag) = 20abaf5147d6770907473e298f3177f6c8e4c131
SHA1 (patch-af) = 4ebed2b1b9e12b0c7b17e7078e5ef66b1e1ab82c
SHA1 (patch-ag) = 44bdd6fba4f796792ff13ea8daee9e5f9344d4a4
SHA1 (patch-ah) = fbd9e5c14e7c7f4e448437f17faa732a87ca427b

View file

@ -1,8 +1,21 @@
$NetBSD: patch-ab,v 1.2 2004/04/03 11:31:02 recht Exp $
$NetBSD: patch-ab,v 1.3 2007/11/15 06:36:45 rillig Exp $
--- ttf.cpp.orig 2002-11-07 06:30:04.000000000 +0100
+++ ttf.cpp
@@ -226,7 +226,7 @@ Face::FontFamilyName (void) const
+++ ttf.cpp 2007-11-15 07:05:27.304109000 +0100
@@ -137,7 +137,12 @@ Face::Face (const std::string &filename)
/*
* find all the encodings that are based on this cmap.
*/
+#if defined(__SUNPRO_CC)
+ /* Error: Cannot use ... ::iterator ... to initialize ... ::const_iterator ... */
+ typedef Encodings_t::iterator MI;
+#else
typedef Encodings_t::const_iterator MI;
+#endif
std::pair<MI, MI> bounds = Encodings::instance()->equal_range (key);
/*
@@ -226,7 +231,7 @@ Face::FontFamilyName (void) const
for (i = 0; i < n; i++) {
if ((fterror = FT_Get_Sfnt_Name (face, i, &NamePtr)) != FT_Err_Ok) {
std::cout << "Warning: Can't SFNT name : " << FileName << "(" << fterror << ")" << std::endl;
@ -11,3 +24,21 @@ $NetBSD: patch-ab,v 1.2 2004/04/03 11:31:02 recht Exp $
};
platform = NamePtr.platform_id;
encoding = NamePtr.encoding_id;
@@ -522,7 +527,7 @@ Face::Weight (void) const
{
const char *result;
- if (cmdline::instance()->option ("panose") && ((result = PanoseWeight ()) != 0)) {
+ if (bool(cmdline::instance()->option ("panose")) && ((result = PanoseWeight ()) != 0)) {
return result;
} else if ((result = OS2Weight ()) != 0) {
return result;
@@ -603,7 +608,7 @@ Face::Width (void) const
{
const char *result;
- if (cmdline::instance()->option ("panose") && ((result = PanoseWidth ()) != 0)) {
+ if (bool(cmdline::instance()->option ("panose")) && ((result = PanoseWidth ()) != 0)) {
return result;
} else if ((result = OS2Width ()) != 0) {
return result;

View file

@ -1,7 +1,9 @@
$NetBSD: patch-af,v 1.1 2004/04/28 00:10:04 recht Exp $
$NetBSD: patch-af,v 1.2 2007/11/15 06:36:45 rillig Exp $
http://wiki.netbsd.se/Typical_pkgsrc_error_messages
--- encoding.cpp.orig 2002-11-07 06:28:44.000000000 +0100
+++ encoding.cpp 2004-04-28 02:04:02.000000000 +0200
+++ encoding.cpp 2007-11-15 07:19:38.547700000 +0100
@@ -2,7 +2,7 @@
#include <cstdio>
#include <cstdlib>
@ -11,3 +13,10 @@ $NetBSD: patch-af,v 1.1 2004/04/28 00:10:04 recht Exp $
#include "ttmkfdir.h"
#include "encoding.h"
@@ -101,5 +101,5 @@ Encoding::Encoding (Encodings_t *dest, B
(*m)[i] = b->mapdata.mappingtable[i];
AddMapping (m);
- dest->insert (std::make_pair(m->cmapkey(), this));;
+ dest->insert (Encodings_t::value_type(m->cmapkey(), this));
}

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ag,v 1.1 2007/05/24 02:06:17 dmcmahill Exp $
$NetBSD: patch-ag,v 1.2 2007/11/15 06:36:46 rillig Exp $
--- commandline.cpp.orig 2000-01-12 03:31:50.000000000 -0500
+++ commandline.cpp
--- commandline.cpp.orig 2000-01-12 09:31:50.000000000 +0100
+++ commandline.cpp 2007-11-15 06:51:09.407141000 +0100
@@ -1,6 +1,18 @@
#include <cstdlib>
@ -21,3 +21,12 @@ $NetBSD: patch-ag,v 1.1 2007/05/24 02:06:17 dmcmahill Exp $
#include <getopt.h>
#include "commandline.h"
@@ -35,7 +47,7 @@ Commandline::parse (int argc, char *argv
int c, j, option_index;
for (i = OptionsByName.begin (), j = 0; i != OptionsByName.end (); i++, j++) {
- lopts[j].name = i->second->name.c_str ();
+ lopts[j].name = const_cast<char *>(i->second->name.c_str ());
lopts[j].has_arg = i->second->argument;
lopts[j].flag = 0;
lopts[j].val = i->second->shortop;

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ah,v 1.1 2007/11/15 06:36:46 rillig Exp $
http://wiki.netbsd.se/Typical_pkgsrc_error_messages
--- encoding.l.orig 2002-11-07 06:28:44.000000000 +0100
+++ encoding.l 2007-11-15 07:29:00.821691000 +0100
@@ -148,7 +148,7 @@ STARTENCODING{WHITESPACES}{STRING} {
<INSIDE_MAP_BLOCK>ENDMAPPING {
cur_enc->AddMapping (cur_map);
- dest.insert (std::make_pair(cur_map->cmapkey(), cur_enc));;
+ dest.insert (Encodings_t::value_type(cur_map->cmapkey(), cur_enc));
BEGIN(INSIDE_ENC_BLOCK);
}