Initial import of pardiff-0.9.3

pardiff is a program that takes the output of diff and displays it in a
parallel (side-by-side) format, emulating the /PARALLEL option on the VMS
version of diff.

pardiff detects the width of the terminal on which it is running and adjusts
its output accordingly.
This commit is contained in:
zuntum 2001-07-09 09:35:37 +00:00
parent 6ce1a5d090
commit 53bebf081c
5 changed files with 63 additions and 0 deletions

15
devel/pardiff/Makefile Normal file
View file

@ -0,0 +1,15 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/07/09 09:35:37 zuntum Exp $
#
DISTNAME= pardiff-0.9.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pardiff/}
MAINTAINER= zuntum@netbsd.org
HOMEPAGE= http://pardiff.sourceforge.net/
COMMENT= converts diff output to paralleled (side-by-side) format
USE_BUILDLINK_ONLY= YES
GNU_CONFIGURE= YES
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,28 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/07/09 09:35:37 zuntum Exp $
--- pardiff/pardiff.c.orig Sat Jul 7 07:54:35 2001
+++ pardiff/pardiff.c
@@ -23,7 +23,11 @@
/* include files to determine the width of the output terminal */
#include <fcntl.h>
+#ifdef __NetBSD__
+#include <sys/ttycom.h>
+#else
#include <termio.h>
+#endif
#else
@@ -314,7 +318,11 @@
* Preprocess lines to get a consistent EOL
*/
if (convertCrlf) {
+#ifndef __NetBSD__
line_len = strnlen(nextline, PARDIFF_LINE_BUF_SIZE);
+#else
+ line_len = strlen(nextline);
+#endif
if (line_len > 2 && nextline[line_len - 2] == 0xd) {
nextline[line_len - 2] = '\n';
nextline[line_len - 1] = '\0';

View file

@ -0,0 +1,9 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/07/09 09:35:37 zuntum Exp $
--- pardiff/diffp.orig Sat Jan 8 05:34:47 2000
+++ pardiff/diffp
@@ -1,2 +1,3 @@
#/bin/sh
-diff $1 $2 | pardiff | ${PAGER:=more}
+PAGER?=more
+diff $1 $2 | pardiff | ${PAGER}

6
devel/pardiff/pkg/DESCR Normal file
View file

@ -0,0 +1,6 @@
Pardiff is a program that takes the output of diff and displays it in a
parallel (side-by-side) format, emulating the /PARALLEL option on the VMS
version of diff.
Pardiff detects the width of the terminal on which it is running and adjusts
its output accordingly.

5
devel/pardiff/pkg/PLIST Normal file
View file

@ -0,0 +1,5 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2001/07/09 09:35:37 zuntum Exp $
bin/diffp
bin/pardiff
man/man1/diffp.1
man/man1/pardiff.1