Update global to 4.0.1 - patches from Hubert. Fixes security issue.

This commit is contained in:
abs 2000-10-08 23:25:30 +00:00
parent 554becefd3
commit 53df6acd41
10 changed files with 13 additions and 122 deletions

View file

@ -1,15 +1,16 @@
# $NetBSD: Makefile,v 1.5 2000/09/09 14:58:49 wiz Exp $
# $NetBSD: Makefile,v 1.6 2000/10/08 23:25:30 abs Exp $
#
DISTNAME= global-3.55
DISTNAME= global-4.0.1
CATEGORIES= devel
MASTER_SITES= http://www.tamacom.com/unix/
MASTER_SITES= http://www.tamacom.com/global/
MAINTAINER= abs@netbsd.org
HOMEPAGE= http://www.tamacom.com/global/
USE_PERL5= yes
MANCOMPRESSED_IF_MANZ= yes
GNU_CONFIGURE= yes
LDFLAGS+= -L../libutil
MAKE_ENV+= LIBDIR="${PREFIX}/lib"

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.2 2000/04/21 06:46:12 sakamoto Exp $
$NetBSD: md5,v 1.3 2000/10/08 23:25:30 abs Exp $
MD5 (global-3.55.tar.gz) = 7d70e8543f50be33172239fe69958c49
MD5 (global-4.0.1.tar.gz) = a5f7c16fb0be046502e421eba40c21e9

View file

@ -1,8 +0,0 @@
$NetBSD: patch-sum,v 1.3 2000/09/09 14:58:49 wiz Exp $
MD5 (patch-aa) = e1f0ce2be24fe52da7380e0e98a7c27c
MD5 (patch-ab) = 2f7523143a210005f0e07eb4438de3f5
MD5 (patch-ac) = 8e1f6d255141a8164598c07ba19c2249
MD5 (patch-ad) = ab1df613c3cb9f2bd7cff2d75e676082
MD5 (patch-ae) = 017926d41b47acb52f2145b86614daf4
MD5 (patch-af) = 92d7819dee02267f3da86f0e60a1b74e

View file

@ -1,9 +0,0 @@
$NetBSD: patch-aa,v 1.3 2000/09/09 14:58:49 wiz Exp $
--- Makefile.orig Sat Sep 18 08:37:53 1999
+++ Makefile
@@ -1,3 +1,3 @@
-SUBDIR= libdb libutil global gtags gctags btreeop htags
+SUBDIR= libutil global gtags gctags btreeop htags
.include <bsd.subdir.mk>

View file

@ -1,9 +0,0 @@
$NetBSD: patch-ab,v 1.3 2000/09/03 09:52:56 wiz Exp $
--- libutil/mgets.c.orig Wed Aug 18 11:02:42 1999
+++ libutil/mgets.c Fri Apr 21 15:14:23 2000
@@ -39,4 +39,5 @@
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include "die.h"

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ac,v 1.3 2000/09/09 14:58:49 wiz Exp $
--- gctags/gctags.1.orig Fri Aug 27 10:25:42 1999
+++ gctags/gctags.1
@@ -128,7 +128,6 @@
.Ar Yyparse
is the start
of the second section of the yacc file.
-.El
.Sh DIAGNOSTICS
.Nm Gctags
exits with a non 0 value if an error occurred, 0 otherwise.

View file

@ -1,23 +0,0 @@
$NetBSD: patch-ad,v 1.2 2000/09/09 14:58:49 wiz Exp $
--- Makefile.inc.orig Sat Sep 18 08:42:34 1999
+++ Makefile.inc
@@ -2,14 +2,11 @@
GLOBAL_MAKEFILE_INC_BEEN_HERE=yes
BINDIR?= /usr/bin
-LDDESTDIR= -L${.OBJDIR}/../libutil \
- -L${.OBJDIR}/../libdb
-LDADD= -lgloutil -lglodb
-DPADD= ${.OBJDIR}/../libutil/libgloutil.a \
- ${.OBJDIR}/../libdb/libglodb.a
-CFLAGS+= -I${.CURDIR} \
+LDFLAGS+= -L${.OBJDIR}/../libutil
+LDADD= -lgloutil
+DPADD= ${.OBJDIR}/../libutil/libgloutil.a
+CPPFLAGS+= -I${.CURDIR} \
-I${.CURDIR}/../libutil \
- -I${.CURDIR}/../libdb \
-I${.CURDIR}/../machine \
-O
# -Wall -Wwrite-strings -Wmissing-prototypes

View file

@ -1,28 +0,0 @@
$NetBSD: patch-ae,v 1.1 2000/04/21 06:46:12 sakamoto Exp $
--- global/global.1.orig Tue Jan 25 17:52:23 2000
+++ global/global.1 Fri Mar 24 05:14:26 2000
@@ -109,6 +109,7 @@
print the locations of specified symbol other than function names.
You need GSYMS tags file. See
.Xr gtags 1 .
+.El
.Sh OPTIONS
The following options are available:
.Bl -tag -width Ds
@@ -131,6 +132,7 @@
.It Fl x
In addition to the default output, produce the line number and
the line contents.
+.El
.Sh FILES
.Bl -tag -width tags -compact
.It Pa GTAGS
@@ -155,6 +157,7 @@
If this variable is set, its value is used as the path to search for library
functions. If specified function is not found in a source tree,
global search in these path too.
+.El
.Sh DIAGNOSTICS
.Nm Global
exits with a non 0 value if an error occurred, 0 otherwise.

View file

@ -1,20 +0,0 @@
$NetBSD: patch-af,v 1.1 2000/04/21 06:46:13 sakamoto Exp $
--- htags/htags.1.orig Fri Aug 27 17:16:30 1999
+++ htags/htags.1 Fri Mar 24 05:18:25 2000
@@ -103,6 +103,7 @@
.It Ar dir
The directory in which hypertext is generated. The default is the current
directory.
+.El
.Sh EXAMPLES
% cd /usr/src/sys
# gtags
@@ -124,6 +125,7 @@
.It Ev TMPDIR
If this variable is set, its value is used as the directory to make temporary files.
The default is /tmp.
+.El
.Sh DIAGNOSTICS
.Nm Htags
exits with a non 0 value if an error occurred, 0 otherwise.

View file

@ -1,17 +1,16 @@
@comment $NetBSD: PLIST,v 1.3 2000/09/09 14:58:50 wiz Exp $
@comment $NetBSD: PLIST,v 1.4 2000/10/08 23:25:31 abs Exp $
bin/btreeop
bin/gctags
bin/global
bin/gtags
bin/htags
lib/libgloutil.a
lib/libgloutil_pic.a
libdata/lint/llib-lgloutil.ln
man/cat1/btreeop.0
man/cat1/gctags.0
man/cat1/global.0
man/cat1/gtags.0
@unexec install-info --delete --info-dir=%D/info %D/info/global.info
info/global.info
@exec install-info --info-dir=%D/info %D/info/global.info
man/man1/btreeop.1
man/man1/gctags.1
man/man1/global.1
man/man1/gtags.1
man/man1/htags.1
@comment @exec /bin/mkdir -p /usr/pkg/libdata/lint
@comment @dirrm libdata/lint