Update to 5.5.3.2. Changes include lots of bugfixes and some enhancements,
in particular JNG support.
This commit is contained in:
parent
50c4c828a3
commit
544917950e
6 changed files with 44 additions and 62 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.88 2002/11/13 19:17:18 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.89 2003/01/03 23:04:35 wiz Exp $
|
||||
|
||||
DISTNAME= ImageMagick-5.5.1-6
|
||||
PKGNAME= ${DISTNAME:S/-6/.6/}
|
||||
PKGREVISION= 1
|
||||
DISTNAME= ImageMagick-${IM_MAJOR_VER}-${IM_MINOR_VER}
|
||||
PKGNAME= ImageMagick-${IM_MAJOR_VER}.${IM_MINOR_VER}
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.nluug.nl/pub/ImageMagick/ \
|
||||
ftp://ftp.yggdrasil.com/mirrors/site/ftp.simplesystems.org/pub/ImageMagick/ \
|
||||
|
@ -14,9 +13,12 @@ MAINTAINER= tron@netbsd.org
|
|||
HOMEPAGE= http://www.simplesystems.org/ImageMagick/
|
||||
COMMENT= Package for display and interactive manipulation of images
|
||||
|
||||
DEPENDS+= mpeg2codec-1.2:../../graphics/mpeg2codec
|
||||
|
||||
CONFLICTS= geomview-[0-9]* # both have a program named 'animate'
|
||||
|
||||
DEPENDS+= mpeg2codec-1.2:../../graphics/mpeg2codec
|
||||
IM_MAJOR_VER= 5.5.3
|
||||
IM_MINOR_VER= 2
|
||||
|
||||
USE_BUILDLINK2= YES
|
||||
USE_X11= YES
|
||||
|
@ -24,7 +26,9 @@ GNU_CONFIGURE= YES
|
|||
USE_LIBTOOL= YES
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/-6//}
|
||||
WRKSRC= ${WRKDIR}/ImageMagick-${IM_MAJOR_VER}
|
||||
|
||||
PLIST_SUBST+= IM_MAJOR_VER=${IM_MAJOR_VER}
|
||||
|
||||
# c++ broken as of 'gcc version 2.95.3 20010315 (release) (NetBSD nb1)'
|
||||
NOT_FOR_PLATFORM= NetBSD-*-sparc64
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.7 2002/11/13 19:17:18 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.8 2003/01/03 23:04:36 wiz Exp $
|
||||
bin/Magick++-config
|
||||
bin/Magick-config
|
||||
bin/animate
|
||||
|
@ -43,32 +43,39 @@ include/magick/magick.h
|
|||
include/magick/magick_config.h
|
||||
include/magick/module.h
|
||||
include/magick/monitor.h
|
||||
include/magick/paint.h
|
||||
include/magick/quantize.h
|
||||
include/magick/random.h
|
||||
include/magick/registry.h
|
||||
include/magick/render.h
|
||||
include/magick/resource.h
|
||||
include/magick/semaphore.h
|
||||
include/magick/signature.h
|
||||
include/magick/timer.h
|
||||
include/magick/utility.h
|
||||
include/magick/version.h
|
||||
include/magick/widget.h
|
||||
include/magick/xwindow.h
|
||||
lib/ImageMagick-5.5.1/colors.mgk
|
||||
lib/ImageMagick-5.5.1/delegates.mgk
|
||||
lib/ImageMagick-5.5.1/log.mgk
|
||||
lib/ImageMagick-5.5.1/magic.mgk
|
||||
lib/ImageMagick-5.5.1/type-ghostscript.mgk
|
||||
lib/ImageMagick-5.5.1/type-solaris.mgk
|
||||
lib/ImageMagick-5.5.1/type-windows.mgk
|
||||
lib/ImageMagick-5.5.1/type.mgk
|
||||
@exec ${MKDIR} %D/lib/ImageMagick-5.5.1/modules/coders
|
||||
lib/ImageMagick-${IM_MAJOR_VER}/colors.mgk
|
||||
lib/ImageMagick-${IM_MAJOR_VER}/delegates.mgk
|
||||
lib/ImageMagick-${IM_MAJOR_VER}/log.mgk
|
||||
lib/ImageMagick-${IM_MAJOR_VER}/magic.mgk
|
||||
lib/ImageMagick-${IM_MAJOR_VER}/type-ghostscript.mgk
|
||||
lib/ImageMagick-${IM_MAJOR_VER}/type-solaris.mgk
|
||||
lib/ImageMagick-${IM_MAJOR_VER}/type-windows.mgk
|
||||
lib/ImageMagick-${IM_MAJOR_VER}/type.mgk
|
||||
@exec ${MKDIR} %D/lib/ImageMagick-${IM_MAJOR_VER}/modules/coders
|
||||
lib/libMagick++.a
|
||||
lib/libMagick++.la
|
||||
lib/libMagick++-5.5.1.so
|
||||
lib/libMagick++-${IM_MAJOR_VER}.so
|
||||
lib/libMagick++-${IM_MAJOR_VER}.so.0
|
||||
lib/libMagick++-${IM_MAJOR_VER}.so.0.0
|
||||
lib/libMagick++.so
|
||||
lib/libMagick.a
|
||||
lib/libMagick.la
|
||||
lib/libMagick-5.5.1.so
|
||||
lib/libMagick-${IM_MAJOR_VER}.so
|
||||
lib/libMagick-${IM_MAJOR_VER}.so.0
|
||||
lib/libMagick-${IM_MAJOR_VER}.so.0.0
|
||||
lib/libMagick.so
|
||||
man/man1/ImageMagick.1
|
||||
man/man1/Magick++-config.1
|
||||
|
@ -89,7 +96,6 @@ share/ImageMagick/ImageMagick.html
|
|||
share/ImageMagick/QuickStart.txt
|
||||
share/ImageMagick/images/authentica.jpg
|
||||
share/ImageMagick/images/ball.png
|
||||
share/ImageMagick/images/corbis.png
|
||||
share/ImageMagick/images/examples.jpg
|
||||
share/ImageMagick/images/home.png
|
||||
share/ImageMagick/images/logo.png
|
||||
|
@ -161,6 +167,7 @@ share/ImageMagick/www/api/color.html
|
|||
share/ImageMagick/www/api/composite.html
|
||||
share/ImageMagick/www/api/constitute.html
|
||||
share/ImageMagick/www/api/decorate.html
|
||||
share/ImageMagick/www/api/deprecate.html
|
||||
share/ImageMagick/www/api/display.html
|
||||
share/ImageMagick/www/api/draw.html
|
||||
share/ImageMagick/www/api/effect.html
|
||||
|
@ -173,6 +180,7 @@ share/ImageMagick/www/api/magick.html
|
|||
share/ImageMagick/www/api/memory.html
|
||||
share/ImageMagick/www/api/monitor.html
|
||||
share/ImageMagick/www/api/montage.html
|
||||
share/ImageMagick/www/api/paint.html
|
||||
share/ImageMagick/www/api/quantize.html
|
||||
share/ImageMagick/www/api/registry.html
|
||||
share/ImageMagick/www/api/render.html
|
||||
|
@ -228,8 +236,8 @@ share/ImageMagick/www/windows.html
|
|||
@dirrm share/ImageMagick/www
|
||||
@dirrm share/ImageMagick/images
|
||||
@dirrm share/ImageMagick
|
||||
@dirrm lib/ImageMagick-5.5.1/modules/coders
|
||||
@dirrm lib/ImageMagick-5.5.1/modules
|
||||
@dirrm lib/ImageMagick-5.5.1
|
||||
@dirrm lib/ImageMagick-${IM_MAJOR_VER}/modules/coders
|
||||
@dirrm lib/ImageMagick-${IM_MAJOR_VER}/modules
|
||||
@dirrm lib/ImageMagick-${IM_MAJOR_VER}
|
||||
@dirrm include/magick
|
||||
@dirrm include/Magick++
|
||||
|
|
|
@ -1,6 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.11 2002/11/13 19:17:18 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.12 2003/01/03 23:04:36 wiz Exp $
|
||||
|
||||
SHA1 (ImageMagick-5.5.1-6.tar.bz2) = c5ddd8904332027e71264a3ea893720cbee06b4a
|
||||
Size (ImageMagick-5.5.1-6.tar.bz2) = 3328933 bytes
|
||||
SHA1 (patch-ac) = fcc9b5518bf876a7937f3afb2d73f9a2a7948a74
|
||||
SHA1 (patch-ad) = 74f1acf61935cfaae3d2ea44a80f74598ed418b9
|
||||
SHA1 (ImageMagick-5.5.3-2.tar.bz2) = cb557cb06d9b9ed595b3910ac73efd65dc3f8f6b
|
||||
Size (ImageMagick-5.5.3-2.tar.bz2) = 3391584 bytes
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.10 2002/11/13 13:44:43 wiz Exp $
|
||||
|
||||
--- coders/fits.c.orig Sat Oct 12 18:41:32 2002
|
||||
+++ coders/fits.c
|
||||
@@ -185,9 +185,11 @@ static Image *ReadFITSImage(const ImageI
|
||||
k,
|
||||
l,
|
||||
packet_size,
|
||||
- quantum,
|
||||
scene,
|
||||
y;
|
||||
+
|
||||
+ int32_t
|
||||
+ quantum;
|
||||
|
||||
register IndexPacket
|
||||
*indexes;
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.7 2002/11/13 13:44:44 wiz Exp $
|
||||
|
||||
--- coders/jp2.c.orig Sun Nov 10 15:33:57 2002
|
||||
+++ coders/jp2.c
|
||||
@@ -604,7 +604,7 @@ static unsigned int WriteJP2Image(const
|
||||
component_info[i].prec=(unsigned int) image->depth <= 8 ? 8 : 16;
|
||||
}
|
||||
jp2_image=jas_image_create((short) number_components,component_info,
|
||||
- number_components == 1 ? JAS_IMAGE_CM_GRAY : JAS_IMAGE_CM_RGB);
|
||||
+ number_components == 1 ? JAS_IMAGE_CS_GRAY : JAS_IMAGE_CS_RGB);
|
||||
if (jp2_image == (jas_image_t *) NULL)
|
||||
ThrowWriterException(FileOpenError,"Unable to create image",image);
|
||||
/*
|
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.23 2002/12/29 21:33:17 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.24 2003/01/03 23:04:39 wiz Exp $
|
||||
|
||||
DISTNAME= ImageMagick-5.5.1-6
|
||||
PKGNAME= p5-PerlMagick-5.5.1.6
|
||||
PKGREVISION= 2
|
||||
DISTNAME= ImageMagick-${IM_MAJOR_VER}-${IM_MINOR_VER}
|
||||
PKGNAME= p5-PerlMagick-${IM_MAJOR_VER}.${IM_MINOR_VER}
|
||||
SVR4_PKGNAME= p5pma
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.nluug.nl/pub/ImageMagick/ \
|
||||
|
@ -18,6 +17,9 @@ DISTINFO_FILE= ${.CURDIR}/../../graphics/ImageMagick/distinfo
|
|||
FILESDIR= ${.CURDIR}/../../graphics/ImageMagick/files
|
||||
PATCHDIR= ${.CURDIR}/../../graphics/ImageMagick/patches
|
||||
|
||||
IM_MAJOR_VER= 5.5.3
|
||||
IM_MINOR_VER= 2
|
||||
|
||||
USE_LIBTOOL= YES
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
|
||||
|
@ -30,7 +32,7 @@ PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Image/Magick/.packlist
|
|||
GNU_CONFIGURE= YES
|
||||
USE_X11= YES
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME:S/-6//}
|
||||
WRKSRC= ${WRKDIR}/ImageMagick-${IM_MAJOR_VER}
|
||||
PERL5_CONFIGURE_DIRS= ${WRKSRC}/PerlMagick
|
||||
BUILD_DIRS= ${PERL5_CONFIGURE_DIRS}
|
||||
|
||||
|
|
Loading…
Reference in a new issue