Remove outdated program, replaced by graphics/fotoxx.
This commit is contained in:
parent
e156a2c570
commit
547d514046
6 changed files with 0 additions and 179 deletions
|
@ -1 +0,0 @@
|
|||
Simple image manipulation program
|
|
@ -1,43 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.4 2008/03/04 15:39:09 jlam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= fotox.34
|
||||
PKGNAME= fotox-34
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://kornelix.squarespace.com/storage/fotox/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://kornelix.squarespace.com/fotox/
|
||||
COMMENT= Simple image manipulation program
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
WRKSRC= ${WRKDIR}/fotox
|
||||
USE_LANGUAGES= c++
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
FDATA= ${PREFIX}/share/fotox
|
||||
|
||||
SUBST_CLASSES+= data
|
||||
SUBST_STAGE.data= pre-build
|
||||
SUBST_FILES.data= zfuncs.cpp
|
||||
SUBST_VARS.data= FDATA
|
||||
|
||||
INSTALLATION_DIRS= bin share/applications
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC} && ${SH} build ${PREFIX} y)
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/fotox ${DESTDIR}${PREFIX}/bin
|
||||
${INSTALL_DATA_DIR} ${DESTDIR}${FDATA}
|
||||
${INSTALL_DATA} ${WRKSRC}/parameters.txt ${DESTDIR}${FDATA}
|
||||
${CP} -r ${WRKSRC}/icons ${DESTDIR}${FDATA}
|
||||
${INSTALL_DATA} ${WRKSRC}/fotox-guide.pdf ${DESTDIR}${FDATA}
|
||||
${INSTALL_DATA} ${WRKSRC}/*.xtext ${DESTDIR}${FDATA}
|
||||
${INSTALL_DATA} ${WRKSRC}/fotox.desktop \
|
||||
${DESTDIR}${PREFIX}/share/applications
|
||||
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,43 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2008/01/09 19:21:08 drochner Exp $
|
||||
bin/fotox
|
||||
share/applications/fotox.desktop
|
||||
share/fotox/fotox-guide.pdf
|
||||
share/fotox/fotox.xtext
|
||||
share/fotox/icons/HDR.png
|
||||
share/fotox/icons/bigger.png
|
||||
share/fotox/icons/blank.png
|
||||
share/fotox/icons/crop.png
|
||||
share/fotox/icons/exif.png
|
||||
share/fotox/icons/exif2.png
|
||||
share/fotox/icons/fotox.png
|
||||
share/fotox/icons/fotox1.png
|
||||
share/fotox/icons/goto-end.png
|
||||
share/fotox/icons/goto-top.png
|
||||
share/fotox/icons/help.png
|
||||
share/fotox/icons/index.png
|
||||
share/fotox/icons/kill.png
|
||||
share/fotox/icons/next-page.png
|
||||
share/fotox/icons/next-row.png
|
||||
share/fotox/icons/next.png
|
||||
share/fotox/icons/open.png
|
||||
share/fotox/icons/pano.png
|
||||
share/fotox/icons/parms.png
|
||||
share/fotox/icons/prev-page.png
|
||||
share/fotox/icons/prev-row.png
|
||||
share/fotox/icons/prev.png
|
||||
share/fotox/icons/quit.png
|
||||
share/fotox/icons/redeye.png
|
||||
share/fotox/icons/redeye1.png
|
||||
share/fotox/icons/redo.png
|
||||
share/fotox/icons/resize.png
|
||||
share/fotox/icons/rotate.png
|
||||
share/fotox/icons/save.png
|
||||
share/fotox/icons/smaller.png
|
||||
share/fotox/icons/trash.png
|
||||
share/fotox/icons/tune.png
|
||||
share/fotox/icons/unbend.png
|
||||
share/fotox/icons/undo.png
|
||||
share/fotox/parameters.txt
|
||||
share/fotox/zfuncs.xtext
|
||||
@dirrm share/fotox/icons
|
||||
@dirrm share/fotox
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/01/09 19:21:08 drochner Exp $
|
||||
|
||||
SHA1 (fotox.34.tar.gz) = 219a8d84bd231c97d8eea10d55c3bc6d5779425c
|
||||
RMD160 (fotox.34.tar.gz) = 774e2fd2934b6720b31199d12ae1047cb2326f1e
|
||||
Size (fotox.34.tar.gz) = 1547843 bytes
|
||||
SHA1 (patch-aa) = bc49037c49944db7b097c4123f9735c0198ea02e
|
||||
SHA1 (patch-ab) = 63e3c6311835d97aadef852a03f528ece47bd61c
|
|
@ -1,37 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2008/01/09 19:21:09 drochner Exp $
|
||||
|
||||
--- zfuncs.cpp.orig 2008-01-02 09:14:04.000000000 +0100
|
||||
+++ zfuncs.cpp
|
||||
@@ -2150,26 +2150,15 @@ char zexedirk[1000], zappdirk[200],
|
||||
|
||||
void initz_appfiles(const char *appfile, ...) // null terminator v.07
|
||||
{
|
||||
- char command[1200], *pp;
|
||||
- int fcc, err;
|
||||
+ char command[1200];
|
||||
+ int err;
|
||||
struct stat statdat;
|
||||
va_list arglist;
|
||||
|
||||
- fcc = readlink("/proc/self/exe",zexedirk,999); // get /dirk-path/appname
|
||||
- if (fcc <= 0) fcc = readlink("/proc/curproc/file",zexedirk,999); // BSD version v.13
|
||||
- if (fcc < 3 || fcc > 997) zappcrash("cannot find executable location");
|
||||
- zexedirk[fcc] = 0;
|
||||
- pp = strrchr(zexedirk,'/');
|
||||
- if (! pp) zappcrash("cannot find executable location");
|
||||
- *pp = 0;
|
||||
-
|
||||
- strncpy0(zappname,pp+1,39); // appname [ .exe ]
|
||||
- pp = strrchr(zappname,'.');
|
||||
- if (pp) *pp = 0;
|
||||
-
|
||||
- pp = cuserid(0); // get /home/user/.appname/
|
||||
- if (strEqu(pp,"root")) snprintf(zappdirk,199,"/root/.%s",zappname);
|
||||
- else snprintf(zappdirk,199,"%s/.%s",getenv("HOME"),zappname); // use HOME variable v.13
|
||||
+ strncpy0(zexedirk, "/usr/pkg/share/fotox", 999);
|
||||
+ strncpy0(zappname,"fotox",39);
|
||||
+
|
||||
+ snprintf(zappdirk,199,"%s/.%s",getenv("HOME"),zappname); // use HOME variable v.13
|
||||
|
||||
err = stat(zappdirk,&statdat); // does it exist already?
|
||||
if (err) {
|
|
@ -1,48 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2008/01/09 19:21:45 drochner Exp $
|
||||
|
||||
--- build.orig 2008-01-02 09:14:04.000000000 +0100
|
||||
+++ build
|
||||
@@ -41,23 +41,6 @@ else
|
||||
fi
|
||||
fi
|
||||
|
||||
-mkdir -p -m a+rx $appdirk # create install directory
|
||||
-if [ $? -ne 0 ]
|
||||
-then
|
||||
- echo "*** unable to create or access $appdirk"
|
||||
- echo " (run this script as root if necessary)"
|
||||
- exit 1
|
||||
-fi
|
||||
-
|
||||
-cp -f -r * $appdirk # copy all files there
|
||||
-if [ $? -ne 0 ]
|
||||
-then
|
||||
- echo "*** unable to copy files to install directory"
|
||||
- exit 1
|
||||
-fi
|
||||
-rm -f -r * # clean up
|
||||
-
|
||||
-cd $appdirk # build executable
|
||||
g++ -O -Wall -o $appname $appname.cpp zfuncs.cpp \
|
||||
$(pkg-config --cflags gtk+-2.0 --libs gtk+-2.0 gthread-2.0)
|
||||
if [ $? -ne 0 ]; then exit 1; fi
|
||||
@@ -66,7 +49,7 @@ echo "$appname build successful"
|
||||
chmod a+rx $appname # set access for all users
|
||||
chmod -R a+r *
|
||||
|
||||
-launcher=$HOME/Desktop/$appname.desktop
|
||||
+launcher=$appname.desktop
|
||||
yn=$2 # yn << parameter
|
||||
|
||||
if [ -z "$yn" ]
|
||||
@@ -83,8 +66,8 @@ then
|
||||
echo "Name=$appname" >> $launcher
|
||||
echo "Type=Application" >> $launcher
|
||||
echo "Terminal=false" >> $launcher
|
||||
- echo "Exec=$appdirk/$appname" >> $launcher
|
||||
- echo "Icon=$appdirk/icons/$appname.png" >> $launcher
|
||||
+ echo "Exec=$appdirk/bin/$appname" >> $launcher
|
||||
+ echo "Icon=$appdirk/share/fotox/icons/$appname.png" >> $launcher
|
||||
fi; fi
|
||||
|
||||
exit 0
|
Loading…
Reference in a new issue