Thanks to @@@'s new macros we need another patch now.

This commit is contained in:
christos 2004-04-15 14:37:22 +00:00
parent 0796a62243
commit 548f4ec292
2 changed files with 20 additions and 1 deletions

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.9 2003/11/11 07:57:42 wiz Exp $
$NetBSD: distinfo,v 1.10 2004/04/15 14:37:22 christos Exp $
SHA1 (xosview-1.8.1.tar.gz) = 3b74fb0cf01c99ff0a2da3d1f028bb32e4043e8e
Size (xosview-1.8.1.tar.gz) = 237724 bytes
SHA1 (patch-aa) = cc3de3bb4130724df543f85705b19946fba2577a

View file

@ -0,0 +1,18 @@
$NetBSD: patch-aa,v 1.10 2004/04/15 14:37:22 christos Exp $
--- bsd/kernel.cc.orig 2003-10-13 21:53:17.000000000 -0400
+++ bsd/kernel.cc 2004-04-15 10:16:49.000000000 -0400
@@ -817,11 +817,11 @@
#if defined(NETBSD_1_6A)
// Use the new sysctl to do this for us.
int mib[3] = {CTL_HW, HW_DISKSTATS, sizeof(struct disk_sysctl)};
- size_t sysctl_size = NetBSD_N_Drives * sizeof(struct disk_sysctl);
+ size_t sysctl_sz = NetBSD_N_Drives * sizeof(struct disk_sysctl);
struct disk_sysctl drive_stats[NetBSD_N_Drives];
// Do the sysctl.
- if (sysctl(mib, 3, drive_stats, &sysctl_size, NULL, 0) < 0) {
+ if (sysctl(mib, 3, drive_stats, &sysctl_sz, NULL, 0) < 0) {
err(1, "sysctl hw.diskstats failed");
}