redis: updated to 6.0.9
Redis 6.0.9 =========== Upgrade urgency: SECURITY if you use an affected platform (see below). Otherwise the upgrade urgency is MODERATE. This release fixes a potential heap overflow when using a heap allocator other than jemalloc or glibc's malloc. See: https://github.com/redis/redis/pull/7963 Other fixes in this release: New: * Memory reporting of clients argv * Add redis-cli control on raw format line delimiter * Add redis-cli support for rediss:// -u prefix * Get rss size support for NetBSD and DragonFlyBSD Behavior changes: * WATCH no longer ignores keys which have expired for MULTI/EXEC * Correct OBJECT ENCODING response for stream type * Allow blocked XREAD on a cluster replica * TLS: Do not require CA config if not used Bug fixes: * INFO report real peak memory (before eviction) * Allow requirepass config to clear the password * Fix config rewrite file handling to make it really atomic * Fix excessive categories being displayed from ACLs * Add fsync in replica when full RDB payload was received * Don't write replies to socket when output buffer limit reached * Fix redis-check-rdb support for modules aux data * Other smaller bug fixes Modules API: * Add APIs for version and compatibility checks * Add RM_GetClientCertificate * Add RM_GetDetachedThreadSafeContext * Add RM_GetCommandKeys * Add Swapdb Module Event * RM_GetContextFlags provides indication of being in a fork child * RM_GetContextFlags document missing flags: MULTI_DIRTY, IS_CHILD * Expose real client on connection events * Minor improvements to module blocked on keys
This commit is contained in:
parent
5dfed7f9a1
commit
54db4b1ecc
4 changed files with 17 additions and 17 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.61 2020/09/11 09:25:18 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.62 2020/10/27 10:22:34 adam Exp $
|
||||
|
||||
DISTNAME= redis-6.0.8
|
||||
DISTNAME= redis-6.0.9
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://download.redis.io/releases/
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.54 2020/09/11 09:25:18 adam Exp $
|
||||
$NetBSD: distinfo,v 1.55 2020/10/27 10:22:34 adam Exp $
|
||||
|
||||
SHA1 (redis-6.0.8.tar.gz) = 2a7b190fc8d9f7e448e1703d353687e19972f195
|
||||
RMD160 (redis-6.0.8.tar.gz) = 09831bbb17e1c4850964389201036027c8195ed3
|
||||
SHA512 (redis-6.0.8.tar.gz) = 49d1ef623c330716c035f6dfd5a4754af4d53b6ec5ea7366fecf9dd90290968893e9f2375e191e7075db563180044c30e58a63624d352ecb5413449c6136e21a
|
||||
Size (redis-6.0.8.tar.gz) = 2247528 bytes
|
||||
SHA1 (redis-6.0.9.tar.gz) = 416ab41ac74be959ad4192462eecaa8ba9a6d3b7
|
||||
RMD160 (redis-6.0.9.tar.gz) = 685cc12eb7d2b14f42dd5fcdabcd18e625e5e4d1
|
||||
SHA512 (redis-6.0.9.tar.gz) = ebae2b09637fdbdc71dd22b72ccea24e2c21beb81c6ff5c4bae8b341886a7d847ce868f52dc917079bab8aa250ff61c83efe8acbb8a1cbc5e285c7842b0aefa3
|
||||
Size (redis-6.0.9.tar.gz) = 2261418 bytes
|
||||
SHA1 (patch-redis.conf) = 528c28e2b7483eb20ccab8f2ab9543822792f016
|
||||
SHA1 (patch-src_Makefile) = 17043eeff933b5eb2ffb37d2c27263939b39bf6d
|
||||
SHA1 (patch-src_hyperloglog.c) = 65a4a220ccd4282162c50293f4fe278a43b84239
|
||||
SHA1 (patch-src_Makefile) = 5c5be572f50d0db6b050a9d83fc30a28e8fa9856
|
||||
SHA1 (patch-src_hyperloglog.c) = e9bdd3c630024a6fbe02c2c1d85e26131ad938cf
|
||||
SHA1 (patch-src_object.c) = 30ffaec9c7e6135e3a5576cd1a35d7bcec668299
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-src_Makefile,v 1.2 2020/05/03 11:31:39 adam Exp $
|
||||
$NetBSD: patch-src_Makefile,v 1.3 2020/10/27 10:22:34 adam Exp $
|
||||
|
||||
Add DESTDIR support.
|
||||
Fix NetBSD support.
|
||||
|
||||
--- src/Makefile.orig 2020-05-01 22:10:20.000000000 +0000
|
||||
--- src/Makefile.orig 2020-10-27 07:12:01.000000000 +0000
|
||||
+++ src/Makefile
|
||||
@@ -30,8 +30,8 @@ WARN=-Wall -W -Wno-missing-field-initial
|
||||
OPT=$(OPTIMIZATION)
|
||||
|
@ -16,9 +16,9 @@ Fix NetBSD support.
|
|||
PKG_CONFIG?=pkg-config
|
||||
|
||||
# Default allocator defaults to Jemalloc if it's not an ARM
|
||||
@@ -121,6 +121,10 @@ ifeq ($(uname_S),OpenBSD)
|
||||
@@ -130,6 +130,10 @@ ifeq ($(uname_S),NetBSD)
|
||||
FINAL_LIBS+= -lexecinfo
|
||||
endif
|
||||
|
||||
else
|
||||
+ifeq ($(uname_S),NetBSD)
|
||||
+ # NetBSD
|
||||
|
@ -27,7 +27,7 @@ Fix NetBSD support.
|
|||
ifeq ($(uname_S),FreeBSD)
|
||||
# FreeBSD
|
||||
FINAL_LIBS+= -lpthread -lexecinfo
|
||||
@@ -138,6 +142,7 @@ endif
|
||||
@@ -165,6 +169,7 @@ endif
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-src_hyperloglog.c,v 1.1 2018/04/23 14:57:57 fhajny Exp $
|
||||
$NetBSD: patch-src_hyperloglog.c,v 1.2 2020/10/27 10:22:34 adam Exp $
|
||||
|
||||
Fix the case of the missing llroundl on NetBSD. Patch by Matthias Petermann.
|
||||
|
||||
--- src/hyperloglog.c.orig 2018-03-26 16:04:15.000000000 +0000
|
||||
--- src/hyperloglog.c.orig 2020-10-27 07:12:01.000000000 +0000
|
||||
+++ src/hyperloglog.c
|
||||
@@ -34,6 +34,16 @@
|
||||
#include <stdint.h>
|
||||
|
@ -20,4 +20,4 @@ Fix the case of the missing llroundl on NetBSD. Patch by Matthias Petermann.
|
|||
+
|
||||
/* The Redis HyperLogLog implementation is based on the following ideas:
|
||||
*
|
||||
* * The use of a 64 bit hash function as proposed in [1], in order to don't
|
||||
* * The use of a 64 bit hash function as proposed in [1], in order to estimate
|
||||
|
|
Loading…
Reference in a new issue