tigervnc: update to 1.10.1nb1.
Use xorg-server-1.19.6 sources. (1.20.7 didn't compile because of missing 'ddxInputThreadInit' symbol.)
This commit is contained in:
parent
5c41b05446
commit
54ff642f63
3 changed files with 9 additions and 81 deletions
|
@ -1,10 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.30 2020/03/13 10:18:43 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.31 2020/03/13 10:30:47 wiz Exp $
|
||||
|
||||
DISTNAME= tigervnc-1.10.1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=TigerVNC/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
XORG_SERVER_FILE= xorg-server-1.17.2
|
||||
XORG_SERVER_FILE= xorg-server-1.19.6
|
||||
SITES.${XORG_SERVER_FILE}.tar.bz2= ${MASTER_SITE_XORG:=xserver/}
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${XORG_SERVER_FILE}.tar.bz2
|
||||
|
||||
|
@ -46,7 +47,7 @@ post-extract:
|
|||
cp -r ${WRKDIR}/${XORG_SERVER_FILE}/* ${WRKSRC}/unix/xserver
|
||||
|
||||
post-patch:
|
||||
cd ${WRKSRC}/unix/xserver && ${PATCH} --batch -p1 <../xserver117.patch
|
||||
cd ${WRKSRC}/unix/xserver && ${PATCH} --batch -p1 <../xserver119.patch
|
||||
|
||||
XORG_CONFIGURE_ARGS+= --prefix=${PREFIX} --mandir=${PREFIX}/${PKGMANDIR}
|
||||
XORG_CONFIGURE_ARGS+= --disable-xwayland --disable-kdrive --disable-xephyr
|
||||
|
|
|
@ -1,16 +1,15 @@
|
|||
$NetBSD: distinfo,v 1.14 2020/03/13 10:18:43 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.15 2020/03/13 10:30:47 wiz Exp $
|
||||
|
||||
SHA1 (tigervnc-1.10.1.tar.gz) = 34efc6e2e67be672dca38c10ce064bcb08adee9f
|
||||
RMD160 (tigervnc-1.10.1.tar.gz) = 42e17e14d2780e1d6bc2c7a4f89145e50f630706
|
||||
SHA512 (tigervnc-1.10.1.tar.gz) = 3486ff772d39217feb8c075860cae58e1021bdb8095443d8b5c383929cc6c622b57ea61c31d06ff0bd48c7e6889db4b6a99d0742bdd60edf323fb2a3ad328705
|
||||
Size (tigervnc-1.10.1.tar.gz) = 1408105 bytes
|
||||
SHA1 (xorg-server-1.17.2.tar.bz2) = 56ac29a82b99bcf4c7ba2fca41a44cfa18748262
|
||||
RMD160 (xorg-server-1.17.2.tar.bz2) = bf575a269f1e7b729992a20989be84e09fcc88a2
|
||||
SHA512 (xorg-server-1.17.2.tar.bz2) = 7e7b7620890cc8db696695758fa22fa879f9d3c33946663611ec0b37f02116e9c6f08779f9eece59907b430d3df93f0c0548939683ea156b3c4cbe02571b7551
|
||||
Size (xorg-server-1.17.2.tar.bz2) = 5767983 bytes
|
||||
SHA1 (xorg-server-1.19.6.tar.bz2) = 2dd560ac49bdbda7f67166546af43541fabf517f
|
||||
RMD160 (xorg-server-1.19.6.tar.bz2) = c2b6f9fe3957c99cddd44bc3ae38343a1c4f314e
|
||||
SHA512 (xorg-server-1.19.6.tar.bz2) = 38519a8d0af9dd034045fc346959496dd718fa59b6188307974797a1cd9c349deb54987f6232ea8396baf810dcc710c0ff191f76ed2186cae4d44921b3680412
|
||||
Size (xorg-server-1.19.6.tar.bz2) = 5984528 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 42a364f898784a9c4da46bea8ef6bc37838815b9
|
||||
SHA1 (patch-media_CMakeLists.txt) = cd50f9b7a9405aa523412ef823a32437a3c19ffa
|
||||
SHA1 (patch-unix_vncserver) = 9c71ad02c6657f537bcb2abaa116a831b555d7c0
|
||||
SHA1 (patch-unix_xserver117.patch) = 5e5d2a98f0b765ae0d6bb5f200808126b03dcc51
|
||||
SHA1 (patch-unix_xserver_hw_vnc_Makefile.am) = 29b33e6d94a070bb0a55a264cd1c4e120c9b1b3c
|
||||
SHA1 (patch-unix_xserver_hw_vnc_vncModule.c) = 77aff6c2bb19e6936302c783b72d581e7d6388f5
|
||||
|
|
|
@ -1,72 +0,0 @@
|
|||
$NetBSD: patch-unix_xserver117.patch,v 1.5 2017/09/13 08:33:03 wiz Exp $
|
||||
|
||||
--- unix/xserver117.patch.orig 2015-07-11 13:00:36.000000000 +0000
|
||||
+++ unix/xserver117.patch
|
||||
@@ -85,7 +85,24 @@ diff -up xorg-server-1.17.1/mi/miinitext
|
||||
diff -up xorg-server-1.17.1/os/WaitFor.c.vnc xorg-server-1.17.1/os/WaitFor.c
|
||||
--- xorg-server-1.17.1/os/WaitFor.c.vnc 2015-01-26 18:40:30.000000000 +0000
|
||||
+++ xorg-server-1.17.1/os/WaitFor.c 2015-02-13 16:14:05.132516837 +0000
|
||||
-@@ -125,6 +125,9 @@ static void DoTimer(OsTimerPtr timer, CA
|
||||
+@@ -52,6 +52,8 @@
|
||||
+ *
|
||||
+ *****************************************************************/
|
||||
+
|
||||
++#include <X11/Xpoll.h>
|
||||
++
|
||||
+ #ifdef HAVE_DIX_CONFIG_H
|
||||
+ #include <dix-config.h>
|
||||
+ #endif
|
||||
+@@ -66,7 +68,6 @@
|
||||
+ #include "misc.h"
|
||||
+
|
||||
+ #include "osdep.h"
|
||||
+-#include <X11/Xpoll.h>
|
||||
+ #include "dixstruct.h"
|
||||
+ #include "opaque.h"
|
||||
+ #ifdef DPMSExtension
|
||||
+@@ -125,6 +126,9 @@
|
||||
static void CheckAllTimers(void);
|
||||
static volatile OsTimerPtr timers = NULL;
|
||||
|
||||
@@ -135,3 +152,41 @@ diff -up xorg-server-1.17.1/os/WaitFor.c
|
||||
if (i <= 0) { /* An error or timeout occurred */
|
||||
if (dispatchException)
|
||||
return 0;
|
||||
+--- xorg-server-1.17.1/os/connection.c.orig 2015-07-22 08:50:52.000000000 +1200
|
||||
++++ xorg-server-1.17.1/os/connection.c 2015-07-22 08:54:35.000000000 +1200
|
||||
+@@ -60,6 +60,8 @@
|
||||
+ *
|
||||
+ *****************************************************************/
|
||||
+
|
||||
++#include <X11/Xpoll.h>
|
||||
++
|
||||
+ #ifdef HAVE_DIX_CONFIG_H
|
||||
+ #include <dix-config.h>
|
||||
+ #endif
|
||||
+@@ -103,7 +105,6 @@
|
||||
+ #endif /* WIN32 */
|
||||
+ #include "misc.h" /* for typedef of pointer */
|
||||
+ #include "osdep.h"
|
||||
+-#include <X11/Xpoll.h>
|
||||
+ #include "opaque.h"
|
||||
+ #include "dixstruct.h"
|
||||
+ #include "xace.h"
|
||||
+--- xorg-server-1.17.1/os/io.c.orig 2015-07-22 08:50:52.000000000 +1200
|
||||
++++ xorg-server-1.17.1/os/io.c 2015-07-22 08:55:03.000000000 +1200
|
||||
+@@ -51,6 +51,8 @@
|
||||
+ *
|
||||
+ *****************************************************************/
|
||||
+
|
||||
++#include <X11/Xpoll.h>
|
||||
++
|
||||
+ #ifdef HAVE_DIX_CONFIG_H
|
||||
+ #include <dix-config.h>
|
||||
+ #endif
|
||||
+@@ -74,7 +76,6 @@
|
||||
+ #include <X11/Xproto.h>
|
||||
+ #include "os.h"
|
||||
+ #include "osdep.h"
|
||||
+-#include <X11/Xpoll.h>
|
||||
+ #include "opaque.h"
|
||||
+ #include "dixstruct.h"
|
||||
+ #include "misc.h"
|
Loading…
Reference in a new issue