Make this package work on Solaris:

+ Makefile patches to work out what OS is being used.
+ Solaris 2.6 (at least) has herror, so don't try to redefine it
+ Pass down CC value from package Makefile
+ Don't pass down Zoularis CPPFLAGS from package Makefile
+ Regen patch-sum file
This commit is contained in:
agc 1999-08-05 13:09:27 +00:00
parent b4ba7a4bee
commit 55185663ec
4 changed files with 64 additions and 13 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 1999/05/01 18:23:51 tv Exp $
# $NetBSD: Makefile,v 1.7 1999/08/05 13:09:27 agc Exp $
#
DISTNAME= export.socks.cstc.4.2.2
@ -18,6 +18,12 @@ WRKSRC= ${WRKDIR}/socks.cstc.4.2
NO_CONFIGURE= yes
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "SunOS"
MAKE_ENV+= CC=gcc CPPFLAGS=
.endif
post-patch:
@${SED} -e 's|@PREFIX@|${PREFIX}|g' ${WRKSRC}/include/socks.h \
> ${WRKSRC}/include/socks.h.new && \

View file

@ -1,7 +1,8 @@
$NetBSD: patch-sum,v 1.1 1999/07/09 14:12:29 agc Exp $
$NetBSD: patch-sum,v 1.2 1999/08/05 13:09:28 agc Exp $
MD5 (patch-aa) = 6c1f37cda8393ca8c9c57c669f12cbbe
MD5 (patch-aa) = b5acded2962bb46ba0d9c3ee70d91ccb
MD5 (patch-ab) = 55d17cbdd564c05678fb067355813836
MD5 (patch-ac) = a95ac3a592ff00ce164d76071a7bfab4
MD5 (patch-ad) = aed0e76bf3633f84f49c021a1399ed71
MD5 (patch-ae) = e1160c62b1d4a177e1568833ef79867a
MD5 (patch-af) = efc57c062ec2cc7e5db84bd011f731b9

View file

@ -1,9 +1,13 @@
$NetBSD: patch-aa,v 1.4 1999/02/10 15:16:46 frueauf Exp $
$NetBSD: patch-aa,v 1.5 1999/08/05 13:09:28 agc Exp $
--- Makefile.orig Wed Sep 6 19:24:02 1995
+++ Makefile Tue Jan 19 15:53:43 1999
@@ -5,7 +5,7 @@
--- Makefile.orig Thu Sep 7 03:24:02 1995
+++ Makefile Thu Aug 5 13:50:46 1999
@@ -3,9 +3,11 @@
SHELL=/bin/sh
+OPSYS!= uname -s
+
#SOCKS=-DSOCKS
# or
-SOCKS=-Dconnect=Rconnect -Dgetsockname=Rgetsockname -Dlisten=Rlisten -Daccept=Raccept -Drcmd=Rrcmd -Dbind=Rbind -Dselect=Rselect
@ -11,7 +15,7 @@ $NetBSD: patch-aa,v 1.4 1999/02/10 15:16:46 frueauf Exp $
# If the second definition of SOCKS is used, you MUST also
# define SHORTENED_RBIND
@@ -19,7 +19,7 @@
@@ -19,7 +21,7 @@
# It should be this current directory.
# If your system has getcwd() but no getwd(), uncomment the next line:
@ -20,7 +24,7 @@ $NetBSD: patch-aa,v 1.4 1999/02/10 15:16:46 frueauf Exp $
#If your system doesn't have waitpid(), uncomment the nextline:
#NO_WAITPID=-DNO_WAITPID
@@ -43,16 +43,16 @@
@@ -43,16 +45,16 @@
# Define RCMD and SUPPORT_RCMD if you want to support Rrcmd, which is required
# for SOCKSified rlogin, rsh, and rcp.
@ -41,7 +45,7 @@ $NetBSD: patch-aa,v 1.4 1999/02/10 15:16:46 frueauf Exp $
# Be careful with the OPTIMIZE flag. SunPro's SC2.0.1, for example, is
# knwon to produce incorrect code when -O is used.
@@ -73,13 +73,13 @@
@@ -73,13 +75,13 @@
#BIND_RESOLVER=-DBIND_RESOLVER
# Directory into which to install the man pages
@ -58,7 +62,7 @@ $NetBSD: patch-aa,v 1.4 1999/02/10 15:16:46 frueauf Exp $
# SunOS 4.1.x should use
#CC=cc
@@ -103,13 +103,13 @@
@@ -103,13 +105,13 @@
#GETPASS=getpass.o
# IRIX 5 should use
@ -79,7 +83,30 @@ $NetBSD: patch-aa,v 1.4 1999/02/10 15:16:46 frueauf Exp $
# Ultrix 4.0 should use
#CC=cc
@@ -174,13 +174,13 @@
@@ -156,13 +158,15 @@
#GETPASS=
# SOLARIS should use
-#CC=cc
-#RESOLV_LIB=-lresolv -lnsl -lsocket
-#OTHER_CFLAGS=-DSOLARIS -Dindex=strchr -Drindex=strrchr $(SHORTENED_RBIND) -DUSE_DIRENT $(GETCWD) $(FASCIST) -DCOMPAT $(TRY_PASV)
-#RANLIB=/bin/true
-#OS=solaris2.2
-#INSTALL=install
-#GETPASS=getpass.o
+.if ${OPSYS} == "SunOS"
+#CC=cc
+RESOLV_LIB=-lresolv -lnsl -lsocket
+OTHER_CFLAGS=-DSOLARIS -Dindex=strchr -Drindex=strrchr $(SHORTENED_RBIND) -DUSE_DIRENT $(GETCWD) $(FASCIST) -DCOMPAT $(TRY_PASV)
+RANLIB=/bin/true
+OS=solaris2.2
+INSTALL=install
+GETPASS=getpass.o
+.endif
# Interactive Systems Unix should use
#OTHER_CFLAGS = -DISC -DSVR3 -Dindex=strchr -Drindex=strrchr -D_XOPEN_SOURCE -DGETCWD $(FASCIST) $(SHORTENED_RBIND) -DCOMPAT $(TRY_PASV)
@@ -174,13 +178,15 @@
#RESOLV_LIB=-linet -lc_s
# netBSD should use
@ -90,6 +117,7 @@ $NetBSD: patch-aa,v 1.4 1999/02/10 15:16:46 frueauf Exp $
-#INSTALL=install
-#GETPASS=
-#RESOLV_LIB=
+.if ${OPSYS} == "NetBSD"
+OTHER_CFLAGS = $(GETCWD) $(SHORTENED_RBIND) $(FASCIST) $(TRY_PASV) -Dunix=1
+CC=cc
+RANLIB=ranlib
@ -97,10 +125,11 @@ $NetBSD: patch-aa,v 1.4 1999/02/10 15:16:46 frueauf Exp $
+INSTALL=install -c
+GETPASS=
+RESOLV_LIB=
+.endif
# FreeBSD should use:
#CC=cc
@@ -413,3 +413,11 @@
@@ -413,3 +419,11 @@
( cd $$i ; $(MAKE) clean) done

View file

@ -0,0 +1,15 @@
$NetBSD: patch-af,v 1.1 1999/08/05 13:09:28 agc Exp $
Solaris 2.6 appears to have herror(), so don't redefine it.
--- rftp/ftp.c 1999/08/05 12:56:00 1.1
+++ rftp/ftp.c 1999/08/05 12:56:45
@@ -112,7 +112,7 @@
FILE *cin, *cout;
FILE *dataconn();
-#if !defined(SVR3) && !defined(BIND_RESOLVER) && !defined(LINUX)
+#if !defined(SVR3) && !defined(BIND_RESOLVER) && !defined(LINUX) && !defined(SOLARIS)
/* >>> YDL */
#if !defined(BSD) || (BSD - 43 <= 0)