audio/hts_engine: import hts_engine_API-1.10
The hts_engine API is an API version of hts_engine which has been released since HTS version 1.1. It has been being developed by the HTS working group and some graduate students in Nagoya Institute of Technology.
This commit is contained in:
parent
1432d9a4da
commit
551b2c12d9
6 changed files with 55 additions and 0 deletions
3
audio/hts_engine/DESCR
Normal file
3
audio/hts_engine/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
The hts_engine API is an API version of hts_engine which has been released
|
||||
since HTS version 1.1. It has been being developed by the HTS working group
|
||||
and some graduate students in Nagoya Institute of Technology.
|
14
audio/hts_engine/Makefile
Normal file
14
audio/hts_engine/Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.1 2020/06/22 00:52:42 ryoon Exp $
|
||||
|
||||
DISTNAME= hts_engine_API-1.10
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=hts-engine/}
|
||||
|
||||
MAINTAINER= ryoon@NetBSD.org
|
||||
HOMEPAGE= http://hts-engine.sourceforge.net/
|
||||
COMMENT= Synthesize speech waveform from HMMs trained by HTS
|
||||
LICENSE= modified-bsd
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
4
audio/hts_engine/PLIST
Normal file
4
audio/hts_engine/PLIST
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2020/06/22 00:52:42 ryoon Exp $
|
||||
bin/hts_engine
|
||||
include/HTS_engine.h
|
||||
lib/libHTSEngine.a
|
12
audio/hts_engine/buildlink3.mk
Normal file
12
audio/hts_engine/buildlink3.mk
Normal file
|
@ -0,0 +1,12 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1 2020/06/22 00:52:42 ryoon Exp $
|
||||
|
||||
BUILDLINK_TREE+= hts_engine_API
|
||||
|
||||
.if !defined(HTS_ENGINE_API_BUILDLINK3_MK)
|
||||
HTS_ENGINE_API_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.hts_engine_API+= hts_engine_API>=1.10
|
||||
BUILDLINK_PKGSRCDIR.hts_engine_API?= ../../audio/hts_engine
|
||||
.endif # HTS_ENGINE_API_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -hts_engine_API
|
7
audio/hts_engine/distinfo
Normal file
7
audio/hts_engine/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2020/06/22 00:52:42 ryoon Exp $
|
||||
|
||||
SHA1 (hts_engine_API-1.10.tar.gz) = 520212d589444d7224f954c77c78173eda0a804d
|
||||
RMD160 (hts_engine_API-1.10.tar.gz) = 0b36341db11fabb9fdbf8e0231f2f4bf06e27107
|
||||
SHA512 (hts_engine_API-1.10.tar.gz) = fa43bc0a013bfae1392cc5c1195901aae7de50f1866f06d6ec060af5a5740eb2715632561a117d04c98f2863da32fffff05bcaf76ba6ac70e5649ce94dad544b
|
||||
Size (hts_engine_API-1.10.tar.gz) = 169852 bytes
|
||||
SHA1 (patch-lib_HTS__misc.c) = beff3709a9fd25bdc365a8a170834f9533ad363f
|
15
audio/hts_engine/patches/patch-lib_HTS__misc.c
Normal file
15
audio/hts_engine/patches/patch-lib_HTS__misc.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-lib_HTS__misc.c,v 1.1 2020/06/22 00:52:42 ryoon Exp $
|
||||
|
||||
* Add NetBSD workaround.
|
||||
|
||||
--- lib/HTS_misc.c.orig 2015-12-25 00:12:53.000000000 +0000
|
||||
+++ lib/HTS_misc.c
|
||||
@@ -247,6 +247,8 @@ size_t HTS_ftell(HTS_File * fp)
|
||||
fgetpos((FILE *) fp->pointer, &pos);
|
||||
#if defined(_WIN32) || defined(__CYGWIN__) || defined(__APPLE__) || defined(__ANDROID__)
|
||||
return (size_t) pos;
|
||||
+#elif (__NetBSD__)
|
||||
+ return (size_t) pos._pos;
|
||||
#else
|
||||
return (size_t) pos.__pos;
|
||||
#endif /* _WIN32 || __CYGWIN__ || __APPLE__ || __ANDROID__ */
|
Loading…
Reference in a new issue