Fix build with gcc 4.5

This commit is contained in:
markd 2011-01-18 10:22:57 +00:00
parent f45b8e1d49
commit 553a4c614a
3 changed files with 54 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.98 2009/12/13 19:43:51 markd Exp $
$NetBSD: distinfo,v 1.99 2011/01/18 10:22:57 markd Exp $
SHA1 (kdelibs-3.5.10.tar.bz2) = c930a25f4419134def55b8466c3a6f737227fb82
RMD160 (kdelibs-3.5.10.tar.bz2) = 4c960664283c83ebc8e68932ca9044336fcff223
@ -16,6 +16,8 @@ SHA1 (patch-ap) = 94037230bb3d12549195d52b98ffdd821f94f90d
SHA1 (patch-aq) = 18f3885a73cd9169cf4f9c9d97420e639f7fec3c
SHA1 (patch-ar) = 26ccb0c26f9352e6b862037d0a7ffb338057ff98
SHA1 (patch-as) = 8a6fac19d323f475033ff8e9b8163d9a151483eb
SHA1 (patch-at) = b6f14abad8c260122eda141deefffa55e998bf88
SHA1 (patch-au) = a1cd78ccd00f68f99cc14ef9e9638b87025f4288
SHA1 (patch-bc) = 434a48d290aa9716b8c6e372419460ebd33cf8ea
SHA1 (patch-bd) = 852a12b66968595bf1be4538f8ebf88f031592a4
SHA1 (patch-be) = b7c2ed2856565ef3c831046a909e289409199e48

View file

@ -0,0 +1,27 @@
$NetBSD: patch-at,v 1.8 2011/01/18 10:22:57 markd Exp $
svn r1074156 - fix build with gcc4.5
--- kate/part/katehighlight.cpp.orig 2007-05-14 07:52:27.000000000 +0000
+++ kate/part/katehighlight.cpp
@@ -3225,7 +3225,7 @@ void KateHlManager::getDefaults(uint sch
list.append(charAttribute);
KateAttribute* string = new KateAttribute();
- string->setTextColor(QColor::QColor("#D00"));
+ string->setTextColor(QColor("#D00"));
string->setSelectedTextColor(Qt::red);
list.append(string);
@@ -3242,9 +3242,9 @@ void KateHlManager::getDefaults(uint sch
KateAttribute* alert = new KateAttribute();
alert->setTextColor(Qt::black);
- alert->setSelectedTextColor( QColor::QColor("#FCC") );
+ alert->setSelectedTextColor( QColor("#FCC") );
alert->setBold(true);
- alert->setBGColor( QColor::QColor("#FCC") );
+ alert->setBGColor( QColor("#FCC") );
list.append(alert);
KateAttribute* functionAttribute = new KateAttribute();

View file

@ -0,0 +1,24 @@
$NetBSD: patch-au,v 1.6 2011/01/18 10:22:58 markd Exp $
svn r975371. Fix build with gcc 4.4
--- kioslave/ftp/ftp.cc.orig 2008-08-19 18:18:12.000000000 +0000
+++ kioslave/ftp/ftp.cc
@@ -876,7 +876,7 @@ int Ftp::ftpOpenPASVDataConnection()
// The usual answer is '227 Entering Passive Mode. (160,39,200,55,6,245)'
// but anonftpd gives '227 =160,39,200,55,6,245'
int i[6];
- char *start = strchr(ftpResponse(3), '(');
+ const char *start = strchr(ftpResponse(3), '(');
if ( !start )
start = strchr(ftpResponse(3), '=');
if ( !start ||
@@ -931,7 +931,7 @@ int Ftp::ftpOpenEPSVDataConnection()
return ERR_INTERNAL;
}
- char *start = strchr(ftpResponse(3), '|');
+ const char *start = strchr(ftpResponse(3), '|');
if ( !start || sscanf(start, "|||%d|", &portnum) != 1)
return ERR_INTERNAL;