Don't force archaic C versions. Bump revision.

This commit is contained in:
joerg 2018-03-24 20:13:40 +00:00
parent 3f84ea81e5
commit 55423bb381
3 changed files with 20 additions and 5 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.7 2018/01/17 19:56:18 markd Exp $
# $NetBSD: Makefile,v 1.8 2018/03/24 20:13:40 joerg Exp $
DISTNAME= extra-cmake-modules-5.41.0
PKGREVISION= 1
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_KDE:=frameworks/5.41/}
EXTRACT_SUFX= .tar.xz

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.6 2018/01/17 19:56:18 markd Exp $
$NetBSD: distinfo,v 1.7 2018/03/24 20:13:40 joerg Exp $
SHA1 (extra-cmake-modules-5.41.0.tar.xz) = ef5c552af9212ee7e0a563b8407f5daf9d2d808e
RMD160 (extra-cmake-modules-5.41.0.tar.xz) = 7b9e173b69f6823dd1616ee415ffb74f55d71ec7
SHA512 (extra-cmake-modules-5.41.0.tar.xz) = 034c67ed56ee4f6002ff2f0bfca2d7eb7877180b5aa5cf5eb3babb6e40c0669eb0728f45832bd8250ff304647f9a6555233bff4fdf6eccc9b14b420f4b1c3924
Size (extra-cmake-modules-5.41.0.tar.xz) = 313940 bytes
SHA1 (patch-kde-modules_KDECompilerSettings.cmake) = 0d0c33df8d3207841d48ad2dc51ebe1533866ca1
SHA1 (patch-kde-modules_KDECompilerSettings.cmake) = 7d2d847238a497c81e5287166ce2278350670e18

View file

@ -1,13 +1,27 @@
$NetBSD: patch-kde-modules_KDECompilerSettings.cmake,v 1.2 2018/01/17 19:56:18 markd Exp $
$NetBSD: patch-kde-modules_KDECompilerSettings.cmake,v 1.3 2018/03/24 20:13:40 joerg Exp $
Do not hard-code --enable-new-dtags. It is completely broken on systems like
NetBSD implementing the sane rpath semantic and just have a new enough binutils
version. It is up to the system compiler to know what the correct platfor
choice is.
Do not force C90 mode. It is not a reasonable default.
--- kde-modules/KDECompilerSettings.cmake.orig 2017-11-30 07:42:14.000000000 +0000
+++ kde-modules/KDECompilerSettings.cmake
@@ -229,14 +229,6 @@ if (POLICY CMP0063)
@@ -189,11 +189,6 @@ endif()
# Pick sensible versions of the C and C++ standards.
# Note that MSVC does not have equivalent flags; the features are either
# supported or they are not.
-if (CMAKE_C_COMPILER_ID STREQUAL "GNU" OR CMAKE_C_COMPILER_ID MATCHES "Clang")
- # We use the C89 standard because that is what is common to all our
- # compilers (in particular, MSVC 2010 does not support C99)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=iso9899:1990")
-endif()
if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" OR CMAKE_CXX_COMPILER_ID MATCHES "Clang")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")
elseif (CMAKE_CXX_COMPILER_ID STREQUAL "Intel" AND NOT WIN32)
@@ -229,14 +224,6 @@ if (POLICY CMP0063)
cmake_policy(SET CMP0063 NEW)
endif()