Version 1.3.0

(30 December 2005, from /branches/1.3.x)
http://svn.collab.net/repos/svn/tags/1.3.0

 pkgsrc changes:
  - No more build- or run- time dependency on swig.
  - Add SHLIBTOOL_OVERRIDE to p5-subversion and ruby-subversion.
  - Run new py-subversion tests.

 User-visible-changes:
  - Client:
    * 'svn ls -v' now shows remote locks (issue #2291)
    * 'svn status' speedup (r15061, r15103)
    * 'svn blame' speedup on files with long history (issue #1970)
    * 'svnversion' now assumes default argument of '.' (r14892)
    * support for neon 0.25.x, which fixes http:// control-c bug (issue #2297)
    * support for more ISO-8601 date formats, compatible with GNU date (r14428)
    * support for single-digit date components (r15459)
    * on Windows, '_svn' admin dir now toggled by runtime env. variable (r16244)
    * working copy size with empty propfiles reduced (r16855, see releasenotes)
    * new switches added:
       - 'svn blame --xml [--incremental]' (r14690)
       - 'svn status --xml [--incremental]'  (issue #2069)
       - 'svn info --xml [--incremental]'
       - 'svn add/import --no-ignore'  (issue #2105)
       - 'svnlook tree --full-paths'  (r13976)
       - 'svnlook diff --diff-copy-from'  (r14855)
       - 'svnlook changed --copy-info' (r16681)
    * fixed: 'svn copy wc URL' might include deleted items (issue #2153)
    * fixed: 'svn copy wc wc' allows cross-repository copies (issue #2404)
    * fixed: 'svn up/merge' major property-merging bugs (issue #2035)
    * fixed: 'svn merge' insisting on write access to '.' (issue #2411)
    * fixed: 'svn merge' cross-device move problems (r16293, -329, -330)
    * fixed: 'svn diff' outputs headers in wrong encoding (issue #1533)
    * fixed: 'svn proplist/add/cat' dies on unversioned items (issue #2030)
    * fixed: 'svn add' not honoring svn:ignore property (issue #2243)
    * fixed: 'svn log -rN:M --limit X' error over http:// (issue #2396)
    * fixed: 'svn switch --relocate' failure on 'deleted' dir (r16673)
    * fixed: 'svn info' not always showing repos lock (issue #2276)
    * fixed: 'svn info' might show lock on wrong path (r16626)
    * fixed: 'svnlook' chokes on logs with inconsistent newlines (r14573)
    * fixed: 'svnlook propget --revprop -t' failure (r15203)
    * fixed: 'svnversion' wrongly traverses into externals (r15161)
    * fixed: incorrect URI encoding passed to svn+ssh:// (issue #2406)
    * fixed: properly handle filenames containing '@' (issue #2317)
    * fixed: '--non-interactive' now suppresses launch of $EDITOR (r15277)
    * fixed: conflict markers not in current encoding (r14621)
    * fixed: commands ignoring extraneous -m or -F switches (issue #2285)
    * fixed: poor error-checking when using revprops (r15542)
    * fixed: stack-smashing bugs (r15948, r16037)
    * fixed: incorrect parsing of mod_dav_svn XML responses (r17589)
    * translation updates for all languages

  - Server:
    * svnserve improvements:
       - can now restrict read/write access by path (see releasenotes)
       - undeprecation of the --read-only (-R) option (r17614)
    * mod_dav_svn improvements:
       - 'SVNListParentPath on' shows all repositories in web browser (r16158)
       - ability to log high-level client operations (see releasenotes)
       - sets svn:mime-type on autoversioning commits (r14359)
    * 'svn log' performance improvement (r14722)
    * fixed: fs history algorithm might return wrong objects (issue #1970)
    * fixed: repos deadlock when hooks output too much (issue #2078)
    * fixed: mod_dav_svn displays errors with sensitive paths (r14792)
    * fixed: anonymous reader could create empty commits (issue #2388)
    * fixed: possible segfault to callers of trace_node_locations() (r16188)
    * fixed: BDB-style locking actions on FSFS repositories (r16295, r16297)
    * fixed: numerous bugs running BDB commands on FSFS (issue #2361, r16388)
    * fixed: svndumpfilter incorrectly remapping dropped revs (issue #1911)

  - Both:
    * faster multiple (un)locks in a single svn:// request (issue #2264)
    * the Subversion Book is no longer bundled (r17466)

Developer-visible-changes:
* reorganization of automated tests, including ability to run on ramdisk
* lots of Doxygen/API documentation cleanup
* numerous improvements to gen-make.py build system, especially on win32
* working copy is now storing repos_root as separate field (issue #960)
* keywords are now stored in an internal hash (issue #890)
* client status APIs now makes more server-side info available (r16344)
* new public APIs:
   - new transfer progress callback for DAV (r15948)
   - svn_ra_initialize(), svn_client_open_ra_session()
   - svn_fs_closest_copy(), svn_fs_type()
   - several rev'd APIs, see doxygen docs
* SWIG bindings: No more compile-time or runtime SWIG dependencies
    - SWIG/python bindings:
       - automatic memory management: APIs no longer require pool arguments!
       - improved stability, as shown by our new testsuite
       - better error messages
    - SWIG/ruby bindings:
       - complete API coverage!
       - automatic memory management
       - greatly expanded test suite
    - SWIG/perl bindings:
       - new accessors for svn_lock_t, svn_fs_access_t
       - a number of bugfixes
* javahl bindings:
    - add streamy API for fetching file contents (r15584)
    - fixed: let tests run before bindings are installed (issue #2040)
    - fixed: lock command not raising errors properly (issue #2394)
    - fixed: ignored errors from svn_client_blame2() (r16434)
This commit is contained in:
epg 2006-01-02 21:13:45 +00:00
parent 9038d7156c
commit 5575927262
14 changed files with 795 additions and 354 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.26 2005/09/06 17:35:17 jlam Exp $
# $NetBSD: Makefile,v 1.27 2006/01/02 21:13:45 epg Exp $
PKGNAME= p5-subversion-${SVNVER}
COMMENT= Perl bindings for Subversion
@ -7,6 +7,8 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
.include "../../devel/subversion/Makefile.common"
SHLIBTOOL_OVERRIDE= libtool
PERL5_CONFIGURE= no
PERL5_OPTIONS+= threads
PERL5_PACKLIST= auto/SVN/_Core/.packlist
@ -20,6 +22,5 @@ post-patch:
${CP} ${FILESDIR}/build-outputs.mk ${WRKSRC}/build-outputs.mk
.include "../../devel/subversion/buildlink3.mk"
.include "../../devel/swig13/buildlink3.mk"
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.16 2005/12/05 20:50:07 rillig Exp $
# $NetBSD: Makefile,v 1.17 2006/01/02 21:13:45 epg Exp $
PKGNAME= ${PYPKGPREFIX}-subversion-${SVNVER}
COMMENT= Python bindings and tools for Subversion
@ -20,7 +20,7 @@ MAKE_ENV+= EXTRA_CPPFLAGS=${BUILDLINK_CPPFLAGS:Q}
MAKE_FLAGS+= swig_pydir=${LOCALBASE}/${PYSITELIB}/libsvn \
swig_pydir_extra=${LOCALBASE}/${PYSITELIB}/svn
TEST_TARGET= all check
TEST_TARGET= all check check-swig-py
post-patch:
${RM} ${WRKSRC}/build-outputs.mk
@ -36,7 +36,6 @@ post-install:
${SVNEXAMPLES}/hook-scripts
.include "../../devel/subversion/buildlink3.mk"
.include "../../devel/swig13/buildlink3.mk"
.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,11 +1,12 @@
# $NetBSD: Makefile,v 1.5 2005/12/05 20:50:07 rillig Exp $
# $NetBSD: Makefile,v 1.6 2006/01/02 21:13:45 epg Exp $
PKGNAME= ${RUBY_PKGPREFIX}-subversion-${SVNVER}
PKGREVISION= 1
COMMENT= Ruby bindings for Subversion
.include "../../devel/subversion/Makefile.common"
SHLIBTOOL_OVERRIDE= libtool
USE_RUBY_DIST_SUBDIR= no
REPLACE_RUBY_DIRS= ${WRKSRC}/tools
@ -21,12 +22,10 @@ post-patch:
${CP} ${FILESDIR}/build-outputs.mk ${WRKSRC}/build-outputs.mk
post-install:
${RM} ${RUBY_SITEARCHLIBDIR}/svn/ext/*.a
${RM} ${RUBY_SITEARCHLIBDIR}/svn/ext/*.la
${INSTALL_DATA_DIR} ${SVNEXAMPLES}/ruby
${INSTALL_DATA} ${WRKSRC}/tools/*/*.rb ${SVNEXAMPLES}/ruby
.include "../../devel/subversion/buildlink3.mk"
.include "../../devel/swig13/buildlink3.mk"
.include "../../lang/ruby/modules.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.28 2005/12/05 20:50:08 rillig Exp $
# $NetBSD: Makefile,v 1.29 2006/01/02 21:13:45 epg Exp $
PKGNAME= subversion-base-${SVNVER}
COMMENT= Version control system, base programs and libraries
@ -54,7 +54,7 @@ post-install:
# Use this target to update the build-outputs.mk hack for sub-packages.
svn-build-outputs-hack:
cd ${WRKSRC} && ./gen-make.py --installed-libs libsvn_client,libsvn_delta,libsvn_diff,libsvn_fs,libsvn_ra,libsvn_repos,libsvn_subr,libsvn_wc
cd ${WRKSRC} && ./gen-make.py --release --installed-libs libsvn_client,libsvn_delta,libsvn_diff,libsvn_fs,libsvn_ra,libsvn_repos,libsvn_subr,libsvn_wc
${MV} ${WRKSRC}/build-outputs.mk ${FILESDIR}/build-outputs.mk
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2005/06/25 12:23:21 minskim Exp $
@comment $NetBSD: PLIST,v 1.11 2006/01/02 21:13:45 epg Exp $
bin/svn
bin/svnadmin
bin/svndumpfilter
@ -22,6 +22,7 @@ include/subversion-1/svn_fs.h
include/subversion-1/svn_hash.h
include/subversion-1/svn_io.h
include/subversion-1/svn_md5.h
include/subversion-1/svn_nls.h
include/subversion-1/svn_opt.h
include/subversion-1/svn_path.h
include/subversion-1/svn_pools.h
@ -33,7 +34,6 @@ include/subversion-1/svn_repos.h
include/subversion-1/svn_sorts.h
include/subversion-1/svn_string.h
include/subversion-1/svn_subst.h
include/subversion-1/svn_test.h
include/subversion-1/svn_time.h
include/subversion-1/svn_types.h
include/subversion-1/svn_utf.h

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.21 2005/12/05 20:50:08 rillig Exp $
# $NetBSD: Makefile.common,v 1.22 2006/01/02 21:13:45 epg Exp $
DISTNAME= subversion-${SVNVER}
CATEGORIES= devel
@ -25,8 +25,6 @@ CONFIGURE_ARGS+= --with-apr-util=${BUILDLINK_PREFIX.apr}
CONFIGURE_ARGS+= --with-neon=${BUILDLINK_PREFIX.neon}
CONFIGURE_ARGS+= --with-ssl
MAKE_FLAGS+= SWIG_LIBSWIG_DIR=${BUILDLINK_DIR}/share/swig/1.3
BUILDLINK_DEPENDS.subversion-base+= subversion-base>=${SVNVER}
.include "../../devel/gettext-lib/buildlink3.mk"

View file

@ -1,5 +1,5 @@
# $NetBSD: Makefile.version,v 1.31 2005/09/06 17:35:17 jlam Exp $
# $NetBSD: Makefile.version,v 1.32 2006/01/02 21:13:45 epg Exp $
.if !defined(SVNVER)
SVNVER= 1.2.3
SVNVER= 1.3.0
.endif

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.10 2005/05/23 23:40:35 epg Exp $
# $NetBSD: buildlink3.mk,v 1.11 2006/01/02 21:13:45 epg Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
SUBVERSION_BASE_BUILDLINK3_MK:= ${SUBVERSION_BASE_BUILDLINK3_MK}+
@ -15,7 +15,7 @@ BUILDLINK_PACKAGES+= subversion-base
.if !empty(SUBVERSION_BASE_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.subversion-base+= subversion-base>=1.0.0
BUILDLINK_RECOMMENDED.subversion-base?= subversion-base>=1.2.0
BUILDLINK_RECOMMENDED.subversion-base?= subversion-base>=1.3.0
BUILDLINK_PKGSRCDIR.subversion-base?= ../../devel/subversion-base
BUILDLINK_FILES.subversion-base+= bin/svn-config

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.48 2005/09/06 17:35:17 jlam Exp $
$NetBSD: distinfo,v 1.49 2006/01/02 21:13:45 epg Exp $
SHA1 (subversion-1.2.3.tar.gz) = 790cfc94db98799a48a157fef22a13c878e74345
RMD160 (subversion-1.2.3.tar.gz) = 4a39e2b9f4dcd39023e785ce0a31b3bd493d6a85
Size (subversion-1.2.3.tar.gz) = 8868156 bytes
SHA1 (patch-ad) = 38bc62998284e5c7393fdc450aee4801176a0693
SHA1 (patch-ag) = e9fa5f95fd35740ac38a182cbf975b8206ae8b9a
SHA1 (patch-ah) = 195aeabc711b229cb402312357cad143c19d7b53
SHA1 (patch-ai) = 9b209d2d436a5ed3ac2ca02a2dac80c8cad0e98c
SHA1 (subversion-1.3.0.tar.gz) = 98cb017844750d4ed26e2a811c581a644e3ad585
RMD160 (subversion-1.3.0.tar.gz) = e00cc422636b74df8c8821c136e9eacb8caa42d4
Size (subversion-1.3.0.tar.gz) = 8773294 bytes
SHA1 (patch-ad) = e821ce2a450a2430c082e42bc22fe6e73931d746
SHA1 (patch-ag) = dbcfe77867e5960df4518b998e94e9cfb9e144fa
SHA1 (patch-ah) = 2ee769e649e52bfbcd3049b1a1b6b1cf2b4db8c8
SHA1 (patch-ai) = c06c40c94f0a227f3154aa0997d7a92fc6e43fee
SHA1 (patch-aj) = 18a90663e2abd2ea2ad5f9d3f0e76a3d937d3e64

File diff suppressed because it is too large Load diff

View file

@ -1,16 +1,17 @@
$NetBSD: patch-ad,v 1.11 2005/08/08 18:13:13 jlam Exp $
$NetBSD: patch-ad,v 1.12 2006/01/02 21:13:45 epg Exp $
--- Makefile.in.orig 2005-05-09 01:56:09.000000000 -0400
--- Makefile.in.orig 2005-10-22 12:28:49.000000000 -0400
+++ Makefile.in
@@ -575,9 +575,9 @@ install-swig-py: install-swig-py-lib
install-swig-rb: install-swig-rb-lib
@@ -618,10 +618,9 @@ $(SWIG_PL_DIR)/native/Makefile.PL: $(SWI
./config.status subversion/bindings/swig/perl/native/Makefile.PL
$(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
- cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL
+ cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL INSTALLDIRS=vendor
-swig-pl_DEPS = libsvn_client libsvn_delta libsvn_diff libsvn_fs libsvn_ra libsvn_repos libsvn_subr libsvn_wc libsvn_swig_perl $(SWIG_PL_DIR)/native/Makefile
+swig-pl_DEPS = libsvn_swig_perl $(SWIG_PL_DIR)/native/Makefile
-swig-pl_DEPS = autogen-swig-pl libsvn_client libsvn_delta libsvn_diff \
- libsvn_fs libsvn_ra libsvn_repos libsvn_subr libsvn_wc libsvn_swig_perl \
+swig-pl_DEPS = autogen-swig-pl libsvn_swig_perl \
$(SWIG_PL_DIR)/native/Makefile
swig-pl: $(swig-pl_DEPS)
cd $(SWIG_PL_DIR)/native; $(MAKE)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ag,v 1.7 2005/09/06 17:35:17 jlam Exp $
$NetBSD: patch-ag,v 1.8 2006/01/02 21:13:45 epg Exp $
--- subversion/bindings/swig/perl/native/Makefile.PL.in.orig Tue Mar 22 09:31:58 2005
--- subversion/bindings/swig/perl/native/Makefile.PL.in.orig 2005-10-14 16:45:33.000000000 -0400
+++ subversion/bindings/swig/perl/native/Makefile.PL.in
@@ -46,7 +46,7 @@ my %config = (
@@ -43,7 +43,7 @@ my %config = (
" -I$svnlib_srcdir/include",
" -I$swig_srcdir -g"),
OBJECT => q/$(O_FILES)/,
@ -11,11 +11,3 @@ $NetBSD: patch-ag,v 1.7 2005/09/06 17:35:17 jlam Exp $
(map {$_ = abs_path($_); "-L$_"} @ldpaths),
@ldmodules, '-lsvn_swig_perl-1',
`$swig -perl -ldflags`)],
@@ -105,7 +105,6 @@ sub MY::postamble {
my $swig_modules_command = join ('',
map {"\nsvn_$_.c : $swig_srcdir/svn_$_.i ".
- "$svnlib_builddir/libsvn_$_/libsvn_$_-1.la ".
"ra_plugin.hi ra_reporter.hi ".
"delta_editor.hi\n" .
"\t$swig_command".

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ah,v 1.2 2005/05/23 22:58:26 epg Exp $
$NetBSD: patch-ah,v 1.3 2006/01/02 21:13:45 epg Exp $
--- build/generator/gen_make.py.orig 2005-03-22 10:08:25.000000000 -0500
--- build/generator/gen_make.py.orig 2005-10-25 08:49:37.000000000 -0400
+++ build/generator/gen_make.py
@@ -5,6 +5,7 @@
import os
@ -9,8 +9,8 @@ $NetBSD: patch-ah,v 1.2 2005/05/23 22:58:26 epg Exp $
+import ConfigParser
import gen_base
@@ -39,6 +40,13 @@ class Generator(gen_base.GeneratorBase):
import generator.util.executable
@@ -41,6 +42,13 @@ class Generator(gen_base.GeneratorBase):
install_deps = self.graph.get_deps(gen_base.DT_INSTALL)
install_sources = self.graph.get_all_sources(gen_base.DT_INSTALL)
@ -24,7 +24,7 @@ $NetBSD: patch-ah,v 1.2 2005/05/23 22:58:26 epg Exp $
# ensure consistency between runs
install_deps.sort()
install_sources.sort(lambda s1, s2: cmp(s1.name, s2.name))
@@ -54,11 +62,17 @@ class Generator(gen_base.GeneratorBase):
@@ -56,11 +64,17 @@ class Generator(gen_base.GeneratorBase):
# construct a list of the other .la libs to link against
retreat = build_path_retreat(target.path)
@ -44,7 +44,7 @@ $NetBSD: patch-ah,v 1.2 2005/05/23 22:58:26 epg Exp $
deps.append(source.filename)
link.append(build_path_join(retreat, source.filename))
@@ -136,6 +150,8 @@ class Generator(gen_base.GeneratorBase):
@@ -245,6 +259,8 @@ class Generator(gen_base.GeneratorBase):
elif isinstance(link_dep, gen_base.TargetLinked):
if link_dep.external_lib:
libs.append(link_dep.external_lib)

View file

@ -1,10 +1,10 @@
$NetBSD: patch-ai,v 1.2 2005/05/23 22:58:26 epg Exp $
$NetBSD: patch-ai,v 1.3 2006/01/02 21:13:45 epg Exp $
--- gen-make.py.orig 2005-01-31 07:11:57.000000000 -0500
--- gen-make.py.orig 2005-11-16 19:43:35.000000000 -0500
+++ gen-make.py
@@ -81,6 +81,13 @@ def _usage_exit():
print
print " The default generator type is 'make'"
print " The default generator type is 'make'"
print
+ print " UNIX-specific options:"
+ print
@ -16,7 +16,7 @@ $NetBSD: patch-ai,v 1.2 2005/05/23 22:58:26 epg Exp $
print " Windows-specific options:"
print
print " --with-apr=DIR"
@@ -176,6 +183,7 @@ if __name__ == '__main__':
@@ -181,6 +188,7 @@ if __name__ == '__main__':
'enable-nls',
'enable-bdb-in-apr-util',
'vsnet-version=',