Add missing termios.h includes.

This commit is contained in:
joerg 2013-07-19 12:54:58 +00:00
parent b1e9bc5958
commit 55843e9be6
5 changed files with 40 additions and 11 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2013/01/11 00:00:49 joerg Exp $
$NetBSD: distinfo,v 1.7 2013/07/19 12:54:58 joerg Exp $
SHA1 (splitvt-1.6.6.tar.gz) = 8073f4998ae0d772deecc583b61ea7cb92f7186b
RMD160 (splitvt-1.6.6.tar.gz) = 014a9990ef41414b8488e10c24354bfc9588c4f8
@ -6,5 +6,6 @@ Size (splitvt-1.6.6.tar.gz) = 64797 bytes
SHA1 (patch-aa) = ee16f9bb4b04d65c41ff71a6bc961bf3838e3648
SHA1 (patch-ab) = 047b5fceb89fa952780c0d62a20291399e6370f8
SHA1 (patch-ac) = b98a3c94d27799a4b9d94ccfef0d2de343becdf1
SHA1 (patch-ad) = ee36e355d76630d734a84ebca0b0531a8cef6b96
SHA1 (patch-ad) = f955382aaf72c0d451b48e569ed6af5d0e179d45
SHA1 (patch-cut-paste.c) = f1dc6f569580789ae3bb90633b619047302abdbd
SHA1 (patch-vttest.c) = 0381aa56cebf559172b0b89d9f80fdf8844c0801

View file

@ -1,8 +1,16 @@
$NetBSD: patch-ad,v 1.1 2008/07/25 03:38:01 tonnerre Exp $
$NetBSD: patch-ad,v 1.2 2013/07/19 12:54:58 joerg Exp $
--- misc.c.orig 2007-04-01 19:56:30.000000000 +0200
--- misc.c.orig 2007-04-01 17:56:30.000000000 +0000
+++ misc.c
@@ -108,8 +108,17 @@ int win; /* 0 for upper, 1 for lower */
@@ -7,6 +7,7 @@
#include <stdlib.h>
#include <string.h>
#include <signal.h>
+#include <termios.h>
#ifdef HAVE_TERMIO_H
@@ -108,8 +109,17 @@ int win; /* 0 for upper, 1 for lower */
/* "touch" the tty so 'w' reports proper idle times */
(void) utime(get_ttyname(), NULL);
@ -21,7 +29,7 @@ $NetBSD: patch-ad,v 1.1 2008/07/25 03:38:01 tonnerre Exp $
/* Run the requested program, with possible leading dash. */
execvp(((*argv[0] == '-') ? argv[0]+1 : argv[0]), argv);
@@ -876,8 +885,17 @@ char *type;
@@ -876,8 +886,17 @@ char *type;
}
close(pipe_fds[0]); close(pipe_fds[1]);

View file

@ -0,0 +1,12 @@
$NetBSD: patch-vttest.c,v 1.1 2013/07/19 12:54:58 joerg Exp $
--- vttest.c.orig 2013-07-19 10:26:29.000000000 +0000
+++ vttest.c
@@ -15,6 +15,7 @@
#include <sys/types.h>
#include <stdio.h>
#include <fcntl.h>
+#include <termios.h>
#ifdef HAVE_TERMIO_H
#include <termio.h>
#else

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2013/01/17 16:00:02 joerg Exp $
$NetBSD: distinfo,v 1.9 2013/07/19 12:54:58 joerg Exp $
SHA1 (xjdic-24.locale.patch) = fdd9a6d12a9c2098c315364ad79fe77527f8b43e
RMD160 (xjdic-24.locale.patch) = 3a7bd300f44e17f668213dd66dcb2fe3b377ff21
@ -12,5 +12,5 @@ SHA1 (patch-ac) = 06e8b8ebace1c12e7dbf944d9d6b34d8f5c9acc8
SHA1 (patch-ad) = 57cf0f53d498c7c4af9dfa3dbf6fd76c4f3dfa26
SHA1 (patch-ae) = 7a672438936f7b0827bc0e3b55ac9dc0c3a6c9f8
SHA1 (patch-exjdxgen.c) = 5e6680216435f170716134ec945b22363a15b60a
SHA1 (patch-xjdfrontend.c) = 87535787a34168b53467214ecbd419b9ff5b9454
SHA1 (patch-xjdfrontend.c) = c33c79b843081b8ace8936918d871e0a4504c57b
SHA1 (patch-xjdxgen.c) = f83ce54475dc88d363cf7820d235a2e1454c699d

View file

@ -1,8 +1,16 @@
$NetBSD: patch-xjdfrontend.c,v 1.1 2013/01/17 16:00:02 joerg Exp $
$NetBSD: patch-xjdfrontend.c,v 1.2 2013/07/19 12:54:58 joerg Exp $
--- xjdfrontend.c.orig 2013-01-16 14:01:40.000000000 +0000
--- xjdfrontend.c.orig 2013-07-19 10:14:06.000000000 +0000
+++ xjdfrontend.c
@@ -2917,10 +2917,7 @@ void FiltSet()
@@ -26,6 +26,7 @@
#include <stdlib.h>
#include <signal.h>
#include <errno.h>
+#include <termios.h>
#define HAVE_LOCALE
#ifdef HAVE_LOCALE
@@ -2917,10 +2918,7 @@ void FiltSet()
/* M A I N */