Fix build with png-1.5.
This commit is contained in:
parent
20b6724df9
commit
55878b768c
2 changed files with 28 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.5 2006/10/16 10:48:35 obache Exp $
|
||||
$NetBSD: distinfo,v 1.6 2011/01/29 11:09:44 wiz Exp $
|
||||
|
||||
SHA1 (libmatchbox-1.9.tar.gz) = 9a14f77c7bf0c7ea7177929bbf306bdad7f4a6fe
|
||||
RMD160 (libmatchbox-1.9.tar.gz) = 4620db3da81a6acd69694cd6cec8393ec8d91a05
|
||||
Size (libmatchbox-1.9.tar.gz) = 418576 bytes
|
||||
SHA1 (patch-aa) = eed22f59959b067475fde30c605d446a9f7d1b7d
|
||||
|
|
26
devel/libmatchbox/patches/patch-aa
Normal file
26
devel/libmatchbox/patches/patch-aa
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-aa,v 1.3 2011/01/29 11:09:44 wiz Exp $
|
||||
|
||||
Fix build with png-1.5.
|
||||
|
||||
--- libmb/mbpixbuf.c.orig 2006-07-26 19:12:25.000000000 +0000
|
||||
+++ libmb/mbpixbuf.c
|
||||
@@ -247,7 +247,7 @@ _load_png_file( const char *file,
|
||||
return NULL;
|
||||
}
|
||||
|
||||
- if ( setjmp( png_ptr->jmpbuf ) ) {
|
||||
+ if ( setjmp( png_jmpbuf( png_ptr ) ) ) {
|
||||
png_destroy_read_struct( &png_ptr, &info_ptr, NULL);
|
||||
fclose(fd);
|
||||
return NULL;
|
||||
@@ -269,8 +269,8 @@ _load_png_file( const char *file,
|
||||
( color_type == PNG_COLOR_TYPE_GRAY_ALPHA ))
|
||||
png_set_gray_to_rgb(png_ptr);
|
||||
|
||||
- if ( info_ptr->color_type == PNG_COLOR_TYPE_RGB_ALPHA
|
||||
- || info_ptr->color_type == PNG_COLOR_TYPE_GRAY_ALPHA
|
||||
+ if ( png_get_color_type( png_ptr, info_ptr ) == PNG_COLOR_TYPE_RGB_ALPHA
|
||||
+ || png_get_color_type ( png_ptr, info_ptr ) == PNG_COLOR_TYPE_GRAY_ALPHA
|
||||
)
|
||||
*has_alpha = 1;
|
||||
else
|
Loading…
Reference in a new issue