Update sqlite to 2.8.3. Major relevant changes:
2003 June 4 (2.8.3) - Fix a problem that will corrupt the indices on a table if you do an INSERT OR REPLACE or an UPDATE OR REPLACE on a table that contains an INTEGER PRIMARY KEY plus one or more indices. - Add the ability for INSERT and UPDATE statements to refer to the "rowid" (or "_rowid_" or "oid") columns. - Other important bug fixes 2003 May 17 (2.8.2) - Fix a problem that will corrupt the database file if you drop a table from the main database that has a TEMP index. 2003 May 16 (2.8.1) - Reactivated the VACUUM command that reclaims unused disk space in a database file. - Added the ATTACH and DETACH commands to allow interacting with multiple database files at the same time. - Added support for TEMP triggers and indices. - Added support for in-memory databases. - Removed the experimental sqlite_open_aux_file(). Its function is subsumed in the new ATTACH command. - The precedence order for ON CONFLICT clauses was changed so that ON CONFLICT clauses on BEGIN statements have a higher precedence than ON CONFLICT clauses on constraints. - Many, many bug fixes and compatibility enhancements.
This commit is contained in:
parent
4fb64d4701
commit
55d2128ca3
3 changed files with 6 additions and 28 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.15 2003/03/29 12:40:28 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.16 2003/06/25 19:24:21 tsarna Exp $
|
||||
|
||||
DISTNAME= sqlite-2.8.0
|
||||
DISTNAME= sqlite-2.8.3
|
||||
WRKSRC= ${WRKDIR}/sqlite-build
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.hwaci.com/sw/sqlite/ \
|
||||
|
@ -12,6 +12,7 @@ COMMENT= SQL Database Engine In A C Library
|
|||
|
||||
USE_BUILDLINK2= YES
|
||||
USE_LIBTOOL= YES
|
||||
USE_GMAKE= YES
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.10 2003/02/17 14:55:30 agc Exp $
|
||||
$NetBSD: distinfo,v 1.11 2003/06/25 19:24:21 tsarna Exp $
|
||||
|
||||
SHA1 (sqlite-2.8.0.tar.gz) = 66527dc11f20df9fd5a95aa8ac3c95ee0907b88f
|
||||
Size (sqlite-2.8.0.tar.gz) = 824187 bytes
|
||||
SHA1 (patch-aa) = 05d0408a9c3f6a371b4b9cf5464aa5a7b436023b
|
||||
SHA1 (sqlite-2.8.3.tar.gz) = 20ebbf7779b652e8eb7e99f38c57ae98f14909a4
|
||||
Size (sqlite-2.8.3.tar.gz) = 832405 bytes
|
||||
|
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.2 2001/10/20 18:51:37 reinoud Exp $
|
||||
|
||||
--- ../sqlite/configure.orig Fri Sep 28 03:34:44 2001
|
||||
+++ ../sqlite/configure
|
||||
@@ -13341,7 +13341,7 @@
|
||||
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
|
||||
if test "$ac_cv_search_readline" = no; then
|
||||
for ac_lib in readline; do
|
||||
- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
+ LIBS="-l$ac_lib -ltermcap $ac_func_search_save_LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line 13346 "configure"
|
||||
#include "confdefs.h"
|
||||
@@ -13373,7 +13373,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:13374: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_readline="-l$ac_lib"
|
||||
+ ac_cv_search_readline="${LDFLAGS} -l$ac_lib -ltermcap"
|
||||
break
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
Loading…
Reference in a new issue