Fix build problem on Ruby 2.2.

This commit is contained in:
taca 2015-06-11 17:10:46 +00:00
parent 60a9d58436
commit 561a63445f
2 changed files with 26 additions and 1 deletions

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.4 2006/01/03 14:25:51 taca Exp $
$NetBSD: distinfo,v 1.5 2015/06/11 17:10:46 taca Exp $
SHA1 (webunit-20040429++.tar.gz) = dfc317b7318731e56dadfe4f7d11acc66f54fa29
RMD160 (webunit-20040429++.tar.gz) = db2416e67ffc178a2d8965cdce312c2407d560ca
Size (webunit-20040429++.tar.gz) = 59312 bytes
SHA1 (patch-install.rb) = deed7b29562ddb8a14f3bee1815a99967a403ea1

View file

@ -0,0 +1,24 @@
$NetBSD: patch-install.rb,v 1.1 2015/06/11 17:10:46 taca Exp $
Fix build problem on Ruby 2.2 and later.
--- install.rb.orig 2003-01-21 11:50:39.000000000 +0000
+++ install.rb
@@ -45,7 +45,7 @@ end
class ConfigTable
- c = ::Config::CONFIG
+ c = ::RbConfig::CONFIG
rubypath = c['bindir'] + '/' + c['ruby_install_name']
@@ -691,7 +691,7 @@ class Installer
"no extention exists: Have you done 'ruby #{$0} setup' ?"
end
- DLEXT = /\.#{ ::Config::CONFIG['DLEXT'] }\z/
+ DLEXT = /\.#{ ::RbConfig::CONFIG['DLEXT'] }\z/
def _allext( dir )
Dir.open(dir) {|d|