Update nkf (and p5-nkf) to 2.10.

(while here, added commented out LICENSE=zlib-liccense)

This release is maintainance release, mainly for bug fixes.
* Add install target to Makefile
* Let to recognize hankaku-kana in 8bit JIS
* Fixes perl module build
* Fixes no effect of -Z1, -Z2 and -Z0 option
* Fixes input specification for UTF-16 and UTF-32
* Fixes missing BOM output for UTF-32.
* Fixes miss guesses and output for 4bytes UTF-8
This commit is contained in:
obache 2009-11-19 05:42:02 +00:00
parent dfe1d46da1
commit 5660d0b2c4
7 changed files with 13 additions and 120 deletions

View file

@ -1,12 +1,13 @@
# $NetBSD: Makefile,v 1.12 2009/01/22 08:50:12 obache Exp $
# $NetBSD: Makefile,v 1.13 2009/11/19 05:42:02 obache Exp $
.include "${.CURDIR}/Makefile.common"
PKGNAME= nkf-2.09
PKGNAME= nkf-2.10
CATEGORIES= japanese converters
MAINTAINER= cjs@NetBSD.org
COMMENT= Convert between various Japanese character encodings
#LICENSE= zlib-license
PKG_INSTALLATION_TYPES= overwrite pkgviews
PKG_DESTDIR_SUPPORT= user-destdir

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile.common,v 1.1 2009/01/22 08:50:12 obache Exp $
# $NetBSD: Makefile.common,v 1.2 2009/11/19 05:42:02 obache Exp $
# used by converters/nkf/Makefile
# used by converters/p5-nkf/Makefile
DISTNAME= nkf-2.0.9
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP:=nkf/37177/}
DISTNAME= nkf-2.1.0
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP:=nkf/44486/}
HOMEPAGE= http://sourceforge.jp/projects/nkf/

View file

@ -1,8 +1,5 @@
$NetBSD: distinfo,v 1.6 2009/01/22 08:50:12 obache Exp $
$NetBSD: distinfo,v 1.7 2009/11/19 05:42:02 obache Exp $
SHA1 (nkf-2.0.9.tar.gz) = 68e9d5c6224940e6f1fe1d3cf0a54e47c5769a27
RMD160 (nkf-2.0.9.tar.gz) = c27b176f675428c0cbfb7779700979e60de3a42f
Size (nkf-2.0.9.tar.gz) = 157686 bytes
SHA1 (patch-aa) = 04ae92c1ff89b68750cb64186921b8984d527879
SHA1 (patch-ab) = dcb7619ef049f3e9824566565281efaec54587fa
SHA1 (patch-ac) = 2d891bdd891cabd760f7fd905d2ecc5e40908ad0
SHA1 (nkf-2.1.0.tar.gz) = 6c88c12d973abbdb4c61ade47a470e01f7bbcc95
RMD160 (nkf-2.1.0.tar.gz) = 77cf750e00fbc6b7b2178a25c152a4ed7b623a35
Size (nkf-2.1.0.tar.gz) = 156716 bytes

View file

@ -1,40 +0,0 @@
$NetBSD: patch-aa,v 1.1 2009/01/22 08:50:12 obache Exp $
Fix: redefinition of macro SP (workarround).
http://git.sourceforge.jp/view?p=nkf/nkf.git;a=commitdiff;h=d2f5d12b00a610a371ec48f6c841953b792aa721
NKF.xs must follow nkf.c doesn't have WISH_TRUE AND NO_X0201
http://git.sourceforge.jp/view?p=nkf/nkf.git;a=commitdiff;h=f06661980bb179714f60338e09d48ae66ca15f97
--- NKF.mod/NKF.xs.orig 2009-01-20 09:49:31.000000000 +0000
+++ NKF.mod/NKF.xs
@@ -95,7 +95,9 @@ nkf_putchar_grow(unsigned int c)
#define PERL_XS 1
#include "../utf8tbl.c"
+#undef SP
#include "../nkf.c"
+#define SP sp /* perl's CORE/pp.h */
/* package defenition */
@@ -134,9 +136,6 @@ nkf(...)
data = SvPV(ST(argc),i_len);
input_ctr = 0;
- if(x0201_f == WISH_TRUE)
- x0201_f = ((!iso2022jp_f)? TRUE : NO_X0201);
-
/* allocate the result buffer */
/* During conversion, stirngs length may grow. This is the unit */
@@ -178,9 +177,6 @@ nkf_continue(...)
data = SvPV(ST(0),i_len);
input_ctr = 0;
- if(x0201_f == WISH_TRUE)
- x0201_f = ((!iso2022jp_f)? TRUE : NO_X0201);
-
/* allocate the result buffer */
/* During conversion, stirngs length may grow. This is the unit */

View file

@ -1,43 +0,0 @@
$NetBSD: patch-ab,v 1.1 2009/01/22 08:50:12 obache Exp $
Fix: can't run test.
http://git.sourceforge.jp/view?p=nkf/nkf.git;a=commitdiff;h=b7ee1f1b26ba715116fd8f66e83bf1ad8a95bcce
--- NKF.mod/test.pl.orig 2009-01-20 09:49:31.000000000 +0000
+++ NKF.mod/test.pl
@@ -114,8 +114,35 @@ END {print "not ok 1\n" unless $loaded;}
} else {
print "no 5\n";
}
+}
+sub command_tests {
+ my @tests = @_;
+ my ($in, $out, $ans);
+ for (my $i = 0; $i <= $#tests; $i += 3){
+ local (@nkf) = split(/ /,$tests[$i]);
+ shift(@nkf);
+ $in = $tests[$i+1];
+ $ans = $tests[$i+2];
+ $out = NKF::nkf(@nkf,$in);
+ $out =~ s/ //g if $nkf =~ /-\w+m[NS]/o;
+ $ans =~ s/ //g if $nkf =~ /-\w+m[NS]/o;
+ if ($out ne $ans) {
+ last;
+ }
+ }
+ if ($out eq $ans) {
+ print "Ok\n";
+ return;
+ }
+ print "Fail\n";
+ if ($diff) {
+ open(R,"|od -c >tmp.result.bad"); binmode R; print R $out; close(R);
+ open(R,"|od -c >tmp.expect.bad"); binmode R; print R $ans; close(R);
+ system "diff -c tmp.result.bad tmp.expect.bad";
+ }
+ return;
}
do "../nkf_test.pl";

View file

@ -1,23 +0,0 @@
$NetBSD: patch-ac,v 1.1 2009/01/22 08:50:12 obache Exp $
Fix: can't run test.
http://git.sourceforge.jp/view?p=nkf/nkf.git;a=commitdiff;h=b7ee1f1b26ba715116fd8f66e83bf1ad8a95bcce
--- nkf_test.pl.orig 2009-01-20 09:49:31.000000000 +0000
+++ nkf_test.pl
@@ -957,6 +957,7 @@ eofeof
printf "%-40s", "test_data/bugs10904";
&test("$nkf -Mj",$example{'test_data/bugs10904'},$example{'test_data/bugs10904.ans'});
+ if (!NKF) {
printf "%-40s", "Guess NL";
&command_tests(
"$nkf --guess","none", "ASCII\n",
@@ -980,6 +981,7 @@ printf "%-40s", "Guess NL";
"$nkf --guess","\r\n.\n", "ASCII (MIXED NL)\n",
"$nkf --guess","\r\n.\r", "ASCII (MIXED NL)\n",
"$nkf --guess","\r\n.\r\n", "ASCII (CRLF)\n");
+ }
printf "%-40s", "Convert NL to LF";
&command_tests(

View file

@ -1,14 +1,15 @@
# $NetBSD: Makefile,v 1.17 2009/01/22 08:50:12 obache Exp $
# $NetBSD: Makefile,v 1.18 2009/11/19 05:42:02 obache Exp $
#
.include "../../converters/nkf/Makefile.common"
PKGNAME= p5-nkf-2.09
PKGNAME= p5-nkf-2.10
SVR4_PKGNAME= p5nkf
CATEGORIES= japanese converters perl5
MAINTAINER= tech-pkg-ja@jp.NetBSD.org
COMMENT= Perl library for Network Kanji code conversion Filter
#LICENSE= zlib-license
PKG_DESTDIR_SUPPORT= user-destdir