xscreensaver: Avoid "sun" conflict.

This commit is contained in:
jperkin 2024-03-11 10:58:45 +00:00
parent 2f6a1d3bc9
commit 56726fd47b
2 changed files with 42 additions and 1 deletions

View File

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.93 2024/02/08 00:51:39 gutteridge Exp $
$NetBSD: distinfo,v 1.94 2024/03/11 10:58:45 jperkin Exp $
BLAKE2s (xscreensaver-6.08.tar.gz) = f506866c4be3430d5c252f6b6a9f4d99f1e58e59c332770202903dee7f558c37
SHA512 (xscreensaver-6.08.tar.gz) = a333d4921ed3a8219f3b672dd68543aea31fcd64ea6766143f1c7f6e5ed3bc7122355635d5afba1632457ad71a11cabdc7b2756431e4f1dc7e0426ae0896e6db
@ -6,3 +6,4 @@ Size (xscreensaver-6.08.tar.gz) = 19990058 bytes
SHA1 (patch-configure) = 4821b6f4400976990b6042677960a53e25f03a24
SHA1 (patch-driver_xscreensaver-settings.desktop.in) = 524d54cbc0e6baf491a176955fce75076240a395
SHA1 (patch-driver_xscreensaver.desktop.in) = 2cd34016e705da23e54e32d7b282f1388f0e0419
SHA1 (patch-hacks_glx_papercube.c) = cd26c73e5997635c8aba83db5c56217e5259d505

View File

@ -0,0 +1,40 @@
$NetBSD: patch-hacks_glx_papercube.c,v 1.1 2024/03/11 10:58:45 jperkin Exp $
Avoid "sun" conflict.
--- hacks/glx/papercube.c.orig 2024-03-11 10:54:54.580908339 +0000
+++ hacks/glx/papercube.c
@@ -858,7 +858,7 @@ initialize_moves(struct moves *moves)
double angle = 90.0;
double fold = FOLD_DURATION / speed;
double pause = PAUSE_DURATION / speed;
- double sun = SUN_DURATION / speed;
+ double sol = SUN_DURATION / speed;
double spin = SPIN_DURATION / speed;
double spin_rps = SPIN_RPS;
double time = 0;
@@ -866,7 +866,7 @@ initialize_moves(struct moves *moves)
struct field_move *field_move;
int i;
- set_move(&moves->sunrise, time, sun, 0.0, brightness);
+ set_move(&moves->sunrise, time, sol, 0.0, brightness);
time = moves->sunrise.stop + pause;
@@ -901,12 +901,12 @@ initialize_moves(struct moves *moves)
time = field_move->move.stop + pause;
- set_move(&moves->spin, time, time + spin + sun,
- 0.0, (spin + sun) * spin_rps * 360);
+ set_move(&moves->spin, time, time + spin + sol,
+ 0.0, (spin + sol) * spin_rps * 360);
time += spin;
- set_move(&moves->sunset, time, time + sun, brightness, 0.0);
+ set_move(&moves->sunset, time, time + sol, brightness, 0.0);
moves->stage = Sunrise;
set_move_time_big_bang(&moves->move_time);