Update to version 2.40
No longer dependent on Digest::Nilsimsa External taint patches no longer necessary. Changes since 2.36 * Applied another Makefile.PL patch from Michael Schwern to correctly install manpages in part 5 of the manual set in various versions of perl. * Applied patch from Mark Martinec and Vivek Khera of Amavisd to untaint various file targets obtained from user input. This is the same patch pointed to by the SpamAssassin FAQ [http://www.spamassassin.org/released/Razor2.patch] * Support for HTTP 1.1 tunneling [SF patch #821324] by Jon Schewe. * Applied Anne Bennett's patch to Logger.pm to introduce a new log target, "syslog-sys", that talks to Syslog over a Unix socket rather than a TCP socket. * Applied Anne Bennett's patch to deHTML.xs to get rid of the type mismatch warning. * Removed computation of signatures that are no longer supported by the backend -- engines 1, 2 and 3. Digest::Nilsimsa no longer required by Razor Agents.
This commit is contained in:
parent
e9182691c4
commit
5675047fc7
6 changed files with 17 additions and 83 deletions
|
@ -1,27 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.13 2003/12/01 00:24:15 heinz Exp $
|
||||
# $NetBSD: Makefile,v 1.14 2004/03/12 22:55:23 heinz Exp $
|
||||
|
||||
DISTNAME= razor-agents-2.36
|
||||
DISTNAME= razor-agents-2.40
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= # empty
|
||||
SVR4_PKGNAME= p5ra
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=razor/}
|
||||
|
||||
MAINTAINER= heinz-p5ra@NetBSD.org
|
||||
MAINTAINER= heinz@NetBSD.org
|
||||
HOMEPAGE= http://razor.sourceforge.net/
|
||||
COMMENT= Distributed and collaborative spam detection network
|
||||
|
||||
DEPENDS+= p5-Net-DNS-[0-9]*:../../net/p5-Net-DNS
|
||||
DEPENDS+= p5-Time-HiRes-[0-9]*:../../time/p5-Time-HiRes
|
||||
DEPENDS+= p5-Digest-SHA1-[0-9]*:../../security/p5-Digest-SHA1
|
||||
DEPENDS+= p5-Digest-Nilsimsa-[0-9]*:../../security/p5-Digest-Nilsimsa
|
||||
DEPENDS+= p5-URI-[0-9]*:../../www/p5-URI
|
||||
|
||||
# because Net::Ping, Getopt::Long, File::Copy are needed
|
||||
BUILDLINK_DEPENDS.perl= perl>=5.6.0
|
||||
USE_BUILDLINK2= YES
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
# because Net::Ping, Getopt::Long, File::Copy are needed
|
||||
PERL5_REQD+= 5.6.0
|
||||
USE_BUILDLINK3= YES
|
||||
|
||||
PERL5_CONFIGURE= YES
|
||||
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/razor-agents/.packlist
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
|
|
|
@ -1,8 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.6 2003/12/01 00:24:15 heinz Exp $
|
||||
$NetBSD: distinfo,v 1.7 2004/03/12 22:55:23 heinz Exp $
|
||||
|
||||
SHA1 (razor-agents-2.36.tar.gz) = 082f90dc658311e8933b82a67584eeebfa4e7338
|
||||
Size (razor-agents-2.36.tar.gz) = 78709 bytes
|
||||
SHA1 (patch-aa) = 741b5462e3841430be0dacf80b0ddfcfc4869425
|
||||
SHA1 (patch-ab) = 967bf2ea2476ec4205046438877bb52fccb9df50
|
||||
SHA1 (patch-ac) = 38a02c02923043733b47e5bf3bca77174670f38c
|
||||
SHA1 (patch-ad) = 39d7fff8a4a42093f57f99575fc518c262fa3be1
|
||||
SHA1 (razor-agents-2.40.tar.gz) = 90ba50b88d58272282f4a8277c752eabef319873
|
||||
Size (razor-agents-2.40.tar.gz) = 79800 bytes
|
||||
SHA1 (patch-aa) = ec38be16b99dcc5324f813957a82949938f42a11
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.4 2003/12/01 00:24:15 heinz Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2004/03/12 22:55:23 heinz Exp $
|
||||
|
||||
--- Makefile.PL.orig Tue Aug 5 20:02:43 2003
|
||||
--- Makefile.PL.orig Mon Dec 8 08:17:48 2003
|
||||
+++ Makefile.PL
|
||||
@@ -138,7 +138,7 @@ sub MY::install {
|
||||
@@ -141,7 +141,7 @@ sub MY::install {
|
||||
|
||||
# begin razor-agents
|
||||
install_razor_agents ::
|
||||
|
@ -11,13 +11,12 @@ $NetBSD: patch-aa,v 1.4 2003/12/01 00:24:15 heinz Exp $
|
|||
# end razor-agents
|
||||
|
||||
};
|
||||
@@ -149,6 +149,17 @@ install_razor_agents ::
|
||||
$inherited =~ s/(\$\(INSTALL\w*MAN1DIR\))/$1$man5/gm;
|
||||
@@ -152,6 +152,16 @@ install_razor_agents ::
|
||||
$inherited =~ s/(\$\((?:DEST)?INSTALL\w*MAN1DIR\))/$1$man5/gm;
|
||||
|
||||
return $inherited . $install_razor_agents;
|
||||
+}
|
||||
+
|
||||
+
|
||||
+sub MY::libscan {
|
||||
+ my ($self, $path) = @_;
|
||||
+
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.2 2003/12/01 00:24:15 heinz Exp $
|
||||
|
||||
--- lib/Razor2/Client/Agent.pm.orig Wed May 7 02:00:38 2003
|
||||
+++ lib/Razor2/Client/Agent.pm
|
||||
@@ -981,6 +981,7 @@ sub loadservercache {
|
||||
my @fns;
|
||||
if (opendir D,$self->{razorhome}) {
|
||||
@fns = map "$self->{razorhome}/$_", grep /^server\.[\S]+\.conf$/, readdir D;
|
||||
+ @fns = map { /^(\S+)$/, $1 } @fns; # untaint
|
||||
closedir D;
|
||||
}
|
||||
foreach (@fns) {
|
|
@ -1,33 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.2 2003/12/01 00:24:15 heinz Exp $
|
||||
|
||||
--- lib/Razor2/Client/Config.pm.orig Mon Apr 21 21:59:56 2003
|
||||
+++ lib/Razor2/Client/Config.pm
|
||||
@@ -333,9 +333,11 @@ sub my_readlink {
|
||||
if ($fn =~ /^(.*)\/([^\/]+)$/) {
|
||||
my $dir = $1;
|
||||
$fn = readlink $fn;
|
||||
+ $fn = $1 if $fn =~ /^(\S+)$/; # untaint readlink
|
||||
$fn = "$dir/$fn" unless $fn =~ /^\//;
|
||||
} else {
|
||||
$fn = readlink $fn;
|
||||
+ $fn = $1 if $fn =~ /^(\S+)$/; # untaint readlink
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -376,13 +378,13 @@ sub read_file {
|
||||
chomp;
|
||||
next if /^\s*#/;
|
||||
if ($nothash) {
|
||||
- s/^\s+//; s/\s+$//;
|
||||
+ next unless s/^\s*(.+?)\s*$/$1/; # untaint
|
||||
$conf->{$_} = 7;
|
||||
push @lines, $_;
|
||||
} else {
|
||||
next unless /=/;
|
||||
- my ($attribute, $value) = split /\=/, $_, 2;
|
||||
- $attribute =~ s/^\s+//; $attribute =~ s/\s+$//;
|
||||
+ my ($attribute, $value) = /^\s*(.+?)\s*=\s*(.+?)\s*$/; # untaint
|
||||
+ next unless (defined $attribute && defined $value);
|
||||
$conf->{$attribute} = $self->parse_value($value);
|
||||
}
|
||||
$total++;
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.2 2003/12/01 00:24:15 heinz Exp $
|
||||
|
||||
--- lib/Razor2/Client/Core.pm.orig Tue Aug 5 20:07:53 2003
|
||||
+++ lib/Razor2/Client/Core.pm
|
||||
@@ -218,8 +218,10 @@ sub bootstrap_discovery {
|
||||
foreach $rr ($query->answer) {
|
||||
my $pushed = 0;
|
||||
if ($rr->type eq "A") {
|
||||
- push @list, $rr->address;
|
||||
- $pushed = 1;
|
||||
+ if ($rr->address =~ m/^(\d+\.\d+\.\d+\.\d+)$/) {
|
||||
+ push @list, $1;
|
||||
+ $pushed = 1;
|
||||
+ }
|
||||
} elsif ($rr->type eq "CNAME") {
|
||||
if ($rr->cname eq 'list.terminator') {
|
||||
pop @list if $pushed;
|
Loading…
Reference in a new issue