Convert to use only buildlink.mk files and mark as USE_BUILDLINK_ONLY.
Add necessary dependency on zlib.
This commit is contained in:
parent
4cb33d6d21
commit
56c0ff6d58
3 changed files with 39 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.28 2001/03/27 03:20:08 hubertf Exp $
|
||||
# $NetBSD: Makefile,v 1.29 2001/07/14 06:35:11 jlam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= rpm-2.5.4
|
||||
|
@ -14,9 +14,9 @@ BUILD_USES_MSGFMT= yes
|
|||
|
||||
CONFLICTS+= rpm2cpio-*
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBINTL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_BUILDLINK_ONLY= yes
|
||||
|
||||
DEINSTALL_FILE= ${WRKDIR}/DEINSTALL
|
||||
INSTALL_FILE= ${WRKDIR}/INSTALL
|
||||
|
@ -31,4 +31,6 @@ pre-install:
|
|||
post-install:
|
||||
PKG_PREFIX=${PREFIX} ${SH} ${INSTALL_FILE} ${PKGNAME} POST-INSTALL
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink.mk"
|
||||
.include "../../devel/zlib/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/20 13:52:20 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/07/14 06:35:11 jlam Exp $
|
||||
|
||||
SHA1 (rpm-2.5.4.tar.gz) = a7fcd67883aec8d5f17483d5efebe7e5f5453462
|
||||
Size (rpm-2.5.4.tar.gz) = 727849 bytes
|
||||
SHA1 (patch-aa) = 3ee3193cc8e9043017b1f507b606c72acab77ddb
|
||||
SHA1 (patch-ab) = 63635f4f7fd96b4e7a40bfbaffd5673b40db3a13
|
||||
SHA1 (patch-ac) = 4dc758cefefb6d97f9217c6c43943883820b1af8
|
||||
SHA1 (patch-ba) = edf6708fe7ef3b0e899473a13fe709d8c561e14b
|
||||
SHA1 (patch-bb) = dc0ea2dd366b793003218858ca3d67bc285a2089
|
||||
SHA1 (patch-bc) = 7b01437e0fa15ae802dfd7cde4c250fb081ef71c
|
||||
|
|
31
misc/rpm/patches/patch-ac
Normal file
31
misc/rpm/patches/patch-ac
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-ac,v 1.8 2001/07/14 06:35:12 jlam Exp $
|
||||
|
||||
--- configure.orig Mon Sep 28 16:50:23 1998
|
||||
+++ configure Sat Jul 14 02:12:00 2001
|
||||
@@ -1565,7 +1565,6 @@
|
||||
echo $ac_n "checking for $dir/lib in LIBS""... $ac_c" 1>&6
|
||||
echo "configure:1567: checking for $dir/lib in LIBS" >&5
|
||||
if test -d $dir/lib ; then
|
||||
- addlib $dir/lib
|
||||
echo "$ac_t""yes" 1>&6
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
@@ -1574,7 +1573,6 @@
|
||||
echo $ac_n "checking for $dir/include in INCPATH""... $ac_c" 1>&6
|
||||
echo "configure:1576: checking for $dir/include in INCPATH" >&5
|
||||
if test -d $dir/include ; then
|
||||
- INCPATH="$INCPATH -I$dir/include"
|
||||
echo "$ac_t""yes" 1>&6
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
@@ -1585,10 +1583,8 @@
|
||||
echo "configure:1586: checking for /usr/ucblib in LIBS" >&5
|
||||
if test -d /usr/ucblib ; then
|
||||
if test "$build" = "mips-sni-sysv4" ; then
|
||||
- addlib /usr/ccs/lib -lc
|
||||
fi
|
||||
|
||||
- addlib /usr/ucblib
|
||||
|
||||
echo "$ac_t""yes" 1>&6
|
||||
else
|
Loading…
Reference in a new issue