Fix some configure goofiness:
- - Don't pull in /sys/sys/include just for ipv6 support! - - Package wants "bison"; give it bison. - - Don't pull in "libpthreads" just becuase it exists on the build system. - - Likewise for "pgp", unless IRRD_USE_PGP is specified. Also, - - Rearrange package Makefile, so that only that which is "prefs" goes after ".include ../../mk/bsd.prefs.mk". TODO: - - Make the package use pgp5 or pgp2 by default?
This commit is contained in:
parent
52dd4865e0
commit
56d5db9c07
3 changed files with 49 additions and 17 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.4 2000/05/24 23:29:48 fredb Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2000/09/13 15:14:40 fredb Exp $
|
||||
#
|
||||
|
||||
DISTNAME= irrd-1.5-beta-Sept-24-1999
|
||||
|
@ -10,6 +10,17 @@ MAINTAINER= kim@tac.nyc.ny.us
|
|||
HOMEPAGE= http://www.irrd.net/
|
||||
|
||||
BUILD_DEPENDS+= autoreconf:../../devel/autoconf
|
||||
BUILD_DEPENDS+= bison:../../devel/bison
|
||||
|
||||
WRKSRC= ${WRKDIR}/irrd-1.5
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --without-gdbm --with-db1
|
||||
CONFIGURE_ARGS+= --disable-thread --disable-wall
|
||||
CONFIGURE_ENV+= YACC=bison
|
||||
|
||||
pre-configure:
|
||||
@(cd ${WRKSRC} && autoreconf)
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
@ -19,8 +30,7 @@ DEPENDS+= pgp-5.*:../../security/pgp5
|
|||
.elif ${IRRD_USE_PGP} == 2
|
||||
DEPENDS+= pgp-2.*:../../security/pgp2
|
||||
#.else
|
||||
# IRRd will be built with pgpv or pgp if found!
|
||||
#CONFIGURE_ARGS+=--without-pgp
|
||||
CONFIGURE_ARGS+= --without-pgp
|
||||
.endif
|
||||
.endif
|
||||
|
||||
|
@ -28,13 +38,4 @@ DEPENDS+= pgp-2.*:../../security/pgp2
|
|||
CONFIGURE_ARGS+= --disable-ipv6
|
||||
.endif
|
||||
|
||||
WRKSRC= ${WRKDIR}/irrd-1.5
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--with-db1
|
||||
|
||||
pre-configure:
|
||||
@(cd ${WRKSRC} && autoreconf)
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 1999/10/28 19:50:19 kim Exp $
|
||||
$NetBSD: patch-sum,v 1.2 2000/09/13 15:14:41 fredb Exp $
|
||||
|
||||
MD5 (patch-aa) = 5f39473657713f9c7b19e03395ac7945
|
||||
MD5 (patch-aa) = 6b4a6411a298dede181a4891780c939e
|
||||
MD5 (patch-ab) = 63068873063cce05da48ff02a2e8d0f9
|
||||
MD5 (patch-ac) = 210e70db5b5ed608f9b950c7b2e5574f
|
||||
MD5 (patch-ad) = 92713a0b298a9c069ad351be3c117f83
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/10/28 19:50:19 kim Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2000/09/13 15:14:41 fredb Exp $
|
||||
|
||||
--- configure.in.orig Mon Sep 6 15:31:59 1999
|
||||
+++ configure.in Fri Oct 22 19:03:11 1999
|
||||
--- configure.in.orig Mon Sep 6 14:31:59 1999
|
||||
+++ configure.in Wed Sep 13 09:40:58 2000
|
||||
@@ -39,7 +39,7 @@
|
||||
CRYPT_LIB="-lcrypt"
|
||||
AC_DEFINE(USE_LOCKF)
|
||||
|
@ -26,6 +26,37 @@ $NetBSD: patch-aa,v 1.1.1.1 1999/10/28 19:50:19 kim Exp $
|
|||
AC_DEFINE(PGP,26)
|
||||
fi
|
||||
else
|
||||
@@ -178,18 +179,18 @@
|
||||
ifelse([$4], , , [else $4])
|
||||
fi])
|
||||
|
||||
-case "${host_os}" in
|
||||
- *bsdi* | *freebsd* | *netbsd* )
|
||||
-dnl use kernel source if available
|
||||
- AC_DIR_EXIST(/sys/sys, [
|
||||
- CPPFLAGS="$CPPFLAGS -I/sys"
|
||||
- IN_H="$IN_H /sys/netinet/in.h"
|
||||
- IF_H="$IF_H /sys/net/if.h"])
|
||||
- ;;
|
||||
- * )
|
||||
-dnl including header files under /sys makes SIOCGIFCONF confused on sunos.
|
||||
- ;;
|
||||
-esac
|
||||
+#case "${host_os}" in
|
||||
+# *bsdi* | *freebsd* | *netbsd* )
|
||||
+#dnl use kernel source if available
|
||||
+# AC_DIR_EXIST(/sys/sys, [
|
||||
+# CPPFLAGS="$CPPFLAGS -I/sys"
|
||||
+# IN_H="$IN_H /sys/netinet/in.h"
|
||||
+# IF_H="$IF_H /sys/net/if.h"])
|
||||
+# ;;
|
||||
+# * )
|
||||
+#dnl including header files under /sys makes SIOCGIFCONF confused on sunos.
|
||||
+# ;;
|
||||
+#esac
|
||||
|
||||
dnl Add the ICMP code; we'll have to turn this into an interactive
|
||||
dnl question during the configure process later...
|
||||
@@ -302,9 +303,10 @@
|
||||
AC_CHECK_HEADERS(gdbm.h, [exist_gdbm=yes],[exist_gdbm=no])
|
||||
fi
|
||||
|
|
Loading…
Reference in a new issue