PKGREVISION++

Apply bugfix patches for the following problems:
- Searching address fields can crash sometimes.
- Auth process crashes if user doesn't have home directory set.
- Some BODY and BODYSTRUCTURE replies missed data for message/rfc822
  MIME parts causing clients to break.
This commit is contained in:
salo 2003-09-23 13:54:25 +00:00
parent 0f38182c0a
commit 570221b153
3 changed files with 54 additions and 12 deletions

View file

@ -1,10 +1,15 @@
# $NetBSD: Makefile,v 1.5 2003/07/04 14:39:38 salo Exp $
# $NetBSD: Makefile,v 1.6 2003/09/23 13:54:25 salo Exp $
#
DISTNAME= dovecot-0.99.10
PKGREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://dovecot.procontrol.fi/
PATCH_SITES= ${MASTER_SITES}
PATCHFILES= auth-home.patch bodystructure.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tom@replic8.net
HOMEPAGE= http://dovecot.procontrol.fi/
COMMENT= Secure IMAP and POP3 server

View file

@ -1,6 +1,11 @@
$NetBSD: distinfo,v 1.4 2003/07/04 14:39:38 salo Exp $
$NetBSD: distinfo,v 1.5 2003/09/23 13:54:25 salo Exp $
SHA1 (dovecot-0.99.10.tar.gz) = 0a1d83cbd27c3aa3e0732416a0871afc23ee5e19
Size (dovecot-0.99.10.tar.gz) = 735615 bytes
SHA1 (auth-home.patch) = 5af6aa64c81d4bf8b0bc0f7684a1c500198b981a
Size (auth-home.patch) = 612 bytes
SHA1 (bodystructure.patch) = f9a94981a4b8527001203725d22ac74f21968d57
Size (bodystructure.patch) = 3010 bytes
SHA1 (patch-aa) = 6ed31ba47883903e5a7b2fcb715432e0c3e8947c
SHA1 (patch-ab) = 0aca5084186f7faa812351e83d1c9535248da2b0
SHA1 (patch-ac) = 6593c335779aacd0bf285a4faf6411150d4acdcf

View file

@ -0,0 +1,32 @@
$NetBSD: patch-ac,v 1.1 2003/09/23 13:54:25 salo Exp $
--- src/lib-mail/message-address.c.orig 2003-03-20 16:46:34.000000000 +0100
+++ src/lib-mail/message-address.c 2003-09-23 15:42:11.000000000 +0200
@@ -252,14 +252,14 @@
} else if ((addr->name == NULL || *addr->name == '\0') &&
addr->route == NULL) {
i_assert(addr->mailbox != NULL);
- i_assert(addr->domain != NULL);
str_append(str, addr->mailbox);
+ if (addr->domain != NULL) {
str_append_c(str, '@');
str_append(str, addr->domain);
+ }
} else {
i_assert(addr->mailbox != NULL);
- i_assert(addr->domain != NULL);
if (addr->name != NULL) {
str_append(str, addr->name);
@@ -272,8 +272,10 @@
str_append_c(str, ':');
}
str_append(str, addr->mailbox);
+ if (addr->domain != NULL) {
str_append_c(str, '@');
str_append(str, addr->domain);
+ }
str_append_c(str, '>');
}