Update to 0.66:

- add a missing locale display format in upload list. Previously, the upload
  list size are displayed alternatively with locale format and without it.

- fix bug in code detecting if C library can handle locale format in printf.

- in public hub list, a hub existing in both neo-modus and dc++ list is not
  displayed twice.

- The "connect" and the "public" labels blink when the hublist is received.
  The "connect" label no more blinks if the connect tab is the current tab.

- Add support of the search time delay flag (DCTC 0.83.9).

- Download tab is now after the Done tab, GDL tab becomes the first tab.

- In find result and user list tab, when multiple rows are selected and have
  the same size, only the GDL with the same size are displayed at the first
  level of the popup menu.

- fix incorrect charset in fr.po and sv.po
This commit is contained in:
wiz 2002-12-17 19:14:42 +00:00
parent 08361f37a1
commit 572ce946e5
4 changed files with 34 additions and 45 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.7 2002/11/11 14:01:32 wiz Exp $
# $NetBSD: Makefile,v 1.8 2002/12/17 19:14:42 wiz Exp $
#
DISTNAME= dc_gui-0.65
DISTNAME= dc_gui-0.66
CATEGORIES= net
MASTER_SITES= http://www.ac2i.tzo.com/dctc/
@ -9,7 +9,7 @@ MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.ac2i.tzo.com/dctc/
COMMENT= graphical user interface for DCTC
DEPENDS+= dctc>=0.83.8:../../net/dctc
DEPENDS+= dctc>=0.83.9:../../net/dctc
GNU_CONFIGURE= YES
USE_BUILDLINK2= YES

View file

@ -1,9 +1,7 @@
$NetBSD: distinfo,v 1.9 2002/11/11 14:01:32 wiz Exp $
$NetBSD: distinfo,v 1.10 2002/12/17 19:14:42 wiz Exp $
SHA1 (dc_gui-0.65.tar.gz) = dc42a0621d89ba60e139eab79981a71d6333f056
Size (dc_gui-0.65.tar.gz) = 459177 bytes
SHA1 (patch-ac) = 4cfccfb3641c475a6307e82957554c2fc9d0a0f3
SHA1 (patch-ad) = 03bab16dee554b5df86d868ac64e5008edf80b51
SHA1 (patch-ae) = f2e9fe445efea23fe52f27ff14d5dcc5c0775af0
SHA1 (dc_gui-0.66.tar.gz) = 7dd3af9e47f9b9b00eeebf321f32f8f02521117e
Size (dc_gui-0.66.tar.gz) = 461838 bytes
SHA1 (patch-ac) = e0c4f9e1f5c0806b01516b1a7cd449d9445ef769
SHA1 (patch-ad) = 1128fdf19cb51d32b6266cbceb161760630ba002
SHA1 (patch-af) = cd6f3c4f8af7c540064e17c0e9714ddc13050641
SHA1 (patch-ag) = d2c699a09b220c7f53e5fefe35aee3b4d71d74e4

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ac,v 1.5 2002/11/11 14:01:32 wiz Exp $
$NetBSD: patch-ac,v 1.6 2002/12/17 19:14:43 wiz Exp $
--- src/callbacks.c.orig Sat Nov 9 16:54:13 2002
--- src/callbacks.c.orig Sun Dec 1 08:03:43 2002
+++ src/callbacks.c
@@ -2,6 +2,13 @@
# include <config.h>
@ -24,21 +24,14 @@ $NetBSD: patch-ac,v 1.5 2002/11/11 14:01:32 wiz Exp $
#include <gnome.h>
#include <glib.h>
#include <time.h>
@@ -1733,7 +1739,7 @@ on_find_entry_activate (
@@ -40,6 +46,10 @@
#include "find_result_clist.h"
#include "user_file_list_clist.h"
#include "ls_cache_clist.h"
+
+#ifndef MSG_NOSIGNAL
+#define MSG_NOSIGNAL 0
+#endif
val=atof(gtk_entry_get_text(GTK_ENTRY(w)));
- g_string_sprintfa(req,"%lf",scale*val);
+ g_string_sprintfa(req,"%f",scale*val);
}
w=get_widget_by_widget_name("find_result");
@@ -2975,7 +2981,7 @@ on_apply_pref_clicked (
}
if(i==4)
i=0;
- g_string_sprintf(out,"/OFFSET %lf\n",strtod(v,NULL)*scale[i]);
+ g_string_sprintf(out,"/OFFSET %f\n",strtod(v,NULL)*scale[i]);
send_data_to_dctc(out->str);
}
}
static void start_download_from_find_result_clist(void);
static void reload_flagged_user_clist(int only_if_empty);

View file

@ -1,18 +1,16 @@
$NetBSD: patch-ad,v 1.5 2002/11/11 14:01:33 wiz Exp $
$NetBSD: patch-ad,v 1.6 2002/12/17 19:14:43 wiz Exp $
--- src/dctc_process.c.orig Sat Nov 9 17:00:01 2002
--- src/dctc_process.c.orig Sat Nov 16 08:10:25 2002
+++ src/dctc_process.c
@@ -4100,11 +4100,11 @@ static void first_level_glst_end_fnc(Gtk
spd=(double)(gce_root->c.root.last_10sec_speed)/10.0; /* compute the speed of the last 10 seconds */
if(spd<1024.0)
{
- g_string_sprintfa(spd_str,"[%.2lfB/s]",spd);
+ g_string_sprintfa(spd_str,"[%.2fB/s]",spd);
}
else if(spd<(1024.0*1024.0))
{
- g_string_sprintfa(spd_str,"[%.2lfKB/s]",spd/1024.0);
+ g_string_sprintfa(spd_str,"[%.2fKB/s]",spd/1024.0);
}
/* Estimated Time to Arrival computation: now (in second) + missing_bytes/spd */
@@ -575,9 +575,9 @@ static void update_users_info(void)
sprintf(buf,"%'d users (%'.2lfGB)",clst->rows,amount/(1024.0*1024.0*1024.0)); /* NO_PRINTF_LOCAL support added */
#else
if( (amount/(1024.0*1024.0*1024.0)) > 1024.0)
- sprintf(buf,"%d users (%.2lfTB)",clst->rows,amount/(1024.0*1024.0*1024.0*1024.0));
+ sprintf(buf,"%d users (%.2fTB)",clst->rows,amount/(1024.0*1024.0*1024.0*1024.0));
else
- sprintf(buf,"%d users (%.2lfGB)",clst->rows,amount/(1024.0*1024.0*1024.0));
+ sprintf(buf,"%d users (%.2fGB)",clst->rows,amount/(1024.0*1024.0*1024.0));
#endif
w=get_widget_by_widget_name("users_info_label");
if(w==NULL)