Update {g,}mc to 0.4.51. This is a maintenance release from version 0.4.50

and has no list of changes.  Restructure packages to use a common Makefile
and patch directory.  Set the maintainer to me, as this is a non-trivial
change.  Compile in the samba vfs code.
This commit is contained in:
jlam 2000-10-19 23:31:15 +00:00
parent 1507864e08
commit 5731bb3633
25 changed files with 240 additions and 387 deletions

View file

@ -1,27 +1,15 @@
# $NetBSD: Makefile,v 1.22 2000/06/01 17:46:15 rh Exp $
# $NetBSD: Makefile,v 1.23 2000/10/19 23:31:15 jlam Exp $
DISTNAME= mc-4.5.50
PKGNAME= g${DISTNAME}
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=stable/sources/mc/}
PKGNAME= g${DISTNAME}
CATEGORIES+= gnome
MAINTAINER= tron@netbsd.org
HOMEPAGE= http://www.gnome.org/mc/
DEPENDS+= gnome-core-*:../../x11/gnome-core
DEPENDS+= gnome-core-*:../../x11/gnome-core
DEPENDS+= libslang-*:../../devel/libslang
USE_X11BASE= # defined
CONFIGURE_ARGS+= --with-tm-x-support
CONFIGURE_ARGS+= --with-gnome
CONFLICTS+= mc-*
post-install:
${RMDIR} ${PREFIX}/share/gnome/help/gmc/C/figs
GNU_CONFIGURE= YES
USE_GMAKE= yes
USE_X11BASE= yes
CONFIGURE_ARGS+= --with-netrc --with-slang --without-x --with-gnome \
--without-tk
# Funny stuff to get this to use the system libslang.
CONFIGURE_ENV+= LIBS="-lm -ltermcap" CPPFLAGS="-I${LOCALBASE}/include"
CFLAGS+= -Dunix -I${LOCALBASE}/include -DxBSD
LDFLAGS+= -L${LOCALBASE}/lib
.include "../../mk/bsd.pkg.mk"
.include "../../sysutils/mc/Makefile.common"

View file

@ -1,3 +0,0 @@
$NetBSD: md5,v 1.9 2000/06/01 17:46:17 rh Exp $
MD5 (mc-4.5.50.tar.gz) = a9808074a863e564264719632ecc1c97

View file

@ -1,9 +0,0 @@
$NetBSD: patch-sum,v 1.4 2000/03/04 10:00:14 tron Exp $
MD5 (patch-aa) = 2412e7b60e0fda6213b8c50b6315dce6
MD5 (patch-ab) = 38eb63b2947645ec67c9010ffd7f9cf8
MD5 (patch-ac) = 990a7730d8115426662d2d678a99860e
MD5 (patch-ad) = 375fabc8300e8a7626dc3d23628fcd6d
MD5 (patch-ae) = 64c125193b94340f449cdcdff23170d5
MD5 (patch-af) = b229afc7c143b0bb758b165fce44f38f
MD5 (patch-ag) = ed4186ad9684dcc3439ee9808e3bc902

View file

@ -1,21 +0,0 @@
$NetBSD: patch-aa,v 1.2 2000/03/04 10:00:15 tron Exp $
--- configure.orig Tue Dec 7 00:49:54 1999
+++ configure Sat Mar 4 10:51:44 2000
@@ -3257,7 +3257,7 @@
USE_INCLUDED_LIBINTL=yes
CATOBJEXT=.cat
INSTOBJEXT=.cat
- DATADIRNAME=lib
+ DATADIRNAME=share
INTLDEPS='$(top_builddir)/intl/libintl.a'
INTLLIBS=$INTLDEPS
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
@@ -11710,6 +11710,7 @@
s%@LIBS@%$LIBS%g
s%@exec_prefix@%$exec_prefix%g
s%@prefix@%$prefix%g
+s%@localbase@%$LOCALBASE%g
s%@program_transform_name@%$program_transform_name%g
s%@bindir@%$bindir%g
s%@sbindir@%$sbindir%g

View file

@ -1,26 +0,0 @@
$NetBSD: patch-ab,v 1.3 1999/10/23 14:06:59 tron Exp $
--- vfs/Make-mc.in.orig Wed Sep 29 22:39:34 1999
+++ vfs/Make-mc.in Sat Oct 23 13:36:10 1999
@@ -16,6 +16,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@ -m 755
INSTALL_DATA = @INSTALL_DATA@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
AR = @AR@
#
@@ -336,11 +337,11 @@
$(DESTDIR)$(extfsdir)/$$I; \
done
for I in $(EXTFS_CONST) ; do \
- $(INSTALL_PROGRAM) $(srcdir)/extfs/$$I \
+ $(INSTALL_SCRIPT) $(srcdir)/extfs/$$I \
$(DESTDIR)$(extfsdir)/$$I; \
done
for I in $(EXTFS_OUT) ; do \
- $(INSTALL_PROGRAM) $(builddir)/vfs/extfs/$$I \
+ $(INSTALL_SCRIPT) $(builddir)/vfs/extfs/$$I \
$(DESTDIR)$(extfsdir)/$$I; \
done

View file

@ -1,30 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 1999/03/15 00:10:30 tron Exp $
--- intl/xopen-msg.sed.orig Thu Jun 18 13:21:49 1998
+++ intl/xopen-msg.sed Thu Jun 18 13:32:08 1998
@@ -81,6 +81,8 @@
G
s/^[^\n]*$/& /
s/\(.*\)\n\([0-9]*\)/\2 \1/
+# Change escaped quotes into regular quotes.
+ s/\\"/"/g
# Clear flag from last substitution.
tb
# Append the next line.
@@ -90,12 +92,16 @@
s/\(.*\n\)"\(.*\)"/\1\2/
# Yes, then branch.
ta
+# Comment out if no message exists.
+ s/^\([0-9]* *\n\)/$ \1/
P
D
# Note that `D' includes a jump to the start!!
# We found a continuation line. But before printing insert '\'.
:a
s/\(.*\)\(\n.*\)/\1\\\2/
+# Change escaped quotes into regular quotes.
+ s/\\"/"/g
P
# We cannot use the sed command `D' here
s/.*\n\(.*\)/\1/

View file

@ -1,40 +0,0 @@
$NetBSD: patch-ad,v 1.3 1999/10/23 14:06:59 tron Exp $
--- Makefile.in.orig Wed Sep 29 22:39:33 1999
+++ Makefile.in Sat Oct 23 13:25:35 1999
@@ -5,14 +5,15 @@
@MCFGR@@MCF@
foreigndirs=pc
codedirs=vfs lib doc slang gtkedit edit src gnome new_icons icons idl syntax
unixdirs=intl $(codedirs) doc-gnome @POSUB@
alldirs=$(unixdirs) $(foreigndirs)
subdirs=$(alldirs)
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
DISTMAIN = configure configure.in NEWS README INSTALL INSTALL.FAST \
Makefile.in FAQ COPYING create_vcs install-sh \
@@ -45,7 +46,7 @@
install: installdirs
@for I in $(unixdirs); do cd $$I; $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1; cd ..; done
$(INSTALL_DATA) $(srcdir)/FAQ $(DESTDIR)$(mclibdir)/FAQ
- $(INSTALL_PROGRAM) mcfn_install $(DESTDIR)$(suppbindir)/mcfn_install
+ $(INSTALL_SCRIPT) mcfn_install $(DESTDIR)$(suppbindir)/mcfn_install
chmod +x $(DESTDIR)$(suppbindir)/mcfn_install
@echo "Please verify that the configuration values are correctly"
@echo "set in the mc.ext file in $(mclibdir)"
@@ -57,9 +58,8 @@
installdirs:
$(MKINSTALLDIRS) $(DESTDIR)$(bindir) $(DESTDIR)$(mclibdir)
$(MKINSTALLDIRS) $(DESTDIR)$(mandir) $(DESTDIR)$(man8dir)
- $(MKINSTALLDIRS) $(DESTDIR)$(icondir) $(DESTDIR)$(suppbindir)
+ $(MKINSTALLDIRS) $(DESTDIR)$(suppbindir) $(DESTDIR)$(syntaxdir)
$(MKINSTALLDIRS) $(DESTDIR)$(tidir) $(DESTDIR)$(extfsdir)
- $(MKINSTALLDIRS) $(DESTDIR)$(idldir) $(DESTDIR)$(syntaxdir)
mcfninstall:
-/bin/sh ./mcfn_install

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ae,v 1.1 1999/10/23 14:06:59 tron Exp $
--- lib/Makefile.in.orig Wed Sep 29 22:39:38 1999
+++ lib/Makefile.in Sat Oct 23 13:29:19 1999
@@ -7,6 +7,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
#
# Distribution variables
@@ -62,7 +63,7 @@
for I in $(LIBFILES_OUT); \
do $(INSTALL_DATA) $(builddir)/lib/$$I $(DESTDIR)$(mclibdir)/$$I; done
for I in $(SUPPBIN_OUT); \
- do $(INSTALL_PROGRAM) -m 755 $(builddir)/lib/$$I $(DESTDIR)$(suppbindir)//$$I; done
+ do $(INSTALL_SCRIPT) -m 755 $(builddir)/lib/$$I $(DESTDIR)$(suppbindir)//$$I; done
for I in $(TIFILES); \
do $(INSTALL_DATA) $(srcdir)/$$I $(DESTDIR)$(tidir)/$$I; done
$(MKINSTALLDIRS) $(DESTDIR)$(confdir)

View file

@ -1,13 +0,0 @@
$NetBSD: patch-af,v 1.2 2000/03/04 10:00:15 tron Exp $
--- vfs/extfs/uzip.in.orig Tue Dec 7 00:49:56 1999
+++ vfs/extfs/uzip.in Thu Mar 2 22:25:30 2000
@@ -7,7 +7,7 @@
#
#
-DZIP=/usr/bin
+DZIP=@localbase@/bin
XZIP="$DZIP/zip -g"
XDZIP="$DZIP/zip -d"
XUNZIP="$DZIP/unzip"

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ag,v 1.2 2000/03/04 10:00:15 tron Exp $
--- vfs/extfs/urar.in.orig Tue Dec 7 00:49:56 1999
+++ vfs/extfs/urar.in Thu Mar 2 22:29:44 2000
@@ -5,7 +5,7 @@
# Updated by christian.gennerat@alcatel.fr 1999
# beta version 2.0
#
-DRAR=/usr/bin
+DRAR=@localbase@/bin
RAR=$DRAR/rar
UNRAR=$DRAR/unrar # Prefer unrar (freeware)
#

View file

@ -1 +1 @@
Gnome version of Midnight Commander, a free Norton Commander Clone
GNOME version of Midnight Commander, a free Norton Commander Clone

View file

@ -1,8 +1,6 @@
This is version 4.5.25 of the Midnight Commander, a free Norton Commander
Clone with many useful features. The Midnight Commander comes with
mouse support on xterms.
Midnight Commander is a visual shell much like a file manager, only with way
more features. It is text mode, but also includes mouse support if you are
running GPM. Its coolest feature is the ability to ftp, view tar, zip
files, and poke into RPMs for specific files.
The Midnight Commander is a directory browsing tool which bears a
certain remote resemblance to John Socha's Norton Commander for DOS.
The Midnight Commander doesn't have all the bells and whistles of its
DOS counterpart, but was written in much less time.
This package has the GNOME interface to the Midnight Commander.

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2000/06/01 17:46:17 rh Exp $
@comment $NetBSD: PLIST,v 1.11 2000/10/19 23:31:17 jlam Exp $
bin/gmc
bin/gmc-client
bin/mc
@ -14,6 +14,7 @@ lib/mc/bin/mc.sh
lib/mc/bin/mcfn_install
lib/mc/desktop-scripts/README.desktop
lib/mc/desktop-scripts/startup.links
lib/mc/edit.indent.rc
lib/mc/extfs/README
lib/mc/extfs/a
lib/mc/extfs/deb
@ -37,14 +38,13 @@ lib/mc/extfs/urar
lib/mc/extfs/uzip
lib/mc/extfs/uzoo
lib/mc/layout
lib/mc/mc.csh
lib/mc/mc-gnome.ext
lib/mc/mc.csh
lib/mc/mc.ext
lib/mc/mc.hint
lib/mc/mc.hint.cs
lib/mc/mc.hint.es
lib/mc/mc.hint.ru
lib/mc/edit.indent.rc
lib/mc/mc.hlp
lib/mc/mc.lib
lib/mc/mc.menu
@ -80,67 +80,54 @@ lib/mc/term/xterm.ti
man/man1/mc.1
man/man1/mcedit.1
man/man8/mcserv.8
share/gnome/help/gmc/C/topic.dat
share/idl/FileManager.idl
share/idl/Makefile.in
@exec mkdir -p %D/share/gnome/help/gmc/C/figs
share/gnome/help/gmc/C/topic.dat
share/locale/ca/LC_MESSAGES/mc.mo
share/locale/cs/LC_MESSAGES/mc.mo
share/locale/da/LC_MESSAGES/mc.mo
share/locale/de/LC_MESSAGES/mc.mo
share/locale/el/LC_MESSAGES/mc.mo
share/locale/es/LC_MESSAGES/mc.mo
share/locale/es_ES/LC_MESSAGES/mc.mo
share/locale/fi/LC_MESSAGES/mc.mo
share/locale/fr/LC_MESSAGES/mc.mo
share/locale/hu/LC_MESSAGES/mc.mo
share/locale/it/LC_MESSAGES/mc.mo
share/locale/ja/LC_MESSAGES/mc.mo
share/locale/ko/LC_MESSAGES/mc.mo
share/locale/nl/LC_MESSAGES/mc.mo
share/locale/no/LC_MESSAGES/mc.mo
share/locale/pl/LC_MESSAGES/mc.mo
share/locale/pt_BR/LC_MESSAGES/mc.mo
share/locale/ro/LC_MESSAGES/mc.mo
share/locale/ru/LC_MESSAGES/mc.mo
share/locale/sk/LC_MESSAGES/mc.mo
share/locale/sv/LC_MESSAGES/mc.mo
share/locale/tr/LC_MESSAGES/mc.mo
share/locale/wa/LC_MESSAGES/mc.mo
share/locale/uk/LC_MESSAGES/mc.mo
share/locale/zh_CN.GB2312/LC_MESSAGES/mc.mo
share/locale/zh_TW.Big5/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/ca/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/cs/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/da/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/de/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/el/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/es/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/es_ES/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/fi/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/fr/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/hu/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/it/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/ja/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/ko/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/nl/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/no/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/pl/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/pt_BR/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/ro/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/ru/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/sk/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/sl/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/sv/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/tr/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/uk/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/wa/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/zh_CN.GB2312/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/zh_TW.Big5/LC_MESSAGES/mc.mo
share/mime-info/mc.keys
share/pixmaps/mc/directory.xpm
share/pixmaps/mc/gnome-application-pgp.png
share/pixmaps/mc/gnome-application-x-e-theme.png
share/pixmaps/mc/gnome-application-x-kde-app-info.png
share/pixmaps/mc/gnome-application-x-generic-spreadsheet.png
share/pixmaps/mc/gnome-application-x-gnome-app-info.png
share/pixmaps/mc/gnome-application-x-java-source.png
share/pixmaps/mc/gnome-application-x-php.png
share/pixmaps/mc/gnome-application-x-reject.png
share/pixmaps/mc/gnome-application-x-scheme-source.png
share/pixmaps/mc/gnome-application-x-sql.png
share/pixmaps/mc/gnome-text-x-authors.png
share/pixmaps/mc/gnome-text-x-copying.png
share/pixmaps/mc/gnome-text-x-credits.png
share/pixmaps/mc/gnome-text-x-install.png
share/pixmaps/mc/gnome-text-x-makefile.png
share/pixmaps/mc/gnome-text-x-readme.png
share/pixmaps/mc/gnome-audio-x-s3m.png
share/pixmaps/mc/gnome-audio-x-stm.png
share/pixmaps/mc/gnome-audio-x-xi.png
share/pixmaps/mc/gnome-audio-x-xm.png
share/pixmaps/mc/gnome-font-afm.png
share/pixmaps/mc/gnome-font-ttf.png
share/pixmaps/mc/gnome-font-x-pcf.png
share/pixmaps/mc/gnome-image-x-xfig.png
share/pixmaps/mc/gnome-application-encapsulated_postscript.png
share/pixmaps/mc/gnome-application-pdf.png
share/pixmaps/mc/gnome-application-pgp.png
share/pixmaps/mc/gnome-application-postscript.png
share/pixmaps/mc/gnome-application-x-c-header.png
share/pixmaps/mc/gnome-application-x-c-source.png
share/pixmaps/mc/gnome-application-x-cc-source.png
share/pixmaps/mc/gnome-application-x-e-theme.png
share/pixmaps/mc/gnome-application-x-generic-spreadsheet.png
share/pixmaps/mc/gnome-application-x-gnome-app-info.png
share/pixmaps/mc/gnome-application-x-java-source.png
share/pixmaps/mc/gnome-application-x-kde-app-info.png
share/pixmaps/mc/gnome-application-x-php.png
share/pixmaps/mc/gnome-application-x-reject.png
share/pixmaps/mc/gnome-application-x-scheme-source.png
share/pixmaps/mc/gnome-application-x-sql.png
share/pixmaps/mc/gnome-audio-basic.png
share/pixmaps/mc/gnome-audio-midi.png
share/pixmaps/mc/gnome-audio-ulaw.png
@ -148,14 +135,18 @@ share/pixmaps/mc/gnome-audio-x-aiff.png
share/pixmaps/mc/gnome-audio-x-mod.png
share/pixmaps/mc/gnome-audio-x-mp3.png
share/pixmaps/mc/gnome-audio-x-pn-realaudio.png
share/pixmaps/mc/gnome-audio-x-s3m.png
share/pixmaps/mc/gnome-audio-x-stm.png
share/pixmaps/mc/gnome-audio-x-voc.png
share/pixmaps/mc/gnome-audio-x-wav.png
share/pixmaps/mc/i-zipdisk.png
share/pixmaps/mc/i-zipdisk2.png
share/pixmaps/mc/gnome-application-pdf.png
share/pixmaps/mc/gnome-audio-x-xi.png
share/pixmaps/mc/gnome-audio-x-xm.png
share/pixmaps/mc/gnome-audio.png
share/pixmaps/mc/gnome-compressed.png
share/pixmaps/mc/gnome-core.png
share/pixmaps/mc/gnome-font-afm.png
share/pixmaps/mc/gnome-font-ttf.png
share/pixmaps/mc/gnome-font-x-pcf.png
share/pixmaps/mc/gnome-http-url.png
share/pixmaps/mc/gnome-image-bmp.png
share/pixmaps/mc/gnome-image-generic.png
@ -172,6 +163,7 @@ share/pixmaps/mc/gnome-image-ras.png
share/pixmaps/mc/gnome-image-rgb.png
share/pixmaps/mc/gnome-image-tga.png
share/pixmaps/mc/gnome-image-tiff.png
share/pixmaps/mc/gnome-image-x-xfig.png
share/pixmaps/mc/gnome-image-xbm.png
share/pixmaps/mc/gnome-image-xcf.png
share/pixmaps/mc/gnome-image-xpm.png
@ -181,10 +173,18 @@ share/pixmaps/mc/gnome-manpage.png
share/pixmaps/mc/gnome-objectfile.png
share/pixmaps/mc/gnome-pack-deb.png
share/pixmaps/mc/gnome-pack-rpm.png
share/pixmaps/mc/gnome-pack-slp.png
share/pixmaps/mc/gnome-package.png
share/pixmaps/mc/gnome-tex.png
share/pixmaps/mc/gnome-text-html.png
share/pixmaps/mc/gnome-text-x-authors.png
share/pixmaps/mc/gnome-text-x-copying.png
share/pixmaps/mc/gnome-text-x-credits.png
share/pixmaps/mc/gnome-text-x-install.png
share/pixmaps/mc/gnome-text-x-makefile.png
share/pixmaps/mc/gnome-text-x-readme.png
share/pixmaps/mc/gnome-textfile.png
share/pixmaps/mc/gnome-trashcan.png
share/pixmaps/mc/gnome-video-mpeg.png
share/pixmaps/mc/gnome-video-quicktime.png
share/pixmaps/mc/gnome-video-x-msvideo.png
@ -203,13 +203,14 @@ share/pixmaps/mc/i-regular.png
share/pixmaps/mc/i-sock.png
share/pixmaps/mc/i-stalled.png
share/pixmaps/mc/i-symlink.png
share/pixmaps/mc/i-zipdisk.png
share/pixmaps/mc/i-zipdisk2.png
share/pixmaps/mc/makefile.xpm
share/pixmaps/mc/sound.xpm
share/pixmaps/mc/trash.xpm
@dirrm share/gnome/help/gmc/C/figs
@dirrm share/pixmaps/mc
@dirrm share/gnome/help/gmc/C
@dirrm share/gnome/help/gmc
@dirrm share/pixmaps/mc
@dirrm lib/mc/term
@dirrm lib/mc/syntax
@dirrm lib/mc/extfs

View file

@ -1,35 +1,15 @@
# $NetBSD: Makefile,v 1.39 2000/10/04 11:04:58 toshii Exp $
# $NetBSD: Makefile,v 1.40 2000/10/19 23:31:17 jlam Exp $
# FreeBSD Id: Makefile,v 1.16 1997/11/30 19:37:48 vanilla Exp
#
DISTNAME= mc-4.5.50
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_GNOME:=stable/sources/mc/}
CONFIGURE_ARGS+= --without-x
CONFIGURE_ARGS+= --without-tm-x-support
CONFIGURE_ARGS+= --without-gnome
MAINTAINER= tron@netbsd.org
HOMEPAGE= http://www.gnome.org/mc/
# Remove unwanted directories in a non-GNOME installation.
#
post-install:
cd ${PREFIX}; ${RMDIR} -p share/idl 2>/dev/null || ${TRUE}
cd ${PREFIX}; ${RMDIR} -p share/pixmaps/mc 2>/dev/null || ${TRUE}
DEPENDS+= libslang-*:../../devel/libslang
DEPENDS+= glib-1.2.*:../../devel/glib
CONFLICTS+= gmc-*
GNU_CONFIGURE= YES
USE_GMAKE= YES
CONFIGURE_ARGS+= --with-netrc --with-slang --without-x \
--without-gnome --without-tk
# Funny stuff to get this to use the system libslang.
CONFIGURE_ENV+= LIBS="-lm -ltermcap" CPPFLAGS="-I${LOCALBASE}/include"
CFLAGS+= -Dunix -I${LOCALBASE}/include -DxBSD
LDFLAGS+= -L${LOCALBASE}/lib
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "SunOS"
PLIST_SUBST+= LOCALEBASE=lib
.else
PLIST_SUBST+= LOCALEBASE=share
.endif
.include "../../mk/bsd.pkg.mk"
.include "../../sysutils/mc/Makefile.common"

View file

@ -0,0 +1,56 @@
# $NetBSD: Makefile.common,v 1.1 2000/10/19 23:31:17 jlam Exp $
DISTNAME= mc-4.5.51
CATEGORIES+= sysutils
MASTER_SITES+= ${MASTER_SITE_GNOME:=stable/sources/mc/}
MAINTAINER= jlam@netbsd.org
HOMEPAGE= http://www.gnome.org/mc/
DEPENDS+= libslang-*:../../devel/libslang
DEPENDS+= glib>=1.2.0:../../devel/glib
CONFLICTS+= mc-* gmc-*
FILESDIR= ${.CURDIR}/../../sysutils/mc/files
PATCHDIR= ${.CURDIR}/../../sysutils/mc/patches
PLIST_SUBST+= LOCALEBASE=${LOCALEBASE}
USE_GMAKE= # defined
GNU_CONFIGURE= # defined
CONFIGURE_ARGS+= --without-included-gettext
CONFIGURE_ARGS+= --with-netrc --with-slang
CONFIGURE_ARGS+= --with-samba
CONFIGURE_ARGS+= --without-tk
# Don't pick up readline if it's installed in the build environment.
#
CONFIGURE_ENV+= ac_cv_header_history_h=no
CONFIGURE_ENV+= ac_cv_header_readline_h=no
CONFIGURE_ENV+= ac_cv_header_readline_history_h=no
CONFIGURE_ENV+= ac_cv_header_readline_readline_h=no
CONFIGURE_ENV+= LOCALBASE="${LOCALBASE}"
CONFIGURE_ENV+= LOCALEBASE="${LOCALEBASE}"
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
CONFIGURE_ENV+= LIBS="${LIBS}"
LIBS+= -lm -ltermcap # -lslang
LIBS+= -lintl # check for gettext is broken
CPPFLAGS+= -I${LOCALBASE}/include # slang.h
.include "../../mk/bsd.prefs.mk"
# The directory in which locale files are found is:
#
# ${PREFIX}/${LOCALEBASE}/locale/<lang>/LC_MESSAGES
#
.if ${OPSYS} == "SunOS"
LOCALEBASE= lib
.else
LOCALEBASE= share
.endif
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.14 2000/06/01 17:54:25 rh Exp $
$NetBSD: md5,v 1.15 2000/10/19 23:31:17 jlam Exp $
MD5 (mc-4.5.50.tar.gz) = a9808074a863e564264719632ecc1c97
MD5 (mc-4.5.51.tar.gz) = c604292554887e9e6baba0828081b963

View file

@ -1,9 +1,9 @@
$NetBSD: patch-sum,v 1.6 2000/03/03 23:56:40 tron Exp $
$NetBSD: patch-sum,v 1.7 2000/10/19 23:31:17 jlam Exp $
MD5 (patch-aa) = 2892d6861d5fb067447401db2a0f594e
MD5 (patch-ab) = 38eb63b2947645ec67c9010ffd7f9cf8
MD5 (patch-aa) = 5ba726c4ff8367f20a3d0d1052adbe74
MD5 (patch-ab) = 3718e815b0fb883df598f2abbc6c5340
MD5 (patch-ac) = 64c125193b94340f449cdcdff23170d5
MD5 (patch-ad) = 990a7730d8115426662d2d678a99860e
MD5 (patch-af) = 3eea71e3c84e0352e6b3989e1a6a415c
MD5 (patch-ag) = c4f09410d5b2bc581feec64762f30c39
MD5 (patch-ah) = fd65533286dd3c9468b668d11b0ddebc
MD5 (patch-ad) = 62f27e7e3f9eefbe5ef00829913b2508
MD5 (patch-af) = 21dcdded4d98079cbf1d0e2fa8718d59
MD5 (patch-ag) = a6afd6816eca5ae23e56057e1ccd2227
MD5 (patch-ah) = 5bf2e219c2fe895220f0c83654e86dde

View file

@ -1,13 +1,49 @@
$NetBSD: patch-aa,v 1.8 1999/03/14 23:07:55 tron Exp $
$NetBSD: patch-aa,v 1.9 2000/10/19 23:31:18 jlam Exp $
--- configure.orig Mon May 25 06:16:04 1998
+++ configure Sun Oct 4 13:10:51 1998
@@ -3073,7 +3073,7 @@
USE_INCLUDED_LIBINTL=yes
CATOBJEXT=.cat
INSTOBJEXT=.cat
- DATADIRNAME=lib
+ DATADIRNAME=share
INTLDEPS='$(top_builddir)/intl/libintl.a'
INTLLIBS=$INTLDEPS
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
--- configure.orig Mon Jul 3 10:31:57 2000
+++ configure
@@ -3543,6 +3543,11 @@
+# Set DATADIRNAME to "${LOCALEBASE}"
+DATADIRNAME="${LOCALEBASE}"
+INTLDEPS=
+INTLLIBS="-lintl"
+
cc_uses_g=yes
if test x$GCC = xyes; then
if test x$ac_cv_prog_gcc_g = xyes; then
@@ -9409,11 +9414,15 @@
# Check whether --with-gnome or --without-gnome was given.
+gnomecodedirs=
+gnomeunixdirs=
if test "${with_gnome+set}" = set; then
withval="$with_gnome"
if test x$withval = xyes; then
want_gnome=yes
+ gnomecodedirs='gnome idl'
+ gnomeunixdirs='doc-gnome'
mx=mx
gmcdep=gmcdep
libgtkedit="libgtkedit.a"
@@ -11891,6 +11900,7 @@
s/@@/%@/; s/@@/@%/; s/@g\$/%g/' > conftest.subs <<\\CEOF
$ac_vpsub
$extrasub
+s%@LOCALBASE@%$LOCALBASE%g
s%@SHELL@%$SHELL%g
s%@CFLAGS@%$CFLAGS%g
s%@CPPFLAGS@%$CPPFLAGS%g
@@ -12019,6 +12029,8 @@
s%@GNOME_DOCKLETS_LIBS@%$GNOME_DOCKLETS_LIBS%g
s%@GNOME_CAPPLET_LIBS@%$GNOME_CAPPLET_LIBS%g
s%@gnomeicondir@%$gnomeicondir%g
+s%@gnomecodedirs@%$gnomecodedirs%g
+s%@gnomeunixdirs@%$gnomeunixdirs%g
s%@mx@%$mx%g
s%@gmcdep@%$gmcdep%g
s%@libgtkedit@%$libgtkedit%g

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.9 1999/10/23 11:52:07 tron Exp $
$NetBSD: patch-ab,v 1.10 2000/10/19 23:31:18 jlam Exp $
--- vfs/Make-mc.in.orig Wed Sep 29 22:39:34 1999
+++ vfs/Make-mc.in Sat Oct 23 13:36:10 1999
--- vfs/Make-mc.in.orig Mon Jul 3 10:31:58 2000
+++ vfs/Make-mc.in
@@ -16,6 +16,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@ -m 755
@ -10,7 +10,7 @@ $NetBSD: patch-ab,v 1.9 1999/10/23 11:52:07 tron Exp $
AR = @AR@
#
@@ -336,11 +337,11 @@
@@ -342,11 +343,11 @@
$(DESTDIR)$(extfsdir)/$$I; \
done
for I in $(EXTFS_CONST) ; do \

View file

@ -1,30 +1,14 @@
$NetBSD: patch-ad,v 1.5 1999/03/14 20:59:42 tron Exp $
$NetBSD: patch-ad,v 1.6 2000/10/19 23:31:18 jlam Exp $
--- intl/xopen-msg.sed.orig Thu Jun 18 13:21:49 1998
+++ intl/xopen-msg.sed Thu Jun 18 13:32:08 1998
@@ -81,6 +81,8 @@
G
s/^[^\n]*$/& /
s/\(.*\)\n\([0-9]*\)/\2 \1/
+# Change escaped quotes into regular quotes.
+ s/\\"/"/g
# Clear flag from last substitution.
tb
# Append the next line.
@@ -90,12 +92,16 @@
s/\(.*\n\)"\(.*\)"/\1\2/
# Yes, then branch.
ta
+# Comment out if no message exists.
+ s/^\([0-9]* *\n\)/$ \1/
P
D
# Note that `D' includes a jump to the start!!
# We found a continuation line. But before printing insert '\'.
:a
s/\(.*\)\(\n.*\)/\1\\\2/
+# Change escaped quotes into regular quotes.
+ s/\\"/"/g
P
# We cannot use the sed command `D' here
s/.*\n\(.*\)/\1/
--- vfs/smbfs.c.orig Mon Jul 3 10:31:59 2000
+++ vfs/smbfs.c
@@ -375,7 +375,8 @@
static int
smbfs_init(vfs *me)
{
- char *servicesf = "/etc/smb.conf";
+ /* This must match what net/samba uses. */
+ char *servicesf = "/etc/samba/smb.conf";
/* DEBUGLEVEL = 4; */

View file

@ -1,15 +1,15 @@
$NetBSD: patch-af,v 1.10 1999/10/23 11:52:07 tron Exp $
$NetBSD: patch-af,v 1.11 2000/10/19 23:31:18 jlam Exp $
--- Makefile.in.orig Wed Sep 29 22:39:33 1999
+++ Makefile.in Sat Oct 23 13:25:35 1999
--- Makefile.in.orig Mon Jul 3 10:31:57 2000
+++ Makefile.in
@@ -5,14 +5,15 @@
@MCFGR@@MCF@
foreigndirs=pc
-codedirs=vfs lib doc slang gtkedit edit src gnome new_icons icons idl syntax
-unixdirs=intl $(codedirs) doc-gnome @POSUB@
+codedirs=vfs lib doc slang edit src new_icons icons syntax
+unixdirs=intl $(codedirs) @POSUB@
+codedirs=vfs lib doc slang gtkedit edit src new_icons icons syntax @gnomecodedirs@
+unixdirs=intl $(codedirs) @gnomeunixdirs@ @POSUB@
alldirs=$(unixdirs) $(foreigndirs)
subdirs=$(alldirs)
@ -29,14 +29,3 @@ $NetBSD: patch-af,v 1.10 1999/10/23 11:52:07 tron Exp $
chmod +x $(DESTDIR)$(suppbindir)/mcfn_install
@echo "Please verify that the configuration values are correctly"
@echo "set in the mc.ext file in $(mclibdir)"
@@ -57,9 +58,8 @@
installdirs:
$(MKINSTALLDIRS) $(DESTDIR)$(bindir) $(DESTDIR)$(mclibdir)
$(MKINSTALLDIRS) $(DESTDIR)$(mandir) $(DESTDIR)$(man8dir)
- $(MKINSTALLDIRS) $(DESTDIR)$(icondir) $(DESTDIR)$(suppbindir)
+ $(MKINSTALLDIRS) $(DESTDIR)$(suppbindir) $(DESTDIR)$(syntaxdir)
$(MKINSTALLDIRS) $(DESTDIR)$(tidir) $(DESTDIR)$(extfsdir)
- $(MKINSTALLDIRS) $(DESTDIR)$(idldir) $(DESTDIR)$(syntaxdir)
mcfninstall:
-/bin/sh ./mcfn_install

View file

@ -1,13 +1,13 @@
$NetBSD: patch-ag,v 1.7 2000/03/03 23:56:42 tron Exp $
$NetBSD: patch-ag,v 1.8 2000/10/19 23:31:18 jlam Exp $
--- vfs/extfs/uzip.in.orig Tue Dec 7 00:49:56 1999
+++ vfs/extfs/uzip.in Thu Mar 2 22:25:30 2000
--- vfs/extfs/uzip.in.orig Mon Jul 3 10:32:00 2000
+++ vfs/extfs/uzip.in
@@ -7,7 +7,7 @@
#
#
-DZIP=/usr/bin
+DZIP=@prefix@/bin
+DZIP=@LOCALBASE@
XZIP="$DZIP/zip -g"
XDZIP="$DZIP/zip -d"
XUNZIP="$DZIP/unzip"

View file

@ -1,13 +1,13 @@
$NetBSD: patch-ah,v 1.2 2000/03/03 23:56:42 tron Exp $
$NetBSD: patch-ah,v 1.3 2000/10/19 23:31:18 jlam Exp $
--- vfs/extfs/urar.in.orig Tue Dec 7 00:49:56 1999
+++ vfs/extfs/urar.in Thu Mar 2 22:29:44 2000
--- vfs/extfs/urar.in.orig Mon Jul 3 10:32:00 2000
+++ vfs/extfs/urar.in
@@ -5,7 +5,7 @@
# Updated by christian.gennerat@alcatel.fr 1999
# beta version 2.0
#
-DRAR=/usr/bin
+DRAR=@prefix@/bin
+DRAR=@LOCALBASE@
RAR=$DRAR/rar
UNRAR=$DRAR/unrar # Prefer unrar (freeware)
#

View file

@ -1,8 +1,4 @@
This is version 4.5.25 of the Midnight Commander, a free Norton Commander
Clone with many useful features. The Midnight Commander comes with
mouse support on xterms.
The Midnight Commander is a directory browsing tool which bears a
certain remote resemblance to John Socha's Norton Commander for DOS.
The Midnight Commander doesn't have all the bells and whistles of its
DOS counterpart, but was written in much less time.
Midnight Commander is a visual shell much like a file manager, only with way
more features. It is text mode, but also includes mouse support if you are
running GPM. Its coolest feature is the ability to ftp, view tar, zip
files, and poke into RPMs for specific files.

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.15 2000/06/01 17:54:26 rh Exp $
@comment $NetBSD: PLIST,v 1.16 2000/10/19 23:31:18 jlam Exp $
bin/mc
bin/mcedit
bin/mcmfmt
@ -94,13 +94,14 @@ ${LOCALEBASE}/locale/pl/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/pt_BR/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/ro/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/ru/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/sv/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/wa/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/uk/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/zh_TW.Big5/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/sk/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/sl/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/sv/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/tr/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/uk/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/wa/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/zh_CN.GB2312/LC_MESSAGES/mc.mo
${LOCALEBASE}/locale/zh_TW.Big5/LC_MESSAGES/mc.mo
@dirrm lib/mc/term
@dirrm lib/mc/syntax
@dirrm lib/mc/extfs