Update to 3.20110905. From the changelog:

* mercurial: Openid nicknames are now used when committing. (Daniel Andersson)
* mercurial: Implement rcs_commit_staged so comments, attachments, etc
  can be used. (Daniel Andersson)
* mercurial: Implement rcs_rename, rcs_remove. (Daniel Andersson)
* mercurial: Fix viewing of a diff containing non-utf8 changes.
  (Daniel Andersson)
* mercurial: Make both rcs_getctime and rcs_getmtime fast. (Daniel Andersson)
* mercurial: Implement rcs_diff. (Daniel Andersson)
* po: Add `LANG_CODE` and `LANG_NAME` template variables. (intrigeri)
* Fix typo in Danish translation of shortcuts page that caused exponential
  regexp blowup.
* Fix escaping of html entities in permalinks.
* Fix escaping of html entities in tag names.
* Avoid using named capture groups in heredoc code for oldperl compatibility.
* Put in a workaround for #622591, by ensuring Search::Xapian gets loaded
  before Image::Magick.
* Add unminified jquery js and css files to source.
* Update to jquery 1.6.2, and jquery-ui 1.8.14.
* Use lockf rather than flock when taking the cgilock, for better
  portability.
* search: Fix encoding bug in calculation of maximum term size.
* inline: When indexing internal pages for searching, use the url of
  the inlining page.
* Fix comments testsuite to not rely on Date::Parse's ability to
  parse the date Columbus discovered America. Closes: #640350
* Avoid warning message when generating setup file if highlight
  is not installed. Closes: #637606
* Promote RPC::XML to a Recommends, since it's used by auto-blog.setup.
  Closes: #637603
* Fix web revert of a file deletion.
This commit is contained in:
schmonz 2011-09-05 22:07:28 +00:00
parent 4c437dc2ba
commit 574472ef1c
5 changed files with 15 additions and 15 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.83 2011/08/14 16:05:40 obache Exp $
# $NetBSD: Makefile,v 1.84 2011/09/05 22:07:28 schmonz Exp $
#
DISTNAME= ikiwiki_3.20110715
DISTNAME= ikiwiki_3.20110905
PKGNAME= ${DISTNAME:S/_/-/}
PKGREVISION= 1
CATEGORIES= www textproc
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/i/ikiwiki/}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.32 2011/07/08 03:16:12 schmonz Exp $
@comment $NetBSD: PLIST,v 1.33 2011/09/05 22:07:28 schmonz Exp $
bin/ikiwiki
bin/ikiwiki-calendar
bin/ikiwiki-makerepo
@ -110,6 +110,7 @@ share/ikiwiki/examples/blog/archives.mdwn
share/ikiwiki/examples/blog/comments.mdwn
share/ikiwiki/examples/blog/index.mdwn
share/ikiwiki/examples/blog/posts.mdwn
share/ikiwiki/examples/blog/posts/Discussion.mdwn
share/ikiwiki/examples/blog/posts/first_post.mdwn
share/ikiwiki/examples/blog/sidebar.mdwn
share/ikiwiki/examples/blog/tags.mdwn

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.67 2011/07/16 02:52:36 schmonz Exp $
$NetBSD: distinfo,v 1.68 2011/09/05 22:07:28 schmonz Exp $
SHA1 (ikiwiki_3.20110715.tar.gz) = 9e1df129ca66714e746655b6e3c0ccf9ee5a469f
RMD160 (ikiwiki_3.20110715.tar.gz) = 000c68414d04698328fcf1c8b4469e5641ec3de1
Size (ikiwiki_3.20110715.tar.gz) = 2502638 bytes
SHA1 (patch-aa) = 748695579cc57ead26ec9524e633751b2a703b07
SHA1 (patch-ab) = 642d25b01029955864d817e564a09bea04c06b10
SHA1 (ikiwiki_3.20110905.tar.gz) = 5be16cb11cee6beb7977eaa7a26cf52cea33af0a
RMD160 (ikiwiki_3.20110905.tar.gz) = c78d567273583c1b57f4f7a481ee13fb0d059267
Size (ikiwiki_3.20110905.tar.gz) = 2682944 bytes
SHA1 (patch-aa) = f5818d0a32394986e86e2f83ea15aef50d17dae4
SHA1 (patch-ab) = 3e571af1894a9c88c39180a0059cc6b136a949d0

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.22 2011/06/04 15:23:36 schmonz Exp $
$NetBSD: patch-aa,v 1.23 2011/09/05 22:07:28 schmonz Exp $
PKG_SYSCONFDIR and PKGMANDIR support, avoid GNUisms in standard utilities.
--- Makefile.PL.orig 2011-06-03 16:40:11.000000000 +0000
--- Makefile.PL.orig 2011-08-24 21:14:48.000000000 +0000
+++ Makefile.PL
@@ -19,11 +19,14 @@ SED?=sed
@ -48,7 +48,7 @@ PKG_SYSCONFDIR and PKGMANDIR support, avoid GNUisms in standard utilities.
@@ -70,7 +76,7 @@ underlay_install:
for dir in `cd underlays && $(FIND) . -follow -type d`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
for file in `$(FIND) underlays/$$dir -follow -maxdepth 1 -type f`; do \
for file in `$(FIND) underlays/$$dir -follow -maxdepth 1 -type f -not -name \\*.full.js -not -name \\*.full.css`; do \
- cp -aL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir 2>/dev/null || \
+ cp -pRL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir 2>/dev/null || \
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.6 2011/06/04 15:23:36 schmonz Exp $
$NetBSD: patch-ab,v 1.7 2011/09/05 22:07:28 schmonz Exp $
When generating scripts, give them the interpreter we generated them with.
--- IkiWiki/Setup/Standard.pm.orig 2011-05-30 18:25:10.000000000 +0000
--- IkiWiki/Setup/Standard.pm.orig 2011-07-29 10:59:11.000000000 +0000
+++ IkiWiki/Setup/Standard.pm
@@ -14,7 +14,10 @@ sub import {
sub gendump ($@) {