Switch to Makefile.common and fix for -ldl

This commit is contained in:
adam 2014-06-05 07:12:53 +00:00
parent e2a838e2ef
commit 5745fd07e0
7 changed files with 51 additions and 44 deletions

View file

@ -1,24 +1,10 @@
# $NetBSD: Makefile,v 1.24 2014/06/05 06:43:54 adam Exp $
# $NetBSD: Makefile,v 1.25 2014/06/05 07:12:53 adam Exp $
.include "../../graphics/exiv2/Makefile.common"
DISTNAME= exiv2-0.24
PKGNAME= ${DISTNAME:S/exiv2/exiv2-organize/}
CATEGORIES= graphics
MASTER_SITES= http://www.exiv2.org/
MAINTAINER= gdt@NetBSD.org
HOMEPAGE= http://www.exiv2.org/
COMMENT= Image metadata manipulation
LICENSE= gnu-gpl-v2
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_TOOLS+= gmake pkg-config
GNU_CONFIGURE= yes
# The visibility feature seems complicated and causes problems on DragonFly
# (reported by Matt Madden) and on Gentoo (http://bugs.gentoo.org/185907).
CONFIGURE_ARGS+= --disable-visibility
GCC_REQD+= 3.3
USE_TOOLS+= pkg-config
BUILD_DIRS= contrib/organize
INSTALLATION_DIRS= bin

View file

@ -1,6 +0,0 @@
$NetBSD: distinfo,v 1.10 2014/06/05 06:43:54 adam Exp $
SHA1 (exiv2-0.24.tar.gz) = 2f19538e54f8c21c180fa96d17677b7cff7dc1bb
RMD160 (exiv2-0.24.tar.gz) = 453247926e8626bf888578afd5a0dde42c6f6962
Size (exiv2-0.24.tar.gz) = 4635028 bytes
SHA1 (patch-contrib_organize_Makefile) = de74227211b79e49126178f27391831507c2948f

View file

@ -1,24 +1,8 @@
# $NetBSD: Makefile,v 1.34 2014/06/05 06:43:53 adam Exp $
# $NetBSD: Makefile,v 1.35 2014/06/05 07:12:53 adam Exp $
DISTNAME= exiv2-0.24
CATEGORIES= graphics
MASTER_SITES= http://www.exiv2.org/
.include "Makefile.common"
MAINTAINER= gdt@NetBSD.org
HOMEPAGE= http://www.exiv2.org/
COMMENT= Image metadata manipulation
LICENSE= gnu-gpl-v2
GCC_REQD+= 3.3
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_PKGLOCALEDIR= yes
USE_TOOLS+= gmake
GNU_CONFIGURE= yes
# The visibility feature seems complicated and causes problems on DragonFly
# (reported by Matt Madden) and on Gentoo (http://bugs.gentoo.org/185907).
CONFIGURE_ARGS+= --disable-visibility
PKGCONFIG_OVERRIDE= config/exiv2.pc.in
.include "../../converters/libiconv/buildlink3.mk"

View file

@ -0,0 +1,26 @@
# $NetBSD: Makefile.common,v 1.1 2014/06/05 07:12:53 adam Exp $
# used by graphics/exiv2
# used by graphics/exiv2-organizer
DISTNAME= exiv2-0.24
CATEGORIES= graphics
MASTER_SITES= http://www.exiv2.org/
MAINTAINER= gdt@NetBSD.org
HOMEPAGE= http://www.exiv2.org/
COMMENT= Image metadata manipulation
LICENSE= gnu-gpl-v2
DISTINFO_FILE= ${.CURDIR}/../../graphics/exiv2/distinfo
PATCHDIR= ${.CURDIR}/../../graphics/exiv2/patches
GCC_REQD+= 3.3
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_TOOLS+= gmake
GNU_CONFIGURE= yes
# The visibility feature seems complicated and causes problems on DragonFly
# (reported by Matt Madden) and on Gentoo (http://bugs.gentoo.org/185907).
CONFIGURE_ARGS+= --disable-visibility
.include "../../textproc/expat/buildlink3.mk"

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.23 2014/06/05 06:43:53 adam Exp $
$NetBSD: distinfo,v 1.24 2014/06/05 07:12:53 adam Exp $
SHA1 (exiv2-0.24.tar.gz) = 2f19538e54f8c21c180fa96d17677b7cff7dc1bb
RMD160 (exiv2-0.24.tar.gz) = 453247926e8626bf888578afd5a0dde42c6f6962
Size (exiv2-0.24.tar.gz) = 4635028 bytes
SHA1 (patch-aa) = e98a4f1ae3ff2ad5ce0cd0d107ae21752a4edb45
SHA1 (patch-configure) = 11b8d348f94eda4b84c61f34ffced54316d70a70
SHA1 (patch-contrib_organize_Makefile) = de74227211b79e49126178f27391831507c2948f

View file

@ -0,0 +1,15 @@
$NetBSD: patch-configure,v 1.1 2014/06/05 07:12:53 adam Exp $
Don't add -ldl for all OS; this gets auto-detected somewhere else.
--- configure.orig 2014-06-05 06:53:10.000000000 +0000
+++ configure
@@ -17069,8 +17069,6 @@ fi
case "$host_os" in
*mingw* | *cygwin*)
LDFLAGS="$LDFLAGS -no-undefined -lpsapi" ;;
-*)
- LDFLAGS="$LDFLAGS -ldl" ;;
esac
# ---------------------------------------------------------------------------

View file

@ -1,4 +1,4 @@
$NetBSD: patch-contrib_organize_Makefile,v 1.1 2011/02/28 20:37:56 adam Exp $
$NetBSD: patch-contrib_organize_Makefile,v 1.1 2014/06/05 07:12:53 adam Exp $
--- contrib/organize/Makefile.orig 2011-02-28 20:05:59.000000000 +0000
+++ contrib/organize/Makefile