python37: updated to 3.7.4

Python 3.7.4 final

Core and Builtins
bpo-37500: Due to unintended side effects, revert the change introduced by bpo-1875 in 3.7.4rc1 to check for syntax errors in dead conditional code blocks.
Documentation
bpo-37149: Replace the dead link to the Tkinter 8.5 reference by John Shipman, New Mexico Tech, with a link to the archive.org copy.


Python 3.7.4 release candidate 2

Security
bpo-37463: ssl.match_hostname() no longer accepts IPv4 addresses with additional text after the address and only quad-dotted notation without trailing whitespaces. Some inet_aton() implementations ignore whitespace and all data after whitespace, e.g. ‘127.0.0.1 whatever’.

Core and Builtins
bpo-24214: Improved support of the surrogatepass error handler in the UTF-8 and UTF-16 incremental decoders.

Library
bpo-37440: http.client now enables TLS 1.3 post-handshake authentication for default context or if a cert_file is passed to HTTPSConnection.
bpo-37437: Update vendorized expat version to 2.2.7.
bpo-37428: SSLContext.post_handshake_auth = True no longer sets SSL_VERIFY_POST_HANDSHAKE verify flag for client connections. Although the option is documented as ignored for clients, OpenSSL implicitly enables cert chain validation when the flag is set.
bpo-32627: Fix compile error when _uuid headers conflicting included.

Windows
bpo-37369: Fixes path for sys.executable when running from the Microsoft Store.
bpo-35360: Update Windows builds to use SQLite 3.28.0.

macOS
bpo-34602: Avoid test suite failures on macOS by no longer calling resource.setrlimit to increase the process stack size limit at runtime. The runtime change is no longer needed since the interpreter is being built with a larger default stack size.
This commit is contained in:
adam 2019-07-09 07:46:37 +00:00
parent 18943b0afd
commit 574a378047
9 changed files with 26 additions and 68 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.4 2019/03/26 21:29:20 leot Exp $
#
# $NetBSD: Makefile,v 1.5 2019/07/09 07:46:37 adam Exp $
VERS= 3.7.3
VERS= 3.7.4
DISTNAME= python-${VERS}-docs-html
PKGNAME= py37-html-docs-${VERS}
CATEGORIES= lang python
@ -13,8 +12,6 @@ HOMEPAGE= https://www.python.org/doc/
COMMENT= HTML Documentation for Python 3.7
LICENSE= python-software-foundation
DIST_SUBDIR= python
USE_TOOLS+= pax
NO_CONFIGURE= yes
@ -25,6 +22,6 @@ HTMLDIR= share/doc/python3.7
INSTALLATION_DIRS= ${HTMLDIR}
do-install:
cd ${WRKSRC} && pax -rw -pp . ${DESTDIR}${PREFIX}/${HTMLDIR}
cd ${WRKSRC} && ${PAX} -rw -pp . ${DESTDIR}${PREFIX}/${HTMLDIR}
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,6 @@
@comment $NetBSD: PLIST,v 1.4 2019/03/26 21:29:20 leot Exp $
@comment $NetBSD: PLIST,v 1.5 2019/07/09 07:46:37 adam Exp $
share/doc/python3.7/.buildinfo
share/doc/python3.7/_downloads/890993d68b2f4776dedfcafde1149e0b/tzinfo_examples.py
share/doc/python3.7/_downloads/388d705f24bc7799f766c5de6df669c1/tzinfo_examples.py
share/doc/python3.7/_images/hashlib-blake2-tree.png
share/doc/python3.7/_images/logging_flow.png
share/doc/python3.7/_images/pathlib-inheritance.png
@ -480,18 +480,12 @@ share/doc/python3.7/_sources/whatsnew/3.6.rst.txt
share/doc/python3.7/_sources/whatsnew/3.7.rst.txt
share/doc/python3.7/_sources/whatsnew/changelog.rst.txt
share/doc/python3.7/_sources/whatsnew/index.rst.txt
share/doc/python3.7/_static/ajax-loader.gif
share/doc/python3.7/_static/basic.css
share/doc/python3.7/_static/classic.css
share/doc/python3.7/_static/comment-bright.png
share/doc/python3.7/_static/comment-close.png
share/doc/python3.7/_static/comment.png
share/doc/python3.7/_static/copybutton.js
share/doc/python3.7/_static/default.css
share/doc/python3.7/_static/doctools.js
share/doc/python3.7/_static/documentation_options.js
share/doc/python3.7/_static/down-pressed.png
share/doc/python3.7/_static/down.png
share/doc/python3.7/_static/file.png
share/doc/python3.7/_static/jquery-3.2.1.js
share/doc/python3.7/_static/jquery.js
@ -507,9 +501,6 @@ share/doc/python3.7/_static/sidebar.js
share/doc/python3.7/_static/switchers.js
share/doc/python3.7/_static/underscore-1.3.1.js
share/doc/python3.7/_static/underscore.js
share/doc/python3.7/_static/up-pressed.png
share/doc/python3.7/_static/up.png
share/doc/python3.7/_static/websupport.js
share/doc/python3.7/about.html
share/doc/python3.7/bugs.html
share/doc/python3.7/c-api/abstract.html

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.4 2019/03/26 21:29:20 leot Exp $
$NetBSD: distinfo,v 1.5 2019/07/09 07:46:37 adam Exp $
SHA1 (python/python-3.7.3-docs-html.tar.bz2) = 5131efe6860e93b7740593f13990813c6b6d13c0
RMD160 (python/python-3.7.3-docs-html.tar.bz2) = e896ef5764fde8fac033898f01a09501fd4eba42
SHA512 (python/python-3.7.3-docs-html.tar.bz2) = 2a07640081ff1fe5707a06791d27f9f88073513a8628e171e38fa9b7fd42b22f4bff85891f4cbfd11fe4993006487eb18eba8f67bcaeb23d336922e2dcf2bb30
Size (python/python-3.7.3-docs-html.tar.bz2) = 6223981 bytes
SHA1 (python-3.7.4-docs-html.tar.bz2) = 5a0ab4ed4bf690b9bb8c468eca0a1af62d40feef
RMD160 (python-3.7.4-docs-html.tar.bz2) = dd18fa223b9fefa35e3acc44f3aaced61f67fc52
SHA512 (python-3.7.4-docs-html.tar.bz2) = b3d0209bf95ddc6a54c48be380b3514eb20965c812f6b495e387320828f37eb8ce89f3321872a2bcd14387ac4a49d3fb43fcb10cbe9cb38830177f70dcf59992
Size (python-3.7.4-docs-html.tar.bz2) = 6212393 bytes

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.9 2019/05/02 12:50:42 wiedi Exp $
# $NetBSD: Makefile,v 1.10 2019/07/09 07:46:37 adam Exp $
.include "dist.mk"
PKGNAME= python37-${PY_DISTVERSION}
PKGREVISION= 1
CATEGORIES= lang python
MAINTAINER= pkgsrc-users@NetBSD.org

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.6 2019/04/25 15:59:54 roy Exp $
@comment $NetBSD: PLIST,v 1.7 2019/07/09 07:46:37 adam Exp $
bin/2to3-${PY_VER_SUFFIX}
bin/pydoc${PY_VER_SUFFIX}
${PLIST.pymalloc}bin/python${PY_VER_SUFFIX}
@ -754,6 +754,7 @@ lib/python${PY_VER_SUFFIX}/distutils/tests/Setup.sample
lib/python${PY_VER_SUFFIX}/distutils/tests/__init__.py
lib/python${PY_VER_SUFFIX}/distutils/tests/__init__.pyc
lib/python${PY_VER_SUFFIX}/distutils/tests/__init__.pyo
lib/python${PY_VER_SUFFIX}/distutils/tests/includetest.rst
lib/python${PY_VER_SUFFIX}/distutils/tests/support.py
lib/python${PY_VER_SUFFIX}/distutils/tests/support.pyc
lib/python${PY_VER_SUFFIX}/distutils/tests/support.pyo
@ -2980,6 +2981,9 @@ lib/python${PY_VER_SUFFIX}/test/libregrtest/setup.pyo
lib/python${PY_VER_SUFFIX}/test/libregrtest/utils.py
lib/python${PY_VER_SUFFIX}/test/libregrtest/utils.pyc
lib/python${PY_VER_SUFFIX}/test/libregrtest/utils.pyo
lib/python${PY_VER_SUFFIX}/test/libregrtest/win_utils.py
lib/python${PY_VER_SUFFIX}/test/libregrtest/win_utils.pyc
lib/python${PY_VER_SUFFIX}/test/libregrtest/win_utils.pyo
lib/python${PY_VER_SUFFIX}/test/list_tests.py
lib/python${PY_VER_SUFFIX}/test/list_tests.pyc
lib/python${PY_VER_SUFFIX}/test/list_tests.pyo
@ -4693,6 +4697,9 @@ lib/python${PY_VER_SUFFIX}/test/test_tools/test_gprof2html.pyo
lib/python${PY_VER_SUFFIX}/test/test_tools/test_i18n.py
lib/python${PY_VER_SUFFIX}/test/test_tools/test_i18n.pyc
lib/python${PY_VER_SUFFIX}/test/test_tools/test_i18n.pyo
lib/python${PY_VER_SUFFIX}/test/test_tools/test_lll.py
lib/python${PY_VER_SUFFIX}/test/test_tools/test_lll.pyc
lib/python${PY_VER_SUFFIX}/test/test_tools/test_lll.pyo
lib/python${PY_VER_SUFFIX}/test/test_tools/test_md5sum.py
lib/python${PY_VER_SUFFIX}/test/test_tools/test_md5sum.pyc
lib/python${PY_VER_SUFFIX}/test/test_tools/test_md5sum.pyo

View file

@ -1,6 +1,6 @@
# $NetBSD: dist.mk,v 1.4 2019/03/26 20:54:55 adam Exp $
# $NetBSD: dist.mk,v 1.5 2019/07/09 07:46:37 adam Exp $
PY_DISTVERSION= 3.7.3
PY_DISTVERSION= 3.7.4
DISTNAME= Python-${PY_DISTVERSION}
EXTRACT_SUFX= .tar.xz
DISTINFO_FILE= ${.CURDIR}/../../lang/python37/distinfo

View file

@ -1,21 +1,19 @@
$NetBSD: distinfo,v 1.10 2019/05/02 12:50:42 wiedi Exp $
$NetBSD: distinfo,v 1.11 2019/07/09 07:46:37 adam Exp $
SHA1 (Python-3.7.3.tar.xz) = e3584650a06ae2765da0678176deae9d133f1b3d
RMD160 (Python-3.7.3.tar.xz) = 0095f3072e17edb789656442290f8abd0ec1bc58
SHA512 (Python-3.7.3.tar.xz) = 6d9b7c0f1764e0f655a39430a3af6f7b5e3c9b7166c042e780677a54b17ad4ca6d0d9cba262c82b1b70bba8f7c28883dad4cc0d7cc194fc7d2c1b5f4f08a763a
Size (Python-3.7.3.tar.xz) = 17108364 bytes
SHA1 (Python-3.7.4.tar.xz) = a862c5a58626fdad02d2047a57771ede2783fcef
RMD160 (Python-3.7.4.tar.xz) = b9ddfd1ad22b75920f37104ed2fbc0ab39c683f2
SHA512 (Python-3.7.4.tar.xz) = 71f64668c259f3ed07bd4aa239dbba6cc1b6b0a84d50bbff160664845d7986f757e4d65fca327e62a2d12ba593742ca83a22f7cb6093aff8715ec916c2ba9416
Size (Python-3.7.4.tar.xz) = 17131432 bytes
SHA1 (patch-Lib_ctypes_util.py) = 032cc99ebad93ddddfd89073c60424a952e3faa3
SHA1 (patch-Lib_distutils_command_install.py) = 6fc6f5d918b7581fc62cd0fe55857ee932c3a341
SHA1 (patch-Lib_distutils_sysconfig.py) = 6822eafb4dfded86d7f7353831816aeb8119e6cf
SHA1 (patch-Lib_distutils_unixccompiler.py) = 2e65a8dd5dd3fe25957206c062106fa7a6fc4e69
SHA1 (patch-Lib_sysconfig.py) = a4f009ed73ebbd9d9c4bf7e12b7981182ed8fd7c
SHA1 (patch-Makefile.pre.in) = 1393dac225c5a7edcb7947eb707b4526ea884f95
SHA1 (patch-Modules___uuidmodule.c) = fe66366866a924653b3d97625e8ef20be8766d25
SHA1 (patch-Modules_makesetup) = a06786eebffadecedba5e3a50a9785fb47613567
SHA1 (patch-Modules_nismodule.c) = 1bafe9b06359586d027a77011b103877590d947d
SHA1 (patch-Modules_socketmodule.c) = c0bdb256bccc176c2406feec4080cd91fcb693b2
SHA1 (patch-Modules_socketmodule.h) = 13a3290eb72078067060d3e71b7baa08f3eb591c
SHA1 (patch-Python_pylifecycle.c) = e284e1cd8540727927e2028b1f3f21fbd3d24eac
SHA1 (patch-Python_thread__pthread.h) = fb81eaa604b4ed7c1b64c3f4731d58a8aee257be
SHA1 (patch-configure) = 7945fe47fe894a33aceea06918c4740197e4135a
SHA1 (patch-pyconfig.h.in) = 58e2c03489f9b6e4d88f144d8c09773f92eacd61

View file

@ -1,16 +0,0 @@
$NetBSD: patch-Modules___uuidmodule.c,v 1.1 2018/07/03 03:55:40 adam Exp $
Do not include uuid.h from both locations.
--- Modules/_uuidmodule.c.orig 2018-05-07 06:24:32.000000000 +0000
+++ Modules/_uuidmodule.c
@@ -3,8 +3,7 @@
#include "Python.h"
#ifdef HAVE_UUID_UUID_H
#include <uuid/uuid.h>
-#endif
-#ifdef HAVE_UUID_H
+#elif defined(HAVE_UUID_H)
#include <uuid.h>
#endif

View file

@ -1,18 +0,0 @@
$NetBSD: patch-Python_pylifecycle.c,v 1.2 2019/04/25 17:44:22 leot Exp $
NetBSD is also affected by bpo-30225 (<https://bugs.python.org/issue30225>),
use fstat(2) on NetBSD too. Fixes PR pkg/53229.
Reported upstream via bpo-33384: <https://bugs.python.org/issue33384>
--- Python/pylifecycle.c.orig 2019-03-25 20:21:05.000000000 +0000
+++ Python/pylifecycle.c
@@ -1672,7 +1672,7 @@ initsite(void)
static int
is_valid_fd(int fd)
{
-#ifdef __APPLE__
+#if defined(__APPLE__) || defined(__NetBSD__)
/* bpo-30225: On macOS Tiger, when stdout is redirected to a pipe
and the other side of the pipe is closed, dup(1) succeed, whereas
fstat(1, &st) fails with EBADF. Prefer fstat() over dup() to detect