Patches forgotten to cvs add first.
This commit is contained in:
parent
c207c3f459
commit
574a687bf2
4 changed files with 65 additions and 0 deletions
16
graphics/cqcam/patches/patch-aa
Normal file
16
graphics/cqcam/patches/patch-aa
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-aa,v 1.10 2008/10/01 22:12:40 joerg Exp $
|
||||
|
||||
--- cli/Makefile.in.orig 2008-10-01 23:37:58.000000000 +0200
|
||||
+++ cli/Makefile.in
|
||||
@@ -16,8 +16,9 @@ clean:
|
||||
rm -f *.o core $(PROGRAMS)
|
||||
|
||||
bininstall:
|
||||
- mkdir -p $(bindir)
|
||||
- $(INSTALL) -o root -g @bingroup@ -m 4711 $(PROGRAMS) movify $(bindir)
|
||||
+ ${BSD_INSTALL_PROGRAM_DIR} ${DESTDIR}$(bindir)
|
||||
+ ${BSD_INSTALL_PROGRAM} $(PROGRAMS) ${DESTDIR}$(bindir)
|
||||
+ ${BSD_INSTALL_SCRIPT} movify ${DESTDIR}$(bindir)
|
||||
|
||||
cqcam: cqcam.o $(LIBCQCAM)
|
||||
$(CXX) -o $@ cqcam.o $(LDFLAGS) $(LIBS)
|
15
graphics/cqcam/patches/patch-ad
Normal file
15
graphics/cqcam/patches/patch-ad
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ad,v 1.3 2008/10/01 22:12:40 joerg Exp $
|
||||
|
||||
--- webcam/Makefile.in.orig 2008-10-01 23:40:32.000000000 +0200
|
||||
+++ webcam/Makefile.in
|
||||
@@ -19,8 +19,8 @@ webcam: webcam.o $(LIBCQCAM)
|
||||
$(CXX) $(LDFLAGS) -o $@ webcam.o $(LDLIBS) $(LIBS)
|
||||
|
||||
bininstall:
|
||||
- mkdir -p $(bindir)
|
||||
- $(INSTALL) -o root -g @bingroup@ -m 4711 $(PROGRAMS) $(bindir)
|
||||
+ ${BSD_INSTALL_PROGRAM_DIR} ${DESTDIR}$(bindir)
|
||||
+ ${BSD_INSTALL_PROGRAM} $(PROGRAMS) ${DESTDIR}$(bindir)
|
||||
|
||||
$(LIBCQCAM):
|
||||
cd ../libcqcam ; $(MAKE) ; cd ../gtkfe
|
19
graphics/cqcam/patches/patch-ae
Normal file
19
graphics/cqcam/patches/patch-ae
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-ae,v 1.3 2008/10/01 22:12:40 joerg Exp $
|
||||
|
||||
--- Makefile.in.orig 2000-08-23 20:21:16.000000000 +0200
|
||||
+++ Makefile.in
|
||||
@@ -36,10 +36,10 @@ bininstall: all
|
||||
|
||||
maninstall: docs/cqcam.1
|
||||
@echo -n Installing man pages...
|
||||
- @$(MANINSTALL) -o root -g @bingroup@ -m 644 docs/cqcam.1 $(mandir)/man1
|
||||
- @mkdir -p $(mandir)/man1
|
||||
- @echo ".so man1/cqcam.1" > $(mandir)/man1/xcqcam.1
|
||||
- @echo ".so man1/cqcam.1" > $(mandir)/man1/webcam.1
|
||||
+ @${BSD_INSTALL_MAN_DIR} ${DESTDIR}$(mandir)/man1
|
||||
+ @${BSD_INSTALL_MAN} docs/cqcam.1 ${DESTDIR}$(mandir)/man1
|
||||
+ @ln -s cqcam.1 ${DESTDIR}$(mandir)/man1/xcqcam.1
|
||||
+ @ln -s cqcam.1 ${DESTDIR}$(mandir)/man1/webcam.1
|
||||
@echo " done"
|
||||
|
||||
clean:
|
15
graphics/cqcam/patches/patch-af
Normal file
15
graphics/cqcam/patches/patch-af
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-af,v 1.5 2008/10/01 22:12:40 joerg Exp $
|
||||
|
||||
--- xfe/Makefile.in.orig 2000-08-17 12:41:04.000000000 +0200
|
||||
+++ xfe/Makefile.in
|
||||
@@ -20,8 +20,8 @@ xcqcam: $(OBJS) $(LIBCQCAM)
|
||||
$(CXX) -o $@ $(OBJS) $(LDFLAGS) $(LIBS)
|
||||
|
||||
bininstall:
|
||||
- mkdir -p $(bindir)
|
||||
- $(INSTALL) -o root -g @bingroup@ -m 4711 $(PROGRAMS) $(bindir)
|
||||
+ ${BSD_INSTALL_PROGRAM_DIR} ${DESTDIR}$(bindir)
|
||||
+ ${BSD_INSTALL_PROGRAM} $(PROGRAMS) ${DESTDIR}$(bindir)
|
||||
|
||||
$(LIBCQCAM):
|
||||
cd ../libcqcam ; $(MAKE) ; cd ../gtkfe
|
Loading…
Reference in a new issue