Initial import of p5-Mac-AppleScript-Glue version 0.03 in the NetBSD

Packages Collection.

The Perl 5 module Mac::AppleScript::Glue allows you to write Perl
code in object-oriented syntax to control Mac applications. The
module does not actually execute Apple Events, but actually translates
Perl code to AppleScript code and causes it to be executed.
This commit is contained in:
seb 2010-02-18 02:56:35 +00:00
parent d632ab2165
commit 57dbcedfe5
7 changed files with 119 additions and 0 deletions

View file

@ -0,0 +1,4 @@
The Perl 5 module Mac::AppleScript::Glue allows you to write Perl
code in object-oriented syntax to control Mac applications. The
module does not actually execute Apple Events, but actually translates
Perl code to AppleScript code and causes it to be executed.

View file

@ -0,0 +1,22 @@
# $NetBSD: Makefile,v 1.1.1.1 2010/02/18 02:56:35 seb Exp $
DISTNAME= Mac-AppleScript-Glue-0.03
PKGNAME= p5-${DISTNAME}
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Mac/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://search.cpan.org/dist/Mac-AppleScript-Glue/
COMMENT= Perl 5 module allowing AppleScript to be written in Perl
PKG_DESTDIR_SUPPORT= user-destdir
USE_LANGUAGES= # empty
ONLY_FOR_PLATFORM= Darwin-*-*
PERL5_PACKLIST= auto/Mac/AppleScript/Glue/.packlist
DEPENDS+= p5-Mac-AppleScript>=0.03:../../sysutils/p5-Mac-AppleScript
BUILD_DEPENDS+= p5-Test-Pod-[0-9]*:../../devel/p5-Test-Pod
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,9 @@
$NetBSD: distinfo,v 1.1.1.1 2010/02/18 02:56:35 seb Exp $
SHA1 (Mac-AppleScript-Glue-0.03.tar.gz) = 934293946f78cb8e8838931d411d45592f4e363c
RMD160 (Mac-AppleScript-Glue-0.03.tar.gz) = 9ed438297477bfc2b9ebd04e9fe1566842b8043e
Size (Mac-AppleScript-Glue-0.03.tar.gz) = 13229 bytes
SHA1 (patch-aa) = 3a4c0c9c97ccc5439c3f20a3fbdd36982919c42e
SHA1 (patch-ab) = e379f128c98f3d36ee692f52ffb26b4425a6e0cc
SHA1 (patch-ac) = 0ba14c484a70a4ebb18ad4e83fac6ab263452472
SHA1 (patch-ad) = f4d1a9d87f3aade747c9e67eab08bb2135cc6d5b

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1.1.1 2010/02/18 02:56:35 seb Exp $
Use prefered form, warning free with current Perl, for require's argument.
--- Glue.pm.orig 2002-09-15 07:48:11.000000000 +0200
+++ Glue.pm
@@ -231,7 +231,7 @@ statements that work even though they lo
use strict;
use warnings;
-require 5.6.0;
+require 5.006_000;
######################################################################

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1.1.1 2010/02/18 02:56:35 seb Exp $
Prevent division by 0 for disks with no free space.
--- t/finder.t.orig 2002-09-12 16:24:21.000000000 +0200
+++ t/finder.t
@@ -36,7 +36,7 @@ ok($disks)
for my $disk (ref($disks) eq 'ARRAY' ? @{$disks} : $disks) {
my $name = $disk->name;
- my $free = int($disk->free_space / 1024 / 1024);
+ my $free = ($disk->free_space ? int($disk->free_space / 1024 / 1024) : 0);
print "disk \"$name\" has ${free} mb free\n";
}

View file

@ -0,0 +1,32 @@
$NetBSD: patch-ac,v 1.1.1.1 2010/02/18 02:56:35 seb Exp $
Modernize POP tests.
--- t/pod.t.orig 2002-09-08 05:18:03.000000000 +0200
+++ t/pod.t
@@ -7,21 +7,7 @@
use strict;
-my %pods;
-
-BEGIN {
- use Pod::Find qw(pod_find);
-
- %pods = pod_find(
- {
- -verbose => 1,
- },
- 'blib'
- );
-}
-
-use Test::Pod tests => scalar keys %pods;
-
-for my $pod (keys %pods) {
- pod_ok($pod);
-}
+use Test::More;
+eval "use Test::Pod 1.00";
+plan skip_all => "Test::Pod 1.00 required for testing POD" if $@;
+all_pod_files_ok();

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ad,v 1.1.1.1 2010/02/18 02:56:35 seb Exp $
Modern Quicktime Player can open a PNG file, so try to open
a movie file instead.
--- t/quicktime.t.orig 2002-09-12 16:25:40.000000000 +0200
+++ t/quicktime.t
@@ -28,9 +28,12 @@ ok(defined $quicktime)
or die "can't initialize application object (Quicktime)\n";
######################################################################
-
+my $path =
+'/System/Library/PreferencePanes/Mouse.prefPane/Contents/Resources/touchMovie.mov';
+$path = '/System/Library/CoreServices/Dock.app/Contents/Resources/finder.png'
+if ( ! -f $path );
my $file = $quicktime->objref(
- posix_file => "/System/Library/CoreServices/Dock.app/Contents/Resources/finder.png",
+ posix_file => $path,
);
ok(defined $file)