Look for config files and esd module in pkgsrc path. From Tatsuya

Kobayashi in PR 31236.
Bump PKGREVISION.
This commit is contained in:
wiz 2007-01-04 00:15:03 +00:00
parent ea535fc2fd
commit 57ebd3f3a0
4 changed files with 32 additions and 21 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.21 2006/09/09 02:41:56 obache Exp $
# $NetBSD: Makefile,v 1.22 2007/01/04 00:15:03 wiz Exp $
DISTNAME= allegro-4.2.0
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=alleg/}
@ -28,6 +28,12 @@ SUBST_FILES.oss= src/unix/uoss.c setup/setup.c
SUBST_SED.oss= -e "s,/dev/dsp,"${DEVOSSAUDIO:Q}",g"
SUBST_MESSAGE.oss= Fixing hardcoded audio device.
SUBST_CLASSES+= path
SUBST_STAGE.path= post-patch
SUBST_FILES.path= src/unix/umodules.c src/unix/usystem.c
SUBST_SED.path= -e "s,@@PREFIX@@,${PREFIX},g"
SUBST_MESSAGE.path= Fixing hardcoded path.
.include "../../mk/oss.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/x11.buildlink3.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.13 2006/10/12 17:20:19 rillig Exp $
$NetBSD: distinfo,v 1.14 2007/01/04 00:15:03 wiz Exp $
SHA1 (allegro-4.2.0.tar.gz) = 5b4a542c038ee196564f9107de59fe30a8caeaf5
RMD160 (allegro-4.2.0.tar.gz) = e1602ea2f8bc1761be0ee34001e9d77d3a6ea3ff
@ -8,5 +8,5 @@ SHA1 (patch-ab) = f33f1a96394f16398246d3bc1d5cab89df4860e8
SHA1 (patch-ac) = 78f99723b095f460f20e8367fffb443a8f3d6ab6
SHA1 (patch-ad) = 52f694e1b0053cff94c53ee10f603d535eba5fa5
SHA1 (patch-ae) = 32e5ecd77e58bb6926c207c668755043448457f9
SHA1 (patch-ax) = e01206c35df3b951d686c22f3e0ebf6ec2196e20
SHA1 (patch-ay) = 66813e0b018db01a34bf014962e9a4630d8aec0d
SHA1 (patch-ax) = b79d1bf82fc0e9bba9b7d81e6d2005f35a217ca0
SHA1 (patch-ay) = 61f13ecf46da56e396039d8ecfda6e822d80fb04

View file

@ -1,23 +1,25 @@
$NetBSD: patch-ax,v 1.3 2006/03/22 23:53:33 jlam Exp $
$NetBSD: patch-ax,v 1.4 2007/01/04 00:15:03 wiz Exp $
--- src/unix/usystem.c.orig 2005-09-04 12:00:17.000000000 -0400
--- src/unix/usystem.c.orig 2005-09-04 16:00:17.000000000 +0000
+++ src/unix/usystem.c
@@ -129,15 +129,15 @@ int _unix_find_resource(char *dest, AL_C
}
@@ -130,6 +130,7 @@ int _unix_find_resource(char *dest, AL_C
}
- /* if it is a .dat, look in /usr/share/ and /usr/local/share/ */
+ /* if it is a .dat, look in ${PREFIX}/share/ and /usr/share/ */
/* if it is a .dat, look in /usr/share/ and /usr/local/share/ */
+ /* and @@PREFIX@@/share in NetBSD */
if (ustricmp(get_extension(resource), uconvert_ascii("dat", tmp)) == 0) {
- ustrzcpy(buf, sizeof(buf), uconvert_ascii("/usr/share/allegro/", tmp));
+ ustrzcpy(buf, sizeof(buf), uconvert_ascii(INSTPREFIX "/share/allegro/", tmp));
ustrzcpy(buf, sizeof(buf), uconvert_ascii("/usr/share/allegro/", tmp));
ustrzcat(buf, sizeof(buf), resource);
if (exists(buf)) {
@@ -137,6 +138,12 @@ int _unix_find_resource(char *dest, AL_C
ustrzcpy(dest, size, buf);
return 0;
}
- ustrzcpy(buf, sizeof(buf), uconvert_ascii("/usr/local/share/allegro/", tmp));
+ ustrzcpy(buf, sizeof(buf), uconvert_ascii("/usr/share/allegro/", tmp));
+ ustrzcpy(buf, sizeof(buf), uconvert_ascii("@@PREFIX@@/share/allegro/", tmp));
+ ustrzcat(buf, sizeof(buf), resource);
+ if (exists(buf)) {
+ ustrzcpy(dest, size, buf);
+ return 0;
+ }
ustrzcpy(buf, sizeof(buf), uconvert_ascii("/usr/local/share/allegro/", tmp));
ustrzcat(buf, sizeof(buf), resource);
if (exists(buf)) {
ustrzcpy(dest, size, buf);

View file

@ -1,13 +1,16 @@
$NetBSD: patch-ay,v 1.3 2006/03/22 23:53:33 jlam Exp $
$NetBSD: patch-ay,v 1.4 2007/01/04 00:15:03 wiz Exp $
--- src/unix/umodules.c.orig 2005-09-04 12:00:17.000000000 -0400
--- src/unix/umodules.c.orig 2005-09-04 16:00:17.000000000 +0000
+++ src/unix/umodules.c
@@ -44,7 +44,7 @@ static MODULE *module_list = NULL;
@@ -44,7 +44,10 @@ static MODULE *module_list = NULL;
/* where to look for modules.lst */
static char *module_path[] =
{
- "/usr/local/lib/allegro/", "/usr/lib/allegro/", NULL
+ INSTPREFIX "/lib/allegro/", "/usr/lib/allegro/", NULL
+ "@@PREFIX@@/lib/allegro/",
+ "/usr/local/lib/allegro/",
+ "/usr/lib/allegro/",
+ NULL
};