lhasa: update to 0.4.0.

Upstream changes:
 https://github.com/fragglet/lhasa/blob/v0.4.0/NEWS

v0.4.0 (2023-05-14):

     * The manpage was expanded, with more information about different
       compression formats, example commands, a BUGS section and some
       additional references in the SEE ALSO section.
     * A verbose mode was added to the list output that shows the full file
       timestamp (thanks Dan Fandrich).
     * Support for archives generated by the DOS LHARK tool was added; big
       thanks go to Jason Summers for his tool DEARK and his comprehensive
       writeup on the LHARK format.
     * Some changes were made for compatibility with old versions of
       autotools (thanks Ozkan Sezer).
     * Some tweaks were made to tests to make them work on BSD systems.
     * Segmentation fault on NetBSD/amd64 was fixed when decoding 8-bit
       character filenames (thanks Izumi Tsutsui).
     * Some minor tweaks and fixes were made to the help text and manpage
       (thanks Stefan)
     * Some spelling mistakes were fixed, excess whitespace was trimmed, and
       the website link in the RPC spec file was fixed (thanks a1346054 and
       Jakub Wilk).
     * A potential integer overflow in the lha_decode_*uint32 functions was
       fixed (thanks Jacub Wilk).
This commit is contained in:
tsutsui 2023-05-14 16:11:22 +00:00
parent 704a3cb922
commit 58062f2d6c
4 changed files with 8 additions and 51 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.11 2022/01/23 21:50:02 fcambus Exp $
# $NetBSD: Makefile,v 1.12 2023/05/14 16:11:22 tsutsui Exp $
DISTNAME= lhasa-0.3.1
PKGREVISION= 1
DISTNAME= lhasa-0.4.0
CATEGORIES= archivers
MASTER_SITES= https://soulsphere.org/projects/lhasa/

View File

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.1 2019/09/21 11:14:23 nia Exp $
# $NetBSD: buildlink3.mk,v 1.2 2023/05/14 16:11:22 tsutsui Exp $
BUILDLINK_TREE+= lhasa
.if !defined(LHASA_BUILDLINK3_MK)
LHASA_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.lhasa+= lhasa>=0.3.1
BUILDLINK_API_DEPENDS.lhasa+= lhasa>=0.4.0
BUILDLINK_PKGSRCDIR.lhasa?= ../../archivers/lhasa
.endif # LHASA_BUILDLINK3_MK

View File

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.11 2021/10/26 09:57:08 nia Exp $
$NetBSD: distinfo,v 1.12 2023/05/14 16:11:22 tsutsui Exp $
BLAKE2s (lhasa-0.3.1.tar.gz) = c184e9fd2cb6497fe981578be3fdcfe00f96c31f7ca80d5057713a0d5a61dab8
SHA512 (lhasa-0.3.1.tar.gz) = 6e4797aaa054f2ecd25069b32b809ab0111d0179adfd9c676e0609d69efbcc968ec6dce67fbd8ce6bccc102d09ee69996805a5542882b432731e3c273f132c05
Size (lhasa-0.3.1.tar.gz) = 2933084 bytes
SHA1 (patch-lib_lha__file__header.c) = 5603af72663f9d154dd1bdae7839ece1ea22d54a
BLAKE2s (lhasa-0.4.0.tar.gz) = 2812dd3862edd7d455710aeff9f69d84f2920be2967032863a6b142ee97481b0
SHA512 (lhasa-0.4.0.tar.gz) = 55d11a9a23e6a9c847166f963bc11dcc7aba0db1e68c44ae6d0ee40e40494484ff797b649a386bea76ea9b4ff8096722283c82b9ad253d784488366c9d73c127
Size (lhasa-0.4.0.tar.gz) = 3503963 bytes

View File

@ -1,41 +0,0 @@
$NetBSD: patch-lib_lha__file__header.c,v 1.1 2020/11/16 15:48:44 tsutsui Exp $
- avoid SIGSEGV on NetBSD/amd64 on decoding 8bit char filenames.
https://github.com/fragglet/lhasa/pull/33
--- lib/lha_file_header.c.orig 2016-03-30 02:28:14.000000000 +0000
+++ lib/lha_file_header.c
@@ -194,7 +194,7 @@ static void fix_msdos_allcaps(LHAFileHea
if (header->path != NULL) {
for (i = 0; header->path[i] != '\0'; ++i) {
- if (islower((unsigned) header->path[i])) {
+ if (islower((int)(unsigned char) header->path[i])) {
is_allcaps = 0;
break;
}
@@ -203,7 +203,7 @@ static void fix_msdos_allcaps(LHAFileHea
if (is_allcaps && header->filename != NULL) {
for (i = 0; header->filename[i] != '\0'; ++i) {
- if (islower((unsigned) header->filename[i])) {
+ if (islower((int)(unsigned char) header->filename[i])) {
is_allcaps = 0;
break;
}
@@ -216,13 +216,13 @@ static void fix_msdos_allcaps(LHAFileHea
if (header->path != NULL) {
for (i = 0; header->path[i] != '\0'; ++i) {
header->path[i]
- = tolower((unsigned) header->path[i]);
+ = tolower((int)(unsigned char) header->path[i]);
}
}
if (header->filename != NULL) {
for (i = 0; header->filename[i] != '\0'; ++i) {
header->filename[i]
- = tolower((unsigned) header->filename[i]);
+ = tolower((int)(unsigned char) header->filename[i]);
}
}
}