audio/eflite: import eflite-0.0.0.86

Packaged in wip by adr

Eflite is a speech server which allows screen readers like Emacspeak
or Yasrs to interact with the speech sinthesizer Flite.
This commit is contained in:
wiz 2024-02-25 22:00:09 +00:00
parent 377a8ca479
commit 5806a7955f
8 changed files with 124 additions and 0 deletions

2
audio/eflite/DESCR Normal file
View File

@ -0,0 +1,2 @@
Eflite is a speech server which allows screen readers like Emacspeak
or Yasrs to interact with the speech sinthesizer Flite.

28
audio/eflite/Makefile Normal file
View File

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1 2024/02/25 22:00:09 wiz Exp $
COMMITS= 86
DISTNAME= eflite-0.0.0.${COMMITS}
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_GITHUB:=mgorse/}
GITHUB_TAG= 21b950b64c268626351f98625fa1344b37881f1a
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/mgorse/eflite
COMMENT= Speech server for screen readers using Festival Lite
LICENSE= gnu-gpl-v2
USE_LANGUAGES= c
USE_TOOLS= gmake autoconf automake autoreconf
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= CFLAGS="${CFLAGS} -DDO_WAVE_CANCEL"
CONFIGURE_ARGS+= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+= DESTDIR="${DESTDIR}"
BUILD_TARGET= eflite
pre-configure:
set -e; cd ${WRKSRC} && autoreconf -fi
.include "../../audio/flite/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

2
audio/eflite/PLIST Normal file
View File

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST,v 1.1 2024/02/25 22:00:09 wiz Exp $
bin/eflite

9
audio/eflite/distinfo Normal file
View File

@ -0,0 +1,9 @@
$NetBSD: distinfo,v 1.1 2024/02/25 22:00:09 wiz Exp $
BLAKE2s (eflite-0.0.0.86-21b950b64c268626351f98625fa1344b37881f1a.tar.gz) = 2e755246d7528c943ee5a7f1c946ac6577e2a82fb12ca62879058b8f69bcd7f3
SHA512 (eflite-0.0.0.86-21b950b64c268626351f98625fa1344b37881f1a.tar.gz) = 1e8e272aebdce1723dd83c50f1f7c62f83f93491fc19548ec4ae40faccdcc60d7e3d0ee66c6df7922f110ae3bdca0a9b27dde6792589af25bf8cc5995698e222
Size (eflite-0.0.0.86-21b950b64c268626351f98625fa1344b37881f1a.tar.gz) = 32390 bytes
SHA1 (patch-Makefile.in) = f77c612548471c3465860afc9568426ee5faaca8
SHA1 (patch-fs.c) = 21dc050709e9038b74159a4d614dac4b462eaf06
SHA1 (patch-soccon.c) = 33074b1d582738919e7df5a735e204f2aefdfb90
SHA1 (patch-sockopen.c) = 750cb4431307c182692a0a59e105c5be8e32e539

View File

@ -0,0 +1,36 @@
$NetBSD: patch-Makefile.in,v 1.1 2024/02/25 22:00:09 wiz Exp $
Add DEFS to CFLAGS (for string.h)
Use DESTDIR in install target
--- Makefile.in.orig 2024-01-14 23:55:06.000000000 +0000
+++ Makefile.in
@@ -4,7 +4,7 @@
# Do not hand edit.
CC = @CC@
-CFLAGS = @CFLAGS@
+CFLAGS = @CFLAGS@ @DEFS@
CPPFLAGS = @CPPFLAGS@
DEFS = @DEFS@
LDFLAGS = @LDFLAGS@
@@ -18,8 +18,8 @@ FL_LEX = @FL_LEX@
exec_prefix = @exec_prefix@
prefix = @prefix@
EXEEXT = @EXEEXT@
-INSTALLBINDIR = @bindir@
-INSTALLLIBDIR = @libdir@
+INSTALLBINDIR = $(DESTDIR)/@bindir@
+INSTALLLIBDIR = $(DESTDIR)@libdir@
#CFLAGS+= -DDEBUG=2
#CFLAGS+= -DDO_WAVE_CANCEL
@@ -52,7 +52,7 @@ ifneq (,$(wildcard *.o))
endif
install: eflite
- mkdir -p $(exec_prefix)/bin && install -c -m 0755 $< $(exec_prefix)/bin
+ mkdir -p $(INSTALLBINDIR) && install -c -m 0755 $< $(INSTALLBINDIR)
test: eflite
./eflite -f eflite_test.txt

View File

@ -0,0 +1,15 @@
$NetBSD: patch-fs.c,v 1.1 2024/02/25 22:00:09 wiz Exp $
Remove useless operator (typo)
--- fs.c.orig 2024-02-25 17:04:42.792873829 +0000
+++ fs.c
@@ -902,7 +902,7 @@ static int s_clear(synth_t *s)
{
wave_thread_cancel = 1;
#ifdef DO_WAVE_CANCEL
-- pthread_cancel(wave_thread);
+ pthread_cancel(wave_thread);
#endif
pthread_cond_signal(&wave_condition); // necessary because we inhibit cancellation while waiting
}

View File

@ -0,0 +1,16 @@
$NetBSD: patch-soccon.c,v 1.1 2024/02/25 22:00:09 wiz Exp $
Add string.h inclusion when needed
--- soccon.c.orig 2024-01-14 23:55:06.000000000 +0000
+++ soccon.c
@@ -10,6 +10,9 @@
#include <arpa/inet.h>
#include <sys/un.h>
#include <unistd.h>
+#ifdef HAVE_STRING_H
+# include <string.h>
+#endif
int sockconnect_unix(const char *fname)
{

View File

@ -0,0 +1,16 @@
$NetBSD: patch-sockopen.c,v 1.1 2024/02/25 22:00:09 wiz Exp $
Add string.h inclusion when needed
--- sockopen.c.orig 2024-01-14 23:55:06.000000000 +0000
+++ sockopen.c
@@ -11,6 +11,9 @@
#include <sys/stat.h>
#include <sys/un.h>
#include <syslog.h>
+#ifdef HAVE_STRING_H
+# include <string.h>
+#endif
int sockopen_unix(const char *fname)
{