fix some build glitches (require "msgfmt" binary, -export-dynamic)

and python problems (script bugs and version dependencies, depend on
 py-mxDateTime)
This commit is contained in:
drochner 2001-07-02 14:29:45 +00:00
parent 14907a3a5d
commit 581135744e
5 changed files with 58 additions and 8 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2001/06/30 16:56:30 tron Exp $
# $NetBSD: Makefile,v 1.7 2001/07/02 14:29:45 drochner Exp $
#
DISTNAME= emma-0.8-1
@ -14,10 +14,13 @@ COMMENT= Money management program
BUILD_DEPENDS+= automake-1.4:../../devel/automake
DEPENDS+= gnome-libs-*:../../x11/gnome-libs
DEPENDS+= python>=2.0:../../lang/python
DEPENDS+= py-mxDateTime-*:../../time/py-mxDateTime
USE_X11BASE= YES
GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_LIBINTL= yes
BUILD_USES_MSGFMT= yes
WRKSRC= ${WRKDIR}/emma-0.8
@ -27,5 +30,4 @@ post-extract:
${CP} ${LOCALBASE}/share/automake/$$FILE ${WRKSRC}/$$FILE; \
done
.include "../../devel/gettext-lib/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.5 2001/06/30 16:56:30 tron Exp $
$NetBSD: distinfo,v 1.6 2001/07/02 14:29:45 drochner Exp $
SHA1 (emma-0.8-1.tar.gz) = 06c0216a441511b88c36d7d600b9e6e5b443f6d3
Size (emma-0.8-1.tar.gz) = 409664 bytes
SHA1 (patch-aa) = 55412520766343b18c46b1b4e13cc58077a14269
SHA1 (patch-ab) = 2e47edb27702a38e91c45010052d288cd1fe8cd2
SHA1 (patch-ab) = b40e3014cd9287aebf3c19759edc2d4ddcbf9ffe
SHA1 (patch-ac) = d4519cc7d6c1b9d982855be957b88a33f38c3c3d
SHA1 (patch-ad) = 5e0e39e13b2de33942fce6d5d3d72d7755139851
SHA1 (patch-ae) = 9d624620c2702a1a2b6888a715e5ac3e63b21f96

View file

@ -1,12 +1,14 @@
$NetBSD: patch-ab,v 1.1 2001/06/30 16:56:30 tron Exp $
$NetBSD: patch-ab,v 1.2 2001/07/02 14:29:45 drochner Exp $
--- src/Makefile.in.orig Fri Nov 3 13:16:27 2000
+++ src/Makefile.in Sat Jun 30 18:50:41 2001
@@ -150,7 +150,7 @@
+++ src/Makefile.in Mon Jul 2 15:11:52 2001
@@ -149,8 +149,8 @@
report_grp_axis.o report_progress.o schedule.o schedule_dlg.o sm.o \
toolbar.o transaction_dlg.o
emma_DEPENDENCIES =
emma_LDFLAGS =
-emma_LDFLAGS =
-CFLAGS = @CFLAGS@
+emma_LDFLAGS = -export-dynamic
+CFLAGS = @CFLAGS@ -DPREFIX=\"@prefix@\"
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ad,v 1.1 2001/07/02 14:29:45 drochner Exp $
--- data/standard.py.orig Mon Jul 2 15:12:57 2001
+++ data/standard.py Mon Jul 2 15:13:41 2001
@@ -48,7 +48,7 @@
"Example : CurDay()");
A = NormalisedTime()
-FirstDayOfMonth = time.mktime(A[0], A[1], 1, A[3], A[4], A[5], A[6], A[7], A[8]);
+FirstDayOfMonth = time.mktime((A[0], A[1], 1, A[3], A[4], A[5], A[6], A[7], A[8]));
def CurMonth():
return emma.date() >= FirstDayOfMonth
@@ -59,7 +59,7 @@
"Example : CurMonth()");
A = NormalisedTime()
-FirstDayOfYear = time.mktime(A[0], 1, 1, A[3], A[4], A[5], A[6], A[7], A[8]);
+FirstDayOfYear = time.mktime((A[0], 1, 1, A[3], A[4], A[5], A[6], A[7], A[8]));
def CurYear():
return emma.date() >= FirstDayOfYear

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ae,v 1.1 2001/07/02 14:29:46 drochner Exp $
--- data/date.py.orig Mon Jul 2 16:07:58 2001
+++ data/date.py Mon Jul 2 16:08:36 2001
@@ -57,7 +57,7 @@
return emma.date() >= this.ticks() and emma.date() < next.ticks()
emma.register_func("MonthExt",\
- "Args: numMonths, offset\n\n",\
+ "Args: numMonths, offset\n\n"\
"Returns True if the transaction happened\n"\
"in the next <numMonths> months offset by\n"\
"<offset> weeks.\n\n"\
@@ -72,7 +72,7 @@
return emma.date() >= this.ticks() and emma.date() < next.ticks()
emma.register_func("YearExt",\
- "Args: numYears, offset\n\n",\
+ "Args: numYears, offset\n\n"\
"Returns True if the transaction happened in\n"\
"the next <numYears> year offset by <offset>\n"\
"years.\n\n"\