Add a patch to fix cmew's case significant problem of keys.
Bump PKGREVISION.
This commit is contained in:
parent
a301355c98
commit
58696385b7
3 changed files with 52 additions and 2 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.84 2011/10/19 18:32:50 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.85 2012/01/31 14:52:20 taca Exp $
|
||||
|
||||
DISTNAME= mew-6.4
|
||||
PKGNAME= ${EMACS_PKGNAME_PREFIX}${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.mew.org/Release/
|
||||
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.41 2011/10/19 18:32:50 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.42 2012/01/31 14:52:20 taca Exp $
|
||||
|
||||
SHA1 (mew-6.4.tar.gz) = 260cf65b0852c2e871faa1c34a445ab692e26359
|
||||
RMD160 (mew-6.4.tar.gz) = 295634fa5b2a58a29a8e5c2d271900990d726835
|
||||
Size (mew-6.4.tar.gz) = 1025983 bytes
|
||||
SHA1 (patch-aa) = 7d98b2408108ef93137677373b289e7658949209
|
||||
SHA1 (patch-bin_cmew) = 245712f3d5fb60ec4e87f85c56f26c67f1440fe9
|
||||
|
|
48
mail/mew/patches/patch-bin_cmew
Normal file
48
mail/mew/patches/patch-bin_cmew
Normal file
|
@ -0,0 +1,48 @@
|
|||
$NetBSD: patch-bin_cmew,v 1.1 2012/01/31 14:52:20 taca Exp $
|
||||
|
||||
Fix case significant problem of keys.
|
||||
|
||||
--- bin/cmew.orig 2011-10-19 08:46:38.000000000 +0000
|
||||
+++ bin/cmew
|
||||
@@ -29,7 +29,8 @@ def mail_header(path)
|
||||
next if /^From / =~ l
|
||||
break if /^$/ =~ l
|
||||
if /^\s+/ !~ l
|
||||
- (name, value) = l.split(/:\s+/, 2)
|
||||
+ (name, value) = l.split(/:\s*/, 2)
|
||||
+ value = '' if value.nil?
|
||||
@header[name.downcase] = value
|
||||
else
|
||||
value << $'
|
||||
@@ -103,7 +104,7 @@ def check_id(id)
|
||||
end
|
||||
|
||||
def get_id(msg)
|
||||
- return check_id(msg['Message-Id'])
|
||||
+ return check_id(msg['message-id'])
|
||||
end
|
||||
|
||||
def get_parid(msg)
|
||||
@@ -111,11 +112,11 @@ def get_parid(msg)
|
||||
# (2) The References contains one or more IDs, use the last one.
|
||||
# (3) The In-Reply-To contains two or more IDs, use the first one.
|
||||
irt = []
|
||||
- irt = msg['In-Reply-To'].split(/[ \t\n]+/) if msg['In-Reply-To']
|
||||
+ irt = msg['in-reply-to'].split(/[ \t\n]+/) if msg['in-reply-to']
|
||||
irt.delete_if {|id| !check_id(id) }
|
||||
return irt[0] if irt.size == 1
|
||||
ref = []
|
||||
- ref = msg['References'].split(/[ \t\n]+/) if msg['References']
|
||||
+ ref = msg['references'].split(/[ \t\n]+/) if msg['references']
|
||||
ref.delete_if {|id| !check_id(id) }
|
||||
return ref.pop if ref.size > 0
|
||||
return irt[0] if irt.size > 1
|
||||
@@ -124,7 +125,7 @@ end
|
||||
|
||||
def get_date(msg)
|
||||
begin
|
||||
- date = Time.rfc2822(msg['Date']).getutc().strftime('%Y%m%d%H%M%S')
|
||||
+ date = Time.rfc2822(msg['date']).getutc().strftime('%Y%m%d%H%M%S')
|
||||
rescue
|
||||
date = '19700101000000'
|
||||
end
|
Loading…
Reference in a new issue