Update to 0.72.3. Notable changes:
- Blu-ray support - added CD raw reading and majority algorithm - C2 scanning support for CD media - changed treatment of CRC failures: old behaviour was to store a defective sector marker; now the actual sector contents are written to the image file. - Using the CDROM_SEND_PACKET ioctl() will hang parallel SCSI adapters. Added tests to determine the SCSI bus type, and switch to the SG_IO ioctl() when in doubt. [Linux] - fixed and documented -n command line options for RS02.
This commit is contained in:
parent
bb03fb3439
commit
588a594942
9 changed files with 1022 additions and 326 deletions
|
@ -1,10 +1,10 @@
|
|||
CD and DVD media keep their data only for a finite time (typically for
|
||||
many years). After that time, data loss develops slowly with read errors
|
||||
growing from the outer media region towards the inside.
|
||||
Optical media (CD, DVD, BD) keep their data only for a finite time
|
||||
(typically for many years). After that time, data loss develops slowly
|
||||
with read errors growing from the outer media region towards the inside.
|
||||
|
||||
Dvdisaster stores data on CD/DVD in a way that it is fully recoverable
|
||||
even after some read errors have developed. This enables you to rescue
|
||||
the complete data to a new medium.
|
||||
Dvdisaster stores data on CD/DVD/BD in a way that it is fully
|
||||
recoverable even after some read errors have developed. This enables you
|
||||
to rescue the complete data to a new medium.
|
||||
|
||||
Data loss is prevented by using error correcting codes. Error correction
|
||||
data is either added to the medium or kept in separate error correction
|
||||
|
|
|
@ -1,14 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.13 2011/11/01 06:02:31 sbd Exp $
|
||||
# $NetBSD: Makefile,v 1.14 2012/02/04 21:57:54 shattered Exp $
|
||||
#
|
||||
|
||||
DISTNAME= dvdisaster-0.70.6
|
||||
PKGREVISION= 7
|
||||
DISTNAME= dvdisaster-0.72.3
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=dvdisaster/}
|
||||
MASTER_SITES= http://dvdisaster.net/downloads/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= shattered@NetBSD.org
|
||||
HOMEPAGE= http://www.dvdisaster.com/
|
||||
HOMEPAGE= http://www.dvdisaster.net/en/
|
||||
COMMENT= Protects data on optical media with error correcting codes
|
||||
|
||||
ONLY_FOR_PLATFORM= Darwin-*-* FreeBSD-*-* Linux-*-*
|
||||
|
@ -37,6 +36,8 @@ CONFIGURE_ARGS+= --with-embedded-src-path=no
|
|||
CONFIG_SHELL= ${TOOLS_PATH.bash}
|
||||
MAKE_FILE= GNUmakefile
|
||||
|
||||
CHECK_PORTABILITY_SKIP+=macinst/launcher.sh
|
||||
|
||||
post-install:
|
||||
rm -f ${DESTDIR}${PREFIX}/bin/dvdisaster-uninstall.sh
|
||||
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,11 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.4 2011/01/31 21:20:11 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.5 2012/02/04 21:57:54 shattered Exp $
|
||||
|
||||
SHA1 (dvdisaster-0.70.6.tar.bz2) = e5d6b301f2f9b1139a9ac5fa596bf4df9f7063c4
|
||||
RMD160 (dvdisaster-0.70.6.tar.bz2) = 8b88b3b12717b916e1877b6586fc777d64f6df26
|
||||
Size (dvdisaster-0.70.6.tar.bz2) = 1167208 bytes
|
||||
SHA1 (dvdisaster-0.72.3.tar.bz2) = 6ed08f8e52f4b90b39134b0caf9b5f0df221b0da
|
||||
RMD160 (dvdisaster-0.72.3.tar.bz2) = 63a2dcd4387bd2bfd4632270a53e4a0dfd5a692e
|
||||
Size (dvdisaster-0.72.3.tar.bz2) = 4168126 bytes
|
||||
SHA1 (patch-aa) = 97fe33bdc514925041718992b28d75b672b4be0c
|
||||
SHA1 (patch-ab) = 14caeb6c7b40db85c1dba75cc335a67e11551877
|
||||
SHA1 (patch-ad) = 56355c919f1b1cd4c716d1bf3e9a762afb8490e2
|
||||
SHA1 (patch-af) = c3819a7ea476878b293cc37005047852f52804f6
|
||||
SHA1 (patch-ag) = 4f941f14abcaba457dbec99935d07e91276df597
|
||||
SHA1 (patch-ab) = 5d47ca08389005d11618d6d9953f686312c716bf
|
||||
SHA1 (patch-ah) = 9cb1e03dc8c13e560a2f862811a4e828563db112
|
||||
SHA1 (patch-scsi-netbsd.c) = 076a625291bf8d29d6339fb2209d61712ceb6b62
|
||||
|
|
|
@ -1,14 +1,14 @@
|
|||
$NetBSD: patch-ab,v 1.3 2011/01/31 21:20:11 wiz Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2012/02/04 21:57:54 shattered Exp $
|
||||
|
||||
Fix build with png-1.5.
|
||||
|
||||
--- tools/pngpack.c.orig 2006-09-09 12:14:09.000000000 +0000
|
||||
+++ tools/pngpack.c
|
||||
@@ -46,6 +46,7 @@
|
||||
--- tools/pngio.h.orig 2010-10-27 12:41:49.000000000 +0000
|
||||
+++ tools/pngio.h
|
||||
@@ -21,6 +21,7 @@
|
||||
#define PNGIO_H
|
||||
|
||||
#include <bzlib.h>
|
||||
#include <png.h>
|
||||
+#include <zlib.h>
|
||||
|
||||
#include "md5.h"
|
||||
|
||||
typedef struct
|
||||
{ char *name;
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.2 2008/11/23 23:40:12 heinz Exp $
|
||||
|
||||
- Honor configure option --with-embedded-src-path
|
||||
(already committed in unstable version upstream)
|
||||
|
||||
--- closure.c.orig 2008-03-04 10:01:15.000000000 +0000
|
||||
+++ closure.c
|
||||
@@ -174,10 +174,13 @@ static void get_base_dirs()
|
||||
char *appdata;
|
||||
#endif
|
||||
|
||||
- /*** The source directory is supposed to hold the most recent files,
|
||||
+ /*** Unless completely disabled through a configure option, the
|
||||
+ source directory is supposed to hold the most recent files,
|
||||
so try this first. Not necessary under Windows as it will always
|
||||
use the directory the binary has been called from. */
|
||||
|
||||
+#ifdef WITH_EMBEDDED_SRC_PATH_YES
|
||||
+
|
||||
#ifndef SYS_MINGW
|
||||
if(!stat(SRCDIR, &mystat))
|
||||
{ Closure->binDir = g_strdup(SRCDIR);
|
||||
@@ -187,6 +190,8 @@ static void get_base_dirs()
|
||||
}
|
||||
#endif
|
||||
|
||||
+#endif /* WITH_EMBEDDED_SRC_PATH_YES */
|
||||
+
|
||||
/*** Otherwise try the installation directory.
|
||||
On Unices this is a hardcoded directory.
|
||||
Windows has binary distributions with no prior known installation place,
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.2 2008/11/23 23:40:12 heinz Exp $
|
||||
|
||||
- Add option "--with-embedded-src-path", default value is "yes" to keep
|
||||
the current behaviour.
|
||||
(already committed in unstable version upstream)
|
||||
|
||||
--- configure.orig 2007-01-20 13:30:22.000000000 +0100
|
||||
+++ configure
|
||||
@@ -128,6 +128,7 @@ WITH_OPTION nls yes "[yes | no]"
|
||||
WITH_OPTION memdebug no "[no | yes]"
|
||||
WITH_OPTION efence no "[no | yes]"
|
||||
WITH_OPTION logfile no "[no | yes]"
|
||||
+WITH_OPTION embedded-src-path yes "[yes | no]"
|
||||
|
||||
if test "$cfg_with_efence" == "yes"; then
|
||||
if ! CHECK_LIBRARY efence malloc efence; then
|
|
@ -1,37 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.2 2008/11/23 23:40:12 heinz Exp $
|
||||
|
||||
- Use SRCDIR only when configure option --with-embedded-src-path is set
|
||||
to yes.
|
||||
(already committed in unstable version upstream)
|
||||
|
||||
--- dvdisaster.c.orig 2007-01-20 16:44:59.000000000 +0100
|
||||
+++ dvdisaster.c
|
||||
@@ -159,10 +159,12 @@ int main(int argc, char *argv[])
|
||||
char *read_range = NULL;
|
||||
#ifdef WITH_NLS_YES
|
||||
char *locale_test;
|
||||
- #ifndef SYS_MINGW
|
||||
+ #ifdef WITH_EMBEDDED_SRC_PATH_YES
|
||||
+ #ifndef SYS_MINGW
|
||||
char src_locale_path[strlen(SRCDIR)+10];
|
||||
- #else
|
||||
+ #else
|
||||
char *bin_locale_path = NULL;
|
||||
+ #endif
|
||||
#endif
|
||||
#endif
|
||||
|
||||
@@ -245,9 +247,13 @@ int main(int argc, char *argv[])
|
||||
#ifndef SYS_MINGW
|
||||
/* Try local source directory first */
|
||||
|
||||
+#ifdef WITH_EMBEDDED_SRC_PATH_YES
|
||||
g_sprintf(src_locale_path,"%s/locale",SRCDIR);
|
||||
bindtextdomain("dvdisaster", src_locale_path);
|
||||
//printf("testing src %s\n", src_locale_path);
|
||||
+
|
||||
+#endif /* WITH_EMBEDDED_SRC_PATH_YES */
|
||||
+
|
||||
/* TRANSLATORS:
|
||||
This is a dummy entry which is supposed to translate into "ok".
|
||||
Please do not return anything else here. */
|
12
sysutils/dvdisaster/patches/patch-scsi-netbsd.c
Normal file
12
sysutils/dvdisaster/patches/patch-scsi-netbsd.c
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-scsi-netbsd.c,v 1.1 2012/02/04 21:57:54 shattered Exp $
|
||||
|
||||
--- scsi-netbsd.c.orig 2010-10-27 10:14:46.000000000 +0000
|
||||
+++ scsi-netbsd.c
|
||||
@@ -165,6 +165,7 @@ int SendPacket(DeviceHandle *dh, unsigne
|
||||
break;
|
||||
case DATA_NONE:
|
||||
sc.flags = 0;
|
||||
+ break;
|
||||
default:
|
||||
Stop("illegal data_mode: %d", data_mode);
|
||||
}
|
Loading…
Reference in a new issue