pull 2 patches from upstream:

-fix display of animated GIFs
-fix crash on certain sites
bump PKGREV
This commit is contained in:
drochner 2011-03-15 21:58:56 +00:00
parent 0e3f872365
commit 589a1b6ee5
4 changed files with 40 additions and 2 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.37 2011/02/11 05:37:07 obache Exp $ # $NetBSD: Makefile,v 1.38 2011/03/15 21:58:56 drochner Exp $
DISTNAME= webkit-1.2.7 DISTNAME= webkit-1.2.7
PKGNAME= ${DISTNAME:S/webkit/webkit-gtk/} PKGNAME= ${DISTNAME:S/webkit/webkit-gtk/}
PKGREVISION= 1
CATEGORIES= www CATEGORIES= www
MASTER_SITES= http://www.webkitgtk.org/ MASTER_SITES= http://www.webkitgtk.org/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.31 2011/03/14 00:15:32 wiz Exp $ $NetBSD: distinfo,v 1.32 2011/03/15 21:58:56 drochner Exp $
SHA1 (webkit-1.2.7.tar.gz) = e9afc573d2459794c3749ba404f2187f9dcc9ed3 SHA1 (webkit-1.2.7.tar.gz) = e9afc573d2459794c3749ba404f2187f9dcc9ed3
RMD160 (webkit-1.2.7.tar.gz) = f36b3ae05693e0eeb4d1936ceee52b6fe1517e57 RMD160 (webkit-1.2.7.tar.gz) = f36b3ae05693e0eeb4d1936ceee52b6fe1517e57
@ -8,3 +8,5 @@ SHA1 (patch-ad) = ef727a30bf78b747402a23fea7bddcc37d70e77d
SHA1 (patch-af) = 7971cf7d873703e17c002fa660a949f6f6d1c684 SHA1 (patch-af) = 7971cf7d873703e17c002fa660a949f6f6d1c684
SHA1 (patch-ag) = 0da0f8e1299ab061118e0338af521a1f07f4722b SHA1 (patch-ag) = 0da0f8e1299ab061118e0338af521a1f07f4722b
SHA1 (patch-ah) = 9e0178a9fe7175e29e16155bd190b852ced7d01f SHA1 (patch-ah) = 9e0178a9fe7175e29e16155bd190b852ced7d01f
SHA1 (patch-ba) = 6caffef625e9c04e971fbbd0763b4f9c834491e3
SHA1 (patch-bb) = 5e59576629e9ecfbbe576c3d0afe047bda449291

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ba,v 1.3 2011/03/15 21:58:56 drochner Exp $
--- WebCore/platform/image-decoders/gif/GIFImageDecoder.cpp.orig 2011-02-07 17:29:58.000000000 +0000
+++ WebCore/platform/image-decoders/gif/GIFImageDecoder.cpp
@@ -343,7 +343,7 @@ bool GIFImageDecoder::initFrameBuffer(un
if ((prevMethod == RGBA32Buffer::DisposeNotSpecified) || (prevMethod == RGBA32Buffer::DisposeKeep)) {
// Preserve the last frame as the starting state for this frame.
- if (!buffer->copyBitmapData(*prevBuffer));
+ if (!buffer->copyBitmapData(*prevBuffer))
return setFailed();
} else {
// We want to clear the previous frame to transparent, without
@@ -357,7 +357,7 @@ bool GIFImageDecoder::initFrameBuffer(un
return setFailed();
} else {
// Copy the whole previous buffer, then clear just its frame.
- if (!buffer->copyBitmapData(*prevBuffer));
+ if (!buffer->copyBitmapData(*prevBuffer))
return setFailed();
for (int y = prevRect.y(); y < prevRect.bottom(); ++y) {
for (int x = prevRect.x(); x < prevRect.right(); ++x)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-bb,v 1.3 2011/03/15 21:58:56 drochner Exp $
--- WebCore/platform/graphics/cairo/GraphicsContextCairo.cpp.orig 2010-09-10 13:20:33.000000000 +0000
+++ WebCore/platform/graphics/cairo/GraphicsContextCairo.cpp
@@ -184,6 +184,8 @@ static inline void drawPathShadow(Graphi
// Create suitably-sized ImageBuffer to hold the shadow.
OwnPtr<ImageBuffer> shadowBuffer = ImageBuffer::create(shadowBufferSize);
+ if (!shadowBuffer)
+ return;
// Draw shadow into a new ImageBuffer.
cairo_t* shadowContext = shadowBuffer->context()->platformContext();