py-yaml: do not use cython

This module doesn't support Cython 3. This is an open
issue since Jan 2022:
https://github.com/yaml/pyyaml/issues/601

Bump PKGREVISION.
This commit is contained in:
wiz 2023-11-13 16:34:01 +00:00
parent d1e22fccdd
commit 58a10a6812
4 changed files with 23 additions and 5 deletions

View File

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.29 2023/07/18 04:34:33 adam Exp $
# $NetBSD: Makefile,v 1.30 2023/11/13 16:34:01 wiz Exp $
DISTNAME= PyYAML-6.0.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/PyYAML/yaml/}
PKGREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_PYPI:=P/PyYAML/}
@ -10,7 +11,9 @@ HOMEPAGE= https://github.com/yaml/pyyaml
COMMENT= Collection of libraries to process YAML with Python
LICENSE= mit
DEPENDS+= ${PYPKGPREFIX}-cython-[0-9]*:../../devel/py-cython
# does not build with cython-3.x as of 6.0.1
# https://github.com/yaml/pyyaml/issues/601
#DEPENDS+= ${PYPKGPREFIX}-cython-[0-9]*:../../devel/py-cython
PYTHON_VERSIONS_INCOMPATIBLE= 27

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.7 2021/02/21 15:43:35 adam Exp $
@comment $NetBSD: PLIST,v 1.8 2023/11/13 16:34:01 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
@ -9,7 +9,6 @@ ${PYSITELIB}/_yaml/__init__.pyo
${PYSITELIB}/yaml/__init__.py
${PYSITELIB}/yaml/__init__.pyc
${PYSITELIB}/yaml/__init__.pyo
${PYSITELIB}/yaml/_yaml.so
${PYSITELIB}/yaml/composer.py
${PYSITELIB}/yaml/composer.pyc
${PYSITELIB}/yaml/composer.pyo

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.20 2023/07/18 04:34:33 adam Exp $
$NetBSD: distinfo,v 1.21 2023/11/13 16:34:01 wiz Exp $
BLAKE2s (PyYAML-6.0.1.tar.gz) = dac1c12e1cd5749e5de625592f08eedaa6a9618ae42d5e843e8e0cf3007a08d2
SHA512 (PyYAML-6.0.1.tar.gz) = 94a29924484f557c0966d485c2b70232909253f27fcea9b89e1db1462abf61f2f85d55fbae0177b2bed70eb5daa75813551e868df4df4cddfdee9a87bd08485f
Size (PyYAML-6.0.1.tar.gz) = 125201 bytes
SHA1 (patch-setup.py) = a0e8492719abfb58375d6ad2483cc7a2c5305496

View File

@ -0,0 +1,15 @@
$NetBSD: patch-setup.py,v 1.3 2023/11/13 16:34:01 wiz Exp $
Make sure cython is not found.
https://github.com/yaml/pyyaml/issues/601
--- setup.py.orig 2023-07-17 23:39:53.000000000 +0000
+++ setup.py
@@ -87,6 +87,7 @@ try:
except ImportError:
if with_cython:
raise
+with_cython = False
try:
from wheel.bdist_wheel import bdist_wheel